Bug 47808 - FILEOPEN particular (encrypted?) .DOCX via Filter Selection Dialog fails with "General Error."
Summary: FILEOPEN particular (encrypted?) .DOCX via Filter Selection Dialog fails with...
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: Other All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
Depends on:
Blocks:
 
Reported: 2012-03-24 10:22 UTC by allen
Modified: 2013-07-16 14:36 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
failing DOCX, believe created with Mac/Office 2011 (4.99 KB, application/vnd.ms-word.document.12)
2012-03-24 10:22 UTC, allen
Details

Note You need to log in before you can comment on or make changes to this bug.
Description allen 2012-03-24 10:22:55 UTC
Created attachment 58980 [details]
failing DOCX, believe created with Mac/Office 2011

Problem description: opening file returns error

Steps to reproduce:
1. save attachment from email to windows 7 desktop
2. double click
3. Specify file type as Libre doesn't know what it is automatically

LibreOffice 3.5.1.2 
Build ID: dc9775d-05ecbee-0851ad3-1586698-727bf66

Current behavior: specify Microsoft 2007/2010 XML returns error

Expected behavior:

Platform (if different from the browser): 
              
Browser: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:8.0) Gecko/20100101 Firefox/8.0
Comment 1 s-joyemusequna 2012-03-25 00:53:08 UTC
Confirmed with LibO 3.5.2 RC 1 on Windows XP. File is not recognized as a valid DOCX file by LibO. Word 2007 opens it without problems, file seems to be valid DOCX file. I had a look a it with 7 zip, the structure seems to be OK, but I can't open the stream "document.xml" as the compression is not supported by 7zip.

LibO 3.5.2 RC1 and LibO 3.4.5 open a filter selection, if I specify the file type DOCX => general error / IO error.

LibO 3.3.4, OOo 3.1 => general error / IO error (no file type selection).

It seems the compression type is not recognized by LibO.
Comment 2 s-joyemusequna 2012-03-25 01:03:06 UTC
The whole file seems to be encrypted.
Comment 3 Rainer Bielefeld Retired 2013-02-20 18:50:48 UTC
With Server Installation of "LibreOffice 3.5.1.2 English UI/Locale [Build-ID: dc9775d-05ecbee-0851ad3-1586698-727bf66] on German WIN7 Home Premium (64bit)  
I see problems like in "Bug 51194 -FILEOPEN password encrypted .docx and .xlsx fails, opens Filter Selection dialog". 

And as per comment 1 I see the General Error when I continue 

This one has nothing to do with Bug 43246

The "General Error" Problem already exists in LibO 3.3.3 and AOOo 3.4.0, so I believe this one is inherited from OOo.

I add "Bug 51194" related for now 

@Michael:
What do you think, is this a more general problem for al MSO ...x document or will we have to handle Writer and Calc separately?
Comment 4 Rainer Bielefeld Retired 2013-02-20 18:58:28 UTC
Currently I see this one more as an Enhencement Request.
Comment 5 ign_christian 2013-07-16 02:39:53 UTC
I can confirm that file can be opened without problem with LO 4.0.4.2 (Win7 32bit), just like with Word 2007 as stated on comment 1.

Perhaps there is another problem that I didn't see, please REOPENED
Comment 6 allen 2013-07-16 14:16:27 UTC
Opens for me, I will close ticket, good job somebody!
Comment 7 Michael Stahl (allotropia) 2013-07-16 14:25:56 UTC
please only set to FIXED if you know which commit fixed the bug.

since according to comment #5 it works in the 4.0 branch and
all older branches are unsupported now there isn't anything to backport to anyway.
Comment 8 allen 2013-07-16 14:36:03 UTC
(In reply to comment #7)
> please only set to FIXED if you know which commit fixed the bug.
> 
> since according to comment #5 it works in the 4.0 branch and
> all older branches are unsupported now there isn't anything to backport to
> anyway.


Ok, I don't know which commit/version fixed problem.