Bug Hunting Session
Bug 60386 - Document Statistics shell extension not translated
Summary: Document Statistics shell extension not translated
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
3.6.0.0.alpha1
Hardware: x86-64 (AMD64) Windows (All)
: medium minor
Assignee: David Tardon
URL:
Whiteboard: target:4.1.0 target:3.6.6 target:4.0.1
Keywords: regression
: 59324 (view as bug list)
Depends on:
Blocks:
 
Reported: 2013-02-07 01:21 UTC by Cthulhux
Modified: 2013-02-13 12:31 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
Screenshot of the prefs page (34.87 KB, image/png)
2013-02-07 01:21 UTC, Cthulhux
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Cthulhux 2013-02-07 01:21:42 UTC
Created attachment 74314 [details]
Screenshot of the prefs page

I use LO 4.0.0 (the "final" version 4.0.0.3) on Windows 7, 64-bit, in German. The shell extension that creates the "Document Statistics" preferences page is always in English (see attachment). I guess some translation is missing here.
Comment 1 Andras Timar 2013-02-07 17:23:20 UTC
It has been wrong since gbuildification. Translations do not get into the .res/.dll.
Comment 2 Andras Timar 2013-02-11 08:41:50 UTC
*** Bug 59324 has been marked as a duplicate of this bug. ***
Comment 3 David Tardon 2013-02-13 09:35:16 UTC
Oops... It seems I forgot to run ulfex on the .ulf file. And there is at least one more occurence of the same problem, in crashrep.
Comment 4 Not Assigned 2013-02-13 10:00:27 UTC
David Tardon committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=fc65a66de972951946c57c8b01bfd5df46633693

fdo#60386 fix l10n of windows shell extension



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 5 Not Assigned 2013-02-13 10:06:33 UTC
David Tardon committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=5e10c8d2b44f38df0a1a805f4ad6b6610eabecdf

fdo#60386 fix l10n of windows shell extension



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 6 Not Assigned 2013-02-13 12:31:23 UTC
David Tardon committed a patch related to this issue.
It has been pushed to "libreoffice-3-6":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=d13a9d558b5f5bf4c0c29787160878ab5ac9918d&h=libreoffice-3-6

fdo#60386 fix l10n of windows shell extension


It will be available in LibreOffice 3.6.6.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 7 Not Assigned 2013-02-13 12:31:44 UTC
David Tardon committed a patch related to this issue.
It has been pushed to "libreoffice-4-0":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=a648103cfc0c4d51f2ad929d9514561e47106a9e&h=libreoffice-4-0

fdo#60386 fix l10n of windows shell extension


It will be available in LibreOffice 4.0.1.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.