Bug 60433 - Libvisio: Import Page Names from Visio
Summary: Libvisio: Import Page Names from Visio
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Draw (show other bugs)
Version:
(earliest affected)
4.0.0.3 release
Hardware: All All
: low enhancement
Assignee: Fridrich Strba
URL:
Whiteboard: BSA target:4.1.0 target:4.0.1
Keywords:
Depends on:
Blocks:
 
Reported: 2013-02-07 17:52 UTC by Lee
Modified: 2013-12-15 23:41 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Screenshot of layout. (161.96 KB, image/png)
2013-02-07 17:52 UTC, Lee
Details
Zip file containing the visio and OO Draw document source files. (491.55 KB, application/zip)
2013-02-19 15:26 UTC, Lee
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Lee 2013-02-07 17:52:23 UTC
Created attachment 74367 [details]
Screenshot of layout.

I have a 4 page visio document. the first 3 page are setup as landscape legal with the last one landscape A4.

In Draw when I look at the Format->Page for all pages the format is user, Width 101.92cm, Height 72.06cm orientation Portrait (even though in the pages list and the main editing area the page is obviously landscape.)

In addition, the names of the pages (which are on the tabs in Visio) do not show up anywhere in Draw that I can see.


Operating System: Windows 7
Version: unspecified
Comment 1 Julien Nabet 2013-02-17 00:02:50 UTC
Could you attach the Visio file?
Comment 2 Valek Filippov 2013-02-18 22:33:08 UTC
AFAIK LO Draw doesn't support different page sizes in the same document.
To workaround mixed page sizes/orientation situation libvisio generates pages of the largest H and W.

I think at the moment libvisio ignores page names part.

To my taste both are good for feature requests.
Comment 3 Lee 2013-02-19 15:07:15 UTC
I'll try to sanitize the document. I can't attach it as it is due to confidential information.
Comment 4 Lee 2013-02-19 15:26:19 UTC
Created attachment 75117 [details]
Zip file containing the visio and OO Draw document source files.
Comment 5 Lee 2013-02-19 15:32:18 UTC
(In reply to comment #2)
> AFAIK LO Draw doesn't support different page sizes in the same document.
> To workaround mixed page sizes/orientation situation libvisio generates
> pages of the largest H and W.
> 
> I think at the moment libvisio ignores page names part.
> 
> To my taste both are good for feature requests.

If that is indeed the case, how do I change this to a feature request?
Comment 6 Fridrich Strba 2013-02-19 15:54:44 UTC
As for the page sizes, Valek is completely right. Concerning the page names, it should not be difficult to add provided we know how to extract that information from a binary visio file.
Comment 7 Lee 2013-02-19 23:31:20 UTC
(In reply to comment #6)
> As for the page sizes, Valek is completely right. Concerning the page names,
> it should not be difficult to add provided we know how to extract that
> information from a binary visio file.

Can the page size bit be put in as a feature request then?
Comment 8 Valek Filippov 2013-02-20 01:04:51 UTC
> Can the page size bit be put in as a feature request then?

I would suggest to check if something similar was already filed for Draw.
(It should be improved on the Draw side first, fix for libvisio/libcdr wouldn't be difficult).
Comment 9 Joel Madero 2013-02-21 20:30:54 UTC
I am going to make this the enhancement request for names of Visio pages. Please open another enhancement request for the page issue if you don't find one already filed. 

Thanks!
Comment 10 Fridrich Strba 2013-02-22 14:20:20 UTC
OK, page names are now extracted and passed to the API in git master of libvisio. For all file-formats. Concerning the page sizes, libvisio does the right thing, the fix has to be in Draw, in a zone that is very regression-prone. I don't hold my breath to have time to do it for 4.1 even. The page names fix should go to 4.0.2. I don't feel too comfortable to make it part of 4.0.1 during the RC phase we just have, but maybe I become a bit more nuts during the weekend.
Comment 11 Lee 2013-02-22 17:13:42 UTC
Thank you very much! You guys have really been responsive on this! 
I added a feature request as well and put it in the 'See Also:'
Comment 12 Joel Madero 2013-02-22 18:25:12 UTC
@Lee - thanks for reporting the other one.

Also, if you're interested in helping QA triage bugs so that all bugs go as smoothly as yours, please feel free to join our team as we could really use the help.

E-Mail me directly if you'd like to get involved :)
Comment 13 Not Assigned 2013-02-25 09:56:06 UTC
Fridrich Å trba committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=392691c91fbfa96f1805f1cd556dc115b9a486e3

Uploading libvisio-0.0.25 fixing fdo#60433



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 14 Not Assigned 2013-02-25 10:18:41 UTC
Fridrich Å trba committed a patch related to this issue.
It has been pushed to "libreoffice-4-0":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=0f203c99fac3778500dbf664e34ac4cd2d6455de&h=libreoffice-4-0

Uploading libvisio-0.0.25 fixing fdo#60433


It will be available in LibreOffice 4.0.2.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 15 Not Assigned 2013-02-25 10:29:59 UTC
Fridrich Å trba committed a patch related to this issue.
It has been pushed to "libreoffice-4-0-1":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=9381144656fa57b020490d12f27d003436db4643&h=libreoffice-4-0-1

Uploading libvisio-0.0.25 fixing fdo#60433


It will be available already in LibreOffice 4.0.1.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 16 Rainer Bielefeld Retired 2013-04-10 05:45:20 UTC
Modified Assignee due to facts to ease finding of experts via Bugzilla