Bug 60469 - : Wrong "formulas formating" from excel 2010
Summary: : Wrong "formulas formating" from excel 2010
Status: NEW
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords: filter:xlsx
: 128385 (view as bug list)
Depends on:
Blocks: xlsx-aggressive-competitors
  Show dependency treegraph
 
Reported: 2013-02-08 06:25 UTC by Honza
Modified: 2021-08-10 22:42 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
Example of the problem (23.10 KB, application/vnd.openxmlformats-officedocument.spreadsheetml.sheet)
2013-02-08 06:25 UTC, Honza
Details
Screenshot result (115.16 KB, image/png)
2013-02-09 00:35 UTC, m.a.riosv
Details
Problem comparison of MSO and LO (162.40 KB, image/png)
2013-03-31 21:39 UTC, Honza
Details
Comparison of LO and MSO (162.40 KB, image/png)
2013-03-31 21:42 UTC, Honza
Details
Formulas changes (5.06 KB, application/vnd.oasis.opendocument.formula)
2013-04-01 15:24 UTC, Jacques Guilleron
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Honza 2013-02-08 06:25:27 UTC
Created attachment 74405 [details]
Example of the problem

Problem description: 
If I open a spreadsheet from Excel 2010 and there are some formulas made in formula editor (not the once that excel uses for calculations but just to show what excel is calculating to others) for example fractions, subscripts of some unknowns etc doesnt show as it is supposed to for example "Fcd" (CD is lower subscript) is showed as: "f_cd" - just like that.

In writer all the formulas seem to be right...

I am using Version 4.0.0.3 (Build ID: 7545bee9c2a0782548772a21bc84a9dcc583b89) portable
Operating System: Windows 7
Version: unspecified
Comment 1 m.a.riosv 2013-02-09 00:35:53 UTC
Created attachment 74459 [details]
Screenshot result

Hi Honza, thanks for reporting.

I can not reproduce it.
Win7x64 Ultimate.
Version 4.0.0.3 (Build ID: 7545bee9c2a0782548772a21bc84a9dcc583b89)

Attached screenshoot about how it looks.

Have you installed the calibri font?.
Have you tried to reset the user profile?, sometimes solved strange issues.
https://wiki.documentfoundation.org/UserProfile
Comment 2 A (Andy) 2013-03-29 22:10:37 UTC
This specific issue is not reproducible with LO 4.0.1.2 (Win7 Home, 64bit), but comparing MSO 2007 and LO shows, that LO does not correctly import this file (borders, alignment, etc.).
Comment 3 Honza 2013-03-31 21:39:35 UTC
Created attachment 77259 [details]
Problem comparison of MSO and LO
Comment 4 Honza 2013-03-31 21:42:05 UTC
Created attachment 77260 [details]
Comparison of LO and MSO
Comment 5 Jacques Guilleron 2013-04-01 15:19:13 UTC
Hello Honza,

I reproduce the screenshot result of Mariosv with LO 4.0.2.1 and your screenshot comparison of LO with LO 4.0.3.0+ (Build ID: 64a3b58a9ace11c6a01708e8de14712e27e0204).
The main issue is the enormus line height of Cambria Math font, used by formula editor, which allows only seven lines per page.
A second issue is what is imported. This is the script for MS equation editor, not the equation itself, which is not the same than the one used by LO.
Some changes have to be made to get the correct result.

Have a nice day,

Jacques Guilleron
Comment 6 Jacques Guilleron 2013-04-01 15:24:21 UTC
Created attachment 77275 [details]
Formulas changes

What is to get.

Jacques Guilleron
Comment 7 QA Administrators 2015-04-19 03:20:32 UTC Comment hidden (obsolete)
Comment 8 Buovjaga 2015-06-15 12:28:13 UTC
(In reply to Honza from comment #3)
> Created attachment 77259 [details]
> Problem comparison of MSO and LO

Confirmed.

Win 7 Pro 64-bit Version: 5.1.0.0.alpha1+
Build ID: 01a189abcd9a4ca472a74b3b2c000c9338fc2c91
TinderBox: Win-x86@39, Branch:master, Time: 2015-06-14_07:46:28
Locale: fi-FI (fi_FI)
Comment 9 QA Administrators 2016-09-20 10:01:04 UTC Comment hidden (obsolete)
Comment 10 raal 2018-06-12 17:41:32 UTC
better, but still reproducible. LO 6.2 , Linux
Comment 11 QA Administrators 2019-10-25 02:41:03 UTC Comment hidden (obsolete)
Comment 12 NISZ LibreOffice Team 2021-07-14 13:17:32 UTC
*** Bug 128385 has been marked as a duplicate of this bug. ***