Bug 60537 - VIEWING: Corrupt characters in LibreOffice 4 with Nouveau
Summary: VIEWING: Corrupt characters in LibreOffice 4 with Nouveau
Status: VERIFIED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.0.0.3 release
Hardware: Other Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: BSA (target:4.0.1)
Keywords: regression
: 60840 (view as bug list)
Depends on:
Blocks:
 
Reported: 2013-02-09 10:00 UTC by josealb
Modified: 2013-03-11 15:57 UTC (History)
8 users (show)

See Also:
Crash report or crash signature:


Attachments
Characters messed up after scrolling up and down in the LivreOffice 4 help (516.34 KB, image/png)
2013-02-09 10:00 UTC, josealb
Details

Note You need to log in before you can comment on or make changes to this bug.
Description josealb 2013-02-09 10:00:57 UTC
Created attachment 74479 [details]
Characters messed up after scrolling up and down in the LivreOffice 4 help

Problem description: 
Hello,

I'm using Linux Mint 14 x64 MATE kernel 3.5.0-17, with a NVIDIA GTX 460 graphic card and the nouveau driver. When I scroll up or down in LibreOffice 4 writer the most of the characters mess up or dissapear. The same happens if I select a wide zone with the mouse. If I minimize the window and restore it the characters are well displayed, but if I scroll again all mess up again. Nevertheless with LibreOffice 3.6.4 it doesn't happen, it just happen in LibreOffice 4.

Using the NVIDIA privative drivers it is solved, but these drivers doesn't work well with other applications I use, so using the NVIDIA privative drivers is not a solution for my problem.

How do I fix this problem in LibreOffice 4?

Steps to reproduce:
1. Open LibreOffice writer 4.0.0.3 release
2. Go to help > LibreOffice help
3. Scroll up and down

Current behavior: help text's characters mess up

Expected behavior: you should be able to read the help flawlessly scrolling up or down

              
Operating System: Linux (Other)
Version: 4.0.0.3 release
Last worked in: 3.6.4.3 release
Comment 1 Michael Stahl (CIB) 2013-02-12 13:02:18 UTC
hmm.. works-for-me but i've only got Intel gfx...

can QA please check if this happens on anything other than
Linux with Nouveau driver?  if not it's probably some driver bug.
Comment 2 Rainer Bielefeld Retired 2013-02-12 15:36:17 UTC
I'm sorry, can't test, no suitable machine available.

@josealb
Do you always see that damages or is the problem related to 1 of the settings in menu Tools -> Options 
-> LibO -> Viewing -> Hardware Acceleration
-> LibO -> Viewing -> Anti Aliasing
-> Writer -> View -> Smooth Scroll
?
Comment 3 josealb 2013-02-12 21:54:29 UTC
(In reply to comment #1)
> hmm.. works-for-me but i've only got Intel gfx...
> 
> can QA please check if this happens on anything other than
> Linux with Nouveau driver?  if not it's probably some driver bug.

I've got Intel graphics in my laptop too and there work well. Neither happens when I use the NVIDIA privative graphics instead Nouveau in the same PC. It just happens when I use Nouveau. But using LibreOffice 3.6.4 with Nouveau it doesn't happen.
Comment 4 josealb 2013-02-12 21:58:21 UTC
(In reply to comment #2)
> I'm sorry, can't test, no suitable machine available.
> 
> @josealb
> Do you always see that damages or is the problem related to 1 of the
> settings in menu Tools -> Options 
> -> LibO -> Viewing -> Hardware Acceleration
> -> LibO -> Viewing -> Anti Aliasing
> -> Writer -> View -> Smooth Scroll
> ?

I didn't have Smooth Scroll activated, and switching Hardware Acceleration and Anti Aliasing > on on, on off, off on, and off off didn't changed anything including rebooting. Including switching on Smooth Scroll, I've tried out all possible combinations but nothing changed.
Comment 5 Joel Madero 2013-02-12 22:01:45 UTC
Indeed never have seen this behavior with my intel card. It would be a strange driver bug but...who knows. 


josealb - would you be willing to help us with a bibisect if we walk you through it? That would maybe identify the issue
Comment 7 josealb 2013-02-12 22:10:44 UTC
(In reply to comment #5)
> Indeed never have seen this behavior with my intel card. It would be a
> strange driver bug but...who knows. 
> 
> 
> josealb - would you be willing to help us with a bibisect if we walk you
> through it? That would maybe identify the issue

Yes, of course. From where do I begin?
Comment 8 Joel Madero 2013-02-12 22:21:25 UTC
that link I put has pretty good instructions. Download the bibisect40bugs package and follow the instructions there, if you have questions feel free to email me directly or ping me to chat on IRC (jmadero) on #libreoffice-qa
Comment 9 josealb 2013-02-12 22:29:44 UTC
(In reply to comment #8)
> that link I put has pretty good instructions. Download the bibisect40bugs
> package and follow the instructions there, if you have questions feel free
> to email me directly or ping me to chat on IRC (jmadero) on #libreoffice-qa

(In reply to comment #8)
> that link I put has pretty good instructions. Download the bibisect40bugs
> package and follow the instructions there, if you have questions feel free
> to email me directly or ping me to chat on IRC (jmadero) on #libreoffice-qa

Ok, thank you. But I'm sorry because it's late and I have lots of things to do tomorrow. I will try my best in my free time and as soon as I get stuck or get something good I will let you know. See you!
Comment 10 Michael Stahl (CIB) 2013-02-20 10:02:35 UTC
*** Bug 60840 has been marked as a duplicate of this bug. ***
Comment 11 josealb 2013-02-20 17:44:58 UTC
I'm sorry but my day by day is becoming more full of things to do each day. I don't know when am I going to be able to do the bibisect. It's possible that I won't be able until summer. So, I invite anyone who may suffer this bug too to do the bibisect as I don't know when am I going to have some time to try it out.
Sorry and thank you for your help. Bye.
Comment 12 cm20 2013-02-21 10:19:59 UTC
it seems that the mess only occure when in view>draft layout mode. since i mostly work in draft mode, i didn't realise of that before. sorry.

there is no character mess when scrolling in print layout mode. but still some strange effects occure! 
when scrolling part of the text is getting not visible and appears not until by mouse the cursor is set to a new place. (print layout mode+use hardware acc=off+use anti-aliasing=off+smooth scroll=off). this also happens when playing with the viewing options.

i also use the Nouveau driver. since i did kill my system when using a different nvidia driver, i'm not shure what i should do now. i would be grateful to use opensuse and LO out off the box :-)
thanks.

35: PCI 100.0: 0300 VGA compatible controller (VGA)
  [Created at pci.319]
  Unique ID: VCu0.xhxICrT5JnD
  Parent ID: vSkL.kA6er9hJ5O0
  SysFS ID: /devices/pci0000:00/0000:00:01.0/0000:01:00.0
  SysFS BusID: 0000:01:00.0
  Hardware Class: graphics card
  Model: "nVidia G92 [GeForce 9800 GT]"
  Vendor: pci 0x10de "nVidia Corporation"
  Device: pci 0x0614 "G92 [GeForce 9800 GT]"
  SubVendor: pci 0x1043 "ASUSTeK Computer Inc."
  SubDevice: pci 0x82d5 
  Revision: 0xa2
  Driver: "nouveau"
  Driver Modules: "drm"
  Memory Range: 0xfd000000-0xfdffffff (rw,non-prefetchable)
  Memory Range: 0xd0000000-0xdfffffff (ro,non-prefetchable)
  Memory Range: 0xfa000000-0xfbffffff (rw,non-prefetchable)
  I/O Ports: 0xcc00-0xcc7f (rw)
  Memory Range: 0xfe8e0000-0xfe8fffff (ro,non-prefetchable,disabled)
  IRQ: 16 (315 events)
  I/O Ports: 0x3c0-0x3df (rw)
  Module Alias: "pci:v000010DEd00000614sv00001043sd000082D5bc03sc00i00"
  Driver Info #0:
    Driver Status: nvidiafb is not active
    Driver Activation Cmd: "modprobe nvidiafb"
  Driver Info #1:
    Driver Status: nouveau is active
    Driver Activation Cmd: "modprobe nouveau"
  Config Status: cfg=no, avail=yes, need=no, active=unknown
  Attached to: #17 (PCI bridge)
Comment 13 Caolán McNamara 2013-02-21 10:49:43 UTC
FWIW I have a nouveau driver as well on Fedora 18 and see none of these effects, so I think you should report this directly to opensuse so that some devs/maintainers on their side that have the same versions of driver, pixman, cairo, etc. as you etc can attempt to reproduce this and isolate what is the offending components.
Comment 14 cm20 2013-02-21 10:54:19 UTC
i have already reported this bug to novell/suse under
https://bugzilla.novell.com/show_bug.cgi?id=796512
Comment 15 josealb 2013-03-08 16:38:38 UTC
SOOOOOOLVED. I don't know what have you done but with the 4.0.1.2 version release I can see all the things right. Thank you.
Comment 16 Jorendc 2013-03-08 17:00:09 UTC
(In reply to comment #15)
> SOOOOOOLVED. I don't know what have you done but with the 4.0.1.2 version
> release I can see all the things right. Thank you.

Thanks for your feedback!

Therefore I mark this as RESOLVED WORKSFORME.
Can anyone who also issued this bug mark it as VERIFIED WORKSFORME if he/she can't reproduce it anymore?

Thanks in advance,
Joren
Comment 17 cm20 2013-03-11 09:14:38 UTC
using Version 4.0.1.2 (Build ID: 84102822e3d61eb989ddd325abf1ac077904985)
it works with:
print layout mode=on
use hardware acc=on
use anti-aliasing=on
smooth scroll=on

seems to be done?
thanks a lot!
Comment 18 Rainer Bielefeld Retired 2013-03-11 15:57:49 UTC
added target WFM info