Bug 60840 - VIEWING: vertical scroll error
Summary: VIEWING: vertical scroll error
Status: RESOLVED DUPLICATE of bug 60537
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.0.0.3 release
Hardware: Other Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords: regression
Depends on:
Blocks:
 
Reported: 2013-02-14 12:41 UTC by cm20
Modified: 2013-02-20 10:21 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
LO 4.0 scroll error character mess up (211.57 KB, image/png)
2013-02-20 06:49 UTC, cm20
Details
hwinfo from openSUSE-12.2 system where the problem did not happen (1.12 KB, text/plain)
2013-02-20 10:21 UTC, Petr Mladek
Details

Note You need to log in before you can comment on or make changes to this bug.
Description cm20 2013-02-14 12:41:15 UTC
Problem description: 
when vertical scrolling, text will not be represented correct.

Steps to reproduce:
1. ....installing rpm on opensuse12.2 with kde
2. ....scrolling document with vertical slider

Current behavior:
text will not be displayed correct

Expected behavior:
scrolling should work


i had this problem with earlier versions already. with NOT installing the KDE-integration, it works until 3.6.5.2
now with LO4.0 the error happens even when KDE-integration is not installed.

Operating System: openSUSE
Version: 4.0.0.3 release
Last worked in: 3.6.5.2 release
Comment 1 Michael Stahl (allotropia) 2013-02-19 14:25:08 UTC
can't see any scrolling problem on Fedora 18.

does your problem look something like this screenshot:
https://bugs.freedesktop.org/attachment.cgi?id=74479

which is from bug 60537.

can somebody check this on openSuSE?
Comment 2 cm20 2013-02-20 06:49:17 UTC
Created attachment 75160 [details]
LO 4.0 scroll error character mess up
Comment 3 cm20 2013-02-20 07:06:32 UTC
Comment on attachment 75160 [details]
LO 4.0 scroll error character mess up

it seems to be the same than in bug 60537 https://bugs.freedesktop.org/show_bug.cgi?id=60537

can i send some more infos? what infos?
thanks
Comment 4 Thomas Arnhold 2013-02-20 07:35:14 UTC
Did you follow Rainers hints (https://bugs.freedesktop.org/show_bug.cgi?id=60537#c2)?

If you think your bug is an duplicate or you can reproduce them same error as described in the other bug please mark your bug as duplicate.
Comment 5 Michael Stahl (allotropia) 2013-02-20 10:02:35 UTC
that definitely looks like a duplicate.

please provide some info on the graphics driver you use.
especially whether you use the Nouveau driver.

you can find out by looking at /var/log/Xorg.0.log

*** This bug has been marked as a duplicate of bug 60537 ***
Comment 6 Petr Mladek 2013-02-20 10:21:49 UTC
Created attachment 75166 [details]
hwinfo from openSUSE-12.2 system where the problem did not happen

Hmm, I am not able to reproduce this. I tried it on openSUSE-12.2, x86_64, KDE4, with both upstream and SUSE-specific 4.0.0.3 builds.

To be honest, I saw some artifacts when the screen was being repainted but I newer seen any artifact when I stopped scrolling and repainting finished.

It seems that I use the potentially problematic Nouveau driver. See the attached hwinfo for more details.

I guess that the problem happens only with a specific combination of the graphics card and driver.