Download it now!
Bug 60716 - 0^0=1 - Zero power zero equal one
Summary: 0^0=1 - Zero power zero equal one
Status: RESOLVED NOTABUG
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
4.0.0.3 release
Hardware: Other All
: medium major
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
: 63231 (view as bug list)
Depends on:
Blocks:
 
Reported: 2013-02-12 09:15 UTC by Timon
Modified: 2013-04-07 14:23 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Timon 2013-02-12 09:15:49 UTC
It's well known that 0^0 doesn't exist, but LibO says that 0^0=1

The ODF 1.2 standard says 0^0 shall be 0, 1 or an Error. The choice is implementation-defined.

To see the bug in LibO, just put =0^0 in a cell.

MS Excel in this case gives #NUM!

AOO developers are trying to solve the same problem https://issues.apache.org/ooo/show_bug.cgi?id=114430
Comment 1 Thomas van der Meulen 2013-02-12 12:55:46 UTC
Thank you for reporting this bug, 
I can reproduce this bug running LibreOffice on Mac os x 10.6.8.
Comment 2 Norbert Thiebaud 2013-02-16 22:22:15 UTC
"It's well known that 0^0 doesn't exist"
it is not well known that 0^0 does not exist. in fact Euler in ~1740 already defined it to be 1. 0^0 is an indeterminate 'form' in the context of extension by continuity of multi-variables functions... but that is only in that narrow specific sub-set of Math that 0^0 is considered an indeterminate 'form'...
but in many other area of mathematics the convention of 0^0 = 1 is useful and commonly used.

so

1/ The ODF standard allow for 0^0=1
2/ Changing that would break backward compatibility as LibreOffice, OpenFoffice and StarOffice have always returned 1 for 0^0

WAD
Comment 3 Arnaud Versini 2013-04-07 14:23:04 UTC
*** Bug 63231 has been marked as a duplicate of this bug. ***