Bug Hunting Session
Bug 60855 - RTL UI: handout show boxes out of page border
Summary: RTL UI: handout show boxes out of page border
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
3.3.0 release
Hardware: Other All
: medium normal
Assignee: Faisal Menawer
URL: https://issues.apache.org/ooo/show_bu...
Whiteboard: target:4.1.0 target:4.0.3
Keywords:
Depends on:
Blocks: RTL-CTL
  Show dependency treegraph
 
Reported: 2013-02-14 18:49 UTC by Lior Kaplan
Modified: 2013-03-14 13:25 UTC (History)
0 users

See Also:
Crash report or crash signature:


Attachments
handout in LTR locale (82.60 KB, image/png)
2013-02-14 18:50 UTC, Lior Kaplan
Details
handout in RTL locale (83.66 KB, image/png)
2013-02-14 18:51 UTC, Lior Kaplan
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Lior Kaplan 2013-02-14 18:49:07 UTC
Reporting i#114386 against LibO. Verified the bug still exists in 4.0.0.

The problem is that is RTL locale (Hebrew, Arabic...) the handout tab shows the boxes (3, 6, 9 slides per page) partly out of page border. See screen shots.

Notice this isn't related to the UI directionality, but to the system locale is the cause. Setting LC_CTYPE=he_IL.UTF-8 is enough to trigger the bug.
Comment 1 Lior Kaplan 2013-02-14 18:50:50 UTC
Created attachment 74830 [details]
handout in LTR locale
Comment 2 Lior Kaplan 2013-02-14 18:51:08 UTC
Created attachment 74831 [details]
handout in RTL locale
Comment 3 Not Assigned 2013-02-25 08:07:40 UTC
Faisal M. Al-Otaibi committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=12de9b3361236e1d6c931409cf0ad0d4f9924008

Fix fdo#60855 RTL UI: handout show boxes out of page border



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 4 Lior Kaplan 2013-03-07 14:43:51 UTC
Verified on master build.
Comment 5 Commit Notification 2013-03-14 13:25:48 UTC
Faisal M. Al-Otaibi committed a patch related to this issue.
It has been pushed to "libreoffice-4-0":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=cbfcc02027b64f71b2d888e438a2e964d9da0f50&h=libreoffice-4-0

Fix fdo#60855 RTL UI: handout show boxes out of page border


It will be available in LibreOffice 4.0.3.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.