Bug Hunting Session
Bug 61030 - FORMATTING: Synchronize for Business Cards has no effect
Summary: FORMATTING: Synchronize for Business Cards has no effect
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
3.6.5.2 release
Hardware: All Windows (All)
: high normal
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
Depends on:
Blocks: Labels-BusinessCards
  Show dependency treegraph
 
Reported: 2013-02-17 22:52 UTC by Jack Gildar
Modified: 2019-10-19 17:51 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jack Gildar 2013-02-17 22:52:03 UTC
Problem description: In Mac OS 10.8.2, when creating Business Cards the sychronize button appears, but no effect when clicking on it.

Steps to reproduce:
1. File - New - Business Cards
2. Enter appropriate business information....
3. Click Create New Document
4. Nothing happens.  Single Business Card does not populate multiple business cards

Current behavior: see above

Expected behavior: see above

              
Operating System: Mac OS X
Version: 4.0.0.3 release
Comment 1 Joel Madero 2013-04-14 18:34:52 UTC
Thank you for reporting this issue! I have been able to confirm the issue on:
Version 3.6.5.2 
Platform: Bodhi Linux 2.2 x64
+ + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + 
As I've been able to confirm this problem on an earlier release I am changing the version number as version is the earliest version that we can confirm the bug, we use comments to say that the bug exists in newer versions as well.

Marking as:

New (confirmed)
Normal - Prevents high quality/professional work
High - seems like the entire business card creation method is broken. Not sure if it ever worked correctly

+ + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + 
LibreOffice is powered by a team of volunteers, every bug is confirmed (triaged) by human beings who mostly give their time for free. We invite you to join our triaging by checking out this link:
https://wiki.documentfoundation.org/QA/BugTriage

There are also other ways to get involved including with marketing, UX, documentation, and of course developing -  http://www.libreoffice.org/get-help/mailing-lists/. 

Lastly, good bug reports help tremendously in making the process go smoother, please always provide reproducible steps (even if it seems easy) and attach any and all relevant material
Comment 2 Thomas Hackert 2014-01-12 17:54:56 UTC
Hello Jack, *,
I can confirm, that this bug still exists with LO Version: 4.2.0.2 Build ID: 601a398b803303d1a40a3299729531824fe0db56 and installed Germanophone lang- as well as helppack under Debian Testing AMD64 ... :( Though I did a slightly different approach, the result is the same ... :( What I did differently:
1. Started LO
2. Chose "File – New – Labels"
3. Selected a database from my MariaDB RDBMS on the tab "Labels" from the dropdown menu below "Database" on the right
4. Selected a table from it from the dropdown menu below "Table"
5. Selected a "Database field"
6. Chose a "Brand" (I decided to use "Avery A4")
7. Chose a "Type" ("C2160 Avery Inkjet Label")
8. Clicked on "New Document"
After I freshly installed the above mentioned version, I got a window, where I could choose between business and private labels. Then this empty Writer document without any text in it opened, but only the frames of labels were visible. Now, after I have closed LO a couple of times to switch the UI language between German to English and back, I am not even able to open Writer to create a sheet of labels. It just freezes ... :(
HTH
Thomas.
Comment 3 Alex Thurgood 2015-01-03 17:40:12 UTC
Adding self to CC if not already on
Comment 4 QA Administrators 2016-01-17 20:02:24 UTC Comment hidden (obsolete)
Comment 5 Alex Thurgood 2016-01-19 12:46:27 UTC
Version: 5.0.3.2
Build ID: e5f16313668ac592c1bfb310f4390624e3dbfb75
Locale : fr-FR (fr.UTF-8)

Still present
Comment 6 QA Administrators 2017-03-06 13:53:26 UTC Comment hidden (obsolete)
Comment 7 sam.hoskins 2017-06-28 12:38:16 UTC
Problem description: In Windows 10, when creating Business Cards the synchronize button appears, but no effect when clicking on it.

Steps to reproduce:
1. File - New - Business Cards
2. Enter appropriate business information....
3. Click Create New Document
4. Document appears along with Synchronize button.
4. Click on Synchronize. Nothing happens.
Comment 8 sam.hoskins 2017-06-28 12:44:22 UTC
Version: 5.2.7.2
Build ID: 2b7f1e640c46ceb28adf43ee075a6e8b8439ed1

Problem description: In Windows 10, when creating Business Cards the synchronize button appears, but no effect when clicking on it.

Steps to reproduce:
1. File - New - Business Cards
2. Enter appropriate business information....
3. Click Create New Document
4. Document appears along with Synchronize button.
4. Click on Synchronize. Nothing happens.
Comment 9 Laurent BP 2018-06-06 21:07:30 UTC
(In reply to sam.hoskins from comment #8)
> Version: 5.2.7.2
> Build ID: 2b7f1e640c46ceb28adf43ee075a6e8b8439ed1
I cannot reproduce with Version: 5.2.7.2
Build ID: 2b7f1e640c46ceb28adf43ee075a6e8b8439ed10
Threads CPU : 8; Version de l'OS :Linux 4.13; UI Render : par défaut; VCL : gtk2; 
Locale : fr-FR (fr_FR.UTF-8); Calc: group

You need to modify label size to get several business cards on the same page. Otherwise, there is only 1 business card and "Synchronize" button has no effect.

Modified procedure:
1. File > New > Business Cards > Format
2. Try these settings:
    Horizontal pitch = 10cm
    Vertical pitch = 5cm
    Width = 10cm
    Height = 5cm
    Left margin = 0.5cm
    Top margin = 1cm
    Columns = 2
    Rows = 5
    Page width = 20.5cm
    Page height = 26cm
3. "New document" button
4. Type some text in the most top left business card
5. Hit "Synchronize Labels"

Actual and Expected behavior
Text of the 1st business card is copied in the 9 other business cards
Comment 10 QA Administrators 2019-10-19 02:41:44 UTC Comment hidden (obsolete)
Comment 11 Laurent BP 2019-10-19 17:51:59 UTC
1. File > New > Business Cards
2. Click New document
3. Enter text
4. Click "Synchronize" button

Cards are populated as expected.
Version: 6.2.6.2
Build ID: 684e730861356e74889dfe6dbddd3562aae2e6ad
Threads CPU : 8; OS : Linux 5.0; UI Render : par défaut; VCL: gtk3; 
Locale : fr-FR (fr_FR.UTF-8); Langue IHM : fr-FR
Calc: threaded