Bug 117827 - Synchronize Labels button not working
Summary: Synchronize Labels button not working
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
6.0.0.3 release
Hardware: All All
: medium normal
Assignee: Laurent BP
URL:
Whiteboard: target:6.2.0 target:6.1.0.1 target:6.0.5
Keywords: bibisected, bisected, regression
Depends on:
Blocks: Templates
  Show dependency treegraph
 
Reported: 2018-05-26 19:35 UTC by Telesto
Modified: 2018-06-25 11:39 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Telesto 2018-05-26 19:35:53 UTC
Description:
Synchronize Labels not working

Steps to Reproduce:
1. Launch LibreOffice
2. From Start Center -> Templates -> Writer Templates - > Businesscard with Logo
3. Add something into the GSM field 
4. Press Synchronize labels -> nothing 

Actual Results:  
Nothing happens

Expected Results:
Content should be synchronized 


Reproducible: Always


User Profile Reset: No



Additional Info:
Found in
Version: 6.2.0.0.alpha0+
Build ID: 938ec2597be2e0ad3af2fb99f77de7f87285ad86
CPU threads: 4; OS: Windows 6.3; UI render: default; 
TinderBox: Win-x86@42, Branch:master, Time: 2018-05-25_23:38:38
Locale: nl-NL (nl_NL); Calc: CL


User-Agent: Mozilla/5.0 (Windows NT 6.3; WOW64; rv:52.0) Gecko/20100101 Firefox/52.0
Comment 1 Regina Henschel 2018-05-26 22:04:49 UTC
Yes, it is an error in the template. The sections should be linked to the master section, but these links are missing.

Use Format > Sections... Click on "Sektsioon1". You should see "MasterLabel" in field Section and a checked "Link" check box in part Link. Same for the other "Sektsioon". If you correct these missing links, the button "Synchronize Labels" will work as expected.
Comment 2 Xisco Faulí 2018-05-31 15:54:07 UTC
Regression introduced by:

author	Laurent BP <laurent.balland-poirier@laposte.net>	2017-12-16 00:17:40 +0100
committer	Laurent BP <laurent.balland-poirier@laposte.net>	2017-12-22 18:19:30 +0100
commit	de14f0487118d8ea15db54d94c44d7bd28833c82 (patch)
tree	a9a5d24e46b9e69e4bc303870dc1376eeb562f43
parent	b9b2ab0f9f1ad91bba899068d2be7fc7767f41c9 (diff)
tdf#114088 tdf#113795 Improve Writer templates

Bisected with: bibisect-linux64-6.1

Adding Cc: to Laurent BP
Comment 3 Laurent BP 2018-06-03 10:20:43 UTC
Regression was introduced because I wanted to remove external links, which ask to be updated when using template (even if it is internal links). However, this question is required to keep links between section.

Synchronize labels restored in:
https://gerrit.libreoffice.org/55243/
Comment 4 Julien Nabet 2018-06-06 19:33:40 UTC
dup of tdf#61030 put in See also?
Comment 5 Laurent BP 2018-06-06 21:09:26 UTC
(In reply to Julien Nabet from comment #4)
> dup of tdf#61030 put in See also?

No duplicate. Bug report here is about Template "Business card with logo" for all OS.
bug 61030 is about wizard File > New > Business card on Windows only (?)
I cannot reproduce bug 61030 with Version: 5.2.7.2
Build ID: 2b7f1e640c46ceb28adf43ee075a6e8b8439ed10
Threads CPU : 8; Version de l'OS :Linux 4.13; UI Render : par défaut; VCL : gtk2; 
Locale : fr-FR (fr_FR.UTF-8); Calc: group
Comment 6 Commit Notification 2018-06-16 08:32:22 UTC
Laurent BP committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=e92e240693ca13ac2ee38da3518b12f57d3974db

tdf#117827 Restore Synchronize labels in template

It will be available in 6.2.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 7 Commit Notification 2018-06-17 08:10:21 UTC
Laurent BP committed a patch related to this issue.
It has been pushed to "libreoffice-6-1":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=d8f62ed88edf7e1a57aee789c243ad143f329e37&h=libreoffice-6-1

tdf#117827 Restore Synchronize labels in template

It will be available in 6.1.0.1.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 8 Commit Notification 2018-06-19 20:37:02 UTC
Laurent BP committed a patch related to this issue.
It has been pushed to "libreoffice-6-0":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=8ebbf13ecf3fefb7d136b67b53834145105612ef&h=libreoffice-6-0

tdf#117827 Restore Synchronize labels in template

It will be available in 6.0.6.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 9 Commit Notification 2018-06-19 22:17:03 UTC
Laurent BP committed a patch related to this issue.
It has been pushed to "libreoffice-6-0-5":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=e8faa165a5ff448b8db680927aea8066e8f9799c&h=libreoffice-6-0-5

tdf#117827 Restore Synchronize labels in template

It will be available in 6.0.5.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 10 Xisco Faulí 2018-06-25 11:39:13 UTC
Verified in

Version: 6.2.0.0.alpha0+
Build ID: dbfa1c452fd9d02330cb3ec5bf2fd4f2c7782d1a
CPU threads: 4; OS: Linux 4.13; UI render: default; VCL: gtk3; 
Locale: ca-ES (ca_ES.UTF-8); Calc: group threaded

@Laurent BP, thanks for fixing this!!