Bug 114088 - Names of new templates not localized
Summary: Names of new templates not localized
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
4.4.0.3 release
Hardware: All All
: medium normal
Assignee: Gabor Kelemen
URL:
Whiteboard: target:6.0.0.2
Keywords:
: 114362 (view as bug list)
Depends on:
Blocks: Not-Localizable 103317
  Show dependency treegraph
 
Reported: 2017-11-27 09:41 UTC by Yousuf Philips (jay) (retired)
Modified: 2017-12-27 22:00 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Yousuf Philips (jay) (retired) 2017-11-27 09:41:09 UTC
The names of the new impress templates added in bug 103317 arent localizable. Code pointers below.

https://opengrok.libreoffice.org/xref/core/include/sfx2/strings.hrc#269

https://opengrok.libreoffice.org/xref/core/sfx2/source/doc/doctempl.cxx#487
Comment 1 Yousuf Philips (jay) (retired) 2017-11-27 09:45:48 UTC
So its not only limited to just the new impress templates, it also includes the templates added in 4.4, including Beehive, Alizarin, Modern business letter serif, etc.

https://wiki.documentfoundation.org/ReleaseNotes/4.4#New_default_templates
Comment 2 Kevin Suo 2017-11-27 09:50:23 UTC
Confirmed

Version: 6.1.0.0.alpha0+
Build ID:d8c0051c6c0400aae6e0a440e83c2c29979347f7
CPU 线程:4; 操作系统:Linux 4.13; UI 渲染:默认; VCL: gtk2; 
Locale: zh-CN (zh_CN.UTF-8); Calc: group threaded
Comment 3 Gabor Kelemen 2017-12-08 21:02:35 UTC
*** Bug 114362 has been marked as a duplicate of this bug. ***
Comment 4 Yousuf Philips (jay) (retired) 2017-12-09 13:16:04 UTC
Gabor's patch - https://gerrit.libreoffice.org/#/c/45450/
Comment 5 Commit Notification 2017-12-09 18:31:33 UTC
Gabor Kelemen committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=d635da1972f15862bb283e77787243fbff8361a6

tdf#114088 Translate default template names

It will be available in 6.1.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 6 Commit Notification 2017-12-09 21:29:16 UTC
Gabor Kelemen committed a patch related to this issue.
It has been pushed to "libreoffice-6-0":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=29c07c224d8b51ff9bf417eb2e3960cd0f9612fd&h=libreoffice-6-0

tdf#114088 Translate default template names

It will be available in 6.0.0.1.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 7 Commit Notification 2017-12-22 17:19:52 UTC
Laurent BP committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=de14f0487118d8ea15db54d94c44d7bd28833c82

tdf#114088 tdf#113795 Improve Writer templates

It will be available in 6.1.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 8 Laurent BP 2017-12-27 10:39:42 UTC
Still pending for 6.0 branch:
https://gerrit.libreoffice.org/47008/
Comment 9 Commit Notification 2017-12-27 20:28:22 UTC
Laurent BP committed a patch related to this issue.
It has been pushed to "libreoffice-6-0":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=c678dc5309741097d9b0265f03dd279a8794d256&h=libreoffice-6-0

tdf#114088 tdf#113795 Improve Writer templates

It will be available in 6.0.0.2.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.