Bug Hunting Session
Bug 61033 - FILESAVE: Write Error. Error in writing sub-document content.xml.
Summary: FILESAVE: Write Error. Error in writing sub-document content.xml.
Status: RESOLVED DUPLICATE of bug 60769
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.0.0.3 release
Hardware: Other Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
Depends on:
Blocks:
 
Reported: 2013-02-18 01:26 UTC by Doctor
Modified: 2013-04-07 23:45 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
.odt file demonstrating the error. (22.30 KB, application/vnd.oasis.opendocument.text)
2013-04-07 14:56 UTC, Mike Dodd
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Doctor 2013-02-18 01:26:14 UTC
Problem description: 

When changing the word "focussed" to "focus" on page 3 of a document, file is unable to save an returns the error: 

Write Error.
Error in writing sub-document content.xml.

If I undo the change, the document save fine. This also happens for any time I try to correct text that has spelling mistakes. If I delete the word that has the spelling mistake I cannot save either. It seems that when there is an error identified and you try to change that error you are unable to save. Please note that I imported all the text from a Microsoft word document (.docx).

The error does not exist when trying to replicate in another document. Which is weird (and unhelpful.)

Unfortunately I'm unable to attach the file because the data is proprietary :S

Steps to reproduce:
1. ....
2. ....
3. ....

Current behavior:

Unable to save file when correcting spelling errors.

Expected behavior:

Being able to save file when correcting spelling errors.

              
Operating System: Windows 8
Version: 4.0.0.3 release
Comment 1 Luis Villa 2013-02-26 22:40:37 UTC
Looks like a duplicate of bug 60769? (I had the same error, for what it is worth.)
Comment 2 Rainer Bielefeld Retired 2013-03-19 16:24:47 UTC
@dr.andonuts
"Bug 60769 - FILEOPEN, FILESAVE, "Could not save document, error in writing sub document context.xml" then corrupt file." Sonds similar and seems fixed for 4.0.1.2. Can you please check.

Can you please also do a test for "Bug 60588 - Error in writing content.xml"

You can send your sample to me by mail, I will keep it confidential.
Comment 3 V Stuart Foote 2013-03-19 17:03:04 UTC
@dr.andonuts

Also, on original doccument, could you let us know if when you check View > Comments if there are any comments present in the document, and if any are against a block of text.

Also, if the spelling correction you were attempting might have been inside a text block that was commented?
Comment 4 Mike Dodd 2013-04-07 14:56:59 UTC
Created attachment 77556 [details]
.odt file demonstrating the error.

File originally saved OK. Make any change and LibreOffice will not save it.
Comment 5 Mike Dodd 2013-04-07 15:01:52 UTC
My original comments seem to have been lost when I attached the .odt file.

The xxx.odt file has four comments, three of them highlighted (i.e.,  text selected, then a comment added, resulting in highlighted text next to the comment pointer.

xx.odt was successfully save by LO. But making any change now causes the error. Add a single character, then backspace, and you can't save the file again.
Comment 6 V Stuart Foote 2013-04-07 18:06:04 UTC
@Mike Dodd,

A lot of recent work on related issue against bug 60769, applied to final 4.0.2 buid and more recent daily builds.

Please indicate what OS and which build of LibreOffice you are using.
Comment 7 Mike Dodd 2013-04-07 23:04:37 UTC
(In reply to comment #6)
> @Mike Dodd,
> 
> A lot of recent work on related issue against bug 60769, applied to final
> 4.0.2 buid and more recent daily builds.
> 
> Please indicate what OS and which build of LibreOffice you are using.

Windows XP Pro SP 3.

I downloaded and installed 4.02 (LibreOffice_4.0.2_Win_x86.msi) last night, but Help->About shows 4.0.0.3.

I will try the 4.0.2 installation again. Is there anything special I need to do to upgrade?
Comment 8 Mike Dodd 2013-04-07 23:26:58 UTC
SOLVED!

I re-installed 4.0.2.2, and now LO saves my test document, and even the huge document from which I extracted it, without problem.

Don't know why the installation didn't "take" last night, but now I'm running 4.0.2.2 for sure.

Thanks, bug-fixers!
Comment 9 V Stuart Foote 2013-04-07 23:45:12 UTC
No additional details from OP. Resolving as duplicate of 60769 which has been closed as fixed at 4.0.2 final.

*** This bug has been marked as a duplicate of bug 60769 ***