Download it now!
Bug 61087 - impress 4 crashing when opening an previouse impress file..
Summary: impress 4 crashing when opening an previouse impress file..
Status: RESOLVED DUPLICATE of bug 60719
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
4.0.0.3 release
Hardware: x86-64 (AMD64) All
: medium major
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-02-18 22:27 UTC by pete molina
Modified: 2013-02-19 13:05 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
presentation that causes the crash in v 4.0.0.3 and 4.0.1 (2.29 MB, application/vnd.oasis.opendocument.presentation)
2013-02-19 12:32 UTC, pete molina
Details

Note You need to log in before you can comment on or make changes to this bug.
Description pete molina 2013-02-18 22:27:05 UTC
impress 3.6.5 will open a presentation with no problem.. however attempting to open the same file in impress 4.0.0.3 will crash the application..  confirmed it in windows 7 and 8 and linux..  uninstalling 4.0.0.3 and reinstalling 3.6.5 fixes the issue..
Comment 1 Thorsten Behrens (CIB) 2013-02-18 22:54:30 UTC
(In reply to comment #0)
> impress 3.6.5 will open a presentation with no problem.. however attempting
> to open the same file in impress 4.0.0.3 will crash the application..
>
This does not seem to be the case for every presentation. Could you attach a sample document which triggers this for you, including steps how to reproduce?
Comment 2 pete molina 2013-02-19 12:32:09 UTC
Created attachment 75108 [details]
presentation that causes the crash in v 4.0.0.3 and 4.0.1

to reproduce the crash.. just try opening the Impress presentation..  i have tried in versions 4.0.0.3 in windows and linux...and 4.0.1 in linux both crash ... have also tried to reduce the size of the presentation thinking maybe ver. 4 had a problem with the size..  but nothing i do other than reinstall 3.6.5 will open the presentation.  

thanks
Comment 3 Thorsten Behrens (CIB) 2013-02-19 13:05:39 UTC
Ah I see - crashes in ImplCreateRotatedScaled, and seems fixed with bug 60719. There should be master nightly builds available shortly to test it.

*** This bug has been marked as a duplicate of bug 60719 ***