Bug 60719 - FILEOPEN: pdf file result in a crash
Summary: FILEOPEN: pdf file result in a crash
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Draw (show other bugs)
Version:
(earliest affected)
4.0.0.3 release
Hardware: All All
: high critical
Assignee: Norbert Thiebaud
URL:
Whiteboard: BSA bibisected40 target:4.1.0 target:...
Keywords: regression
: 61087 61108 (view as bug list)
Depends on:
Blocks:
 
Reported: 2013-02-12 10:36 UTC by Paul Kerry
Modified: 2013-11-18 12:09 UTC (History)
7 users (show)

See Also:
Crash report or crash signature:


Attachments
pdf file that causes the crash (10.25 KB, application/pdf)
2013-02-12 10:36 UTC, Paul Kerry
Details
bibisect40 log (2.86 KB, text/plain)
2013-02-12 21:02 UTC, Jorendc
Details
Stack trace (6.29 KB, text/plain)
2013-02-13 19:10 UTC, Arnaud Versini
Details
gdbtrace log (26.48 KB, text/plain)
2013-02-13 19:14 UTC, Jorendc
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Paul Kerry 2013-02-12 10:36:22 UTC
Created attachment 74670 [details]
pdf file that causes the crash

Problem description: pdf file will not open (others do)

Steps to reproduce:
1. load libreoffice
2. file - open
3. select pdf file and click open

Current behavior: libreoffice starts to open the file (a page box flashes up on the left within draw) and then crashes

Expected behavior: libreoffice opening the file

This is on a debian 6 amd64 system using the 64bit version...
Version 4.0.0.3 (Build ID: 7545bee9c2a0782548772a21bc84a9dcc583b89)
              
Operating System: Debian
Version: 4.0.0.3 release
Last worked in: 3.6.5.2 release
Comment 1 Jorendc 2013-02-12 20:53:25 UTC
Thanks for reporting!

I can reproduce this behavior using Linux Mint 14 x64 LibreOffice 4.0.0.3 release and LibreOffice Version 4.1.0.0.alpha0+ (Build ID: cbc722733bb272b0f26efec09b478bed9a3cdb9)

Therefore I mark it as NEW.
Following [1] I mark this as 'critical medium' because this is only reproducible using this pdf. 

I'll bibisect this one.

Kind regards,
Joren
Comment 3 Jorendc 2013-02-12 21:05:05 UTC
@Arnaud: maybe due http://cgit.freedesktop.org/libreoffice/core/commit/?id=1f08711bd154d0502e5653088dc87575d4c372a7 ?

Kind regards,
Joren
Comment 4 Jorendc 2013-02-12 21:08:55 UTC
Can reproduce a crash using Mac OSX 10.8.2; therefore it's not Linux only -> set to 'all'.
Comment 5 Jorendc 2013-02-13 13:19:44 UTC
altered the summary a bit.
Comment 6 Arnaud Versini 2013-02-13 18:55:00 UTC
I don't see any reason to have a regression with this patch, but perhaps, I would check. But doesn’t crash with master 4.1.0 on Linux 64, but there is no text on the Draw document.
Comment 7 Arnaud Versini 2013-02-13 19:10:17 UTC
Created attachment 74777 [details]
Stack trace
Comment 8 Jorendc 2013-02-13 19:14:57 UTC
Created attachment 74778 [details]
gdbtrace log
Comment 9 Jorendc 2013-02-13 20:08:46 UTC
@Caolan, jbf: any thoughts? seems like a crash in vcl?
Comment 10 Arnaud Versini 2013-02-13 20:13:32 UTC
Seems due to this patch : http://cgit.freedesktop.org/libreoffice/core/commit/?id=4b161067d46ddd48b4602ccdcc4d1b2545e2ac83 but not sure, bad X coordinates during the rotate and scale.
Comment 11 Arnaud Versini 2013-02-16 20:08:25 UTC
Crash with this autogen.lastrun :

--enable-debug

Doesn't with that :

--with-lang=en-US fr
--enable-debug
--with-alloc=system
--with-system-nss
--with-system-cairo
--with-system-clucene
--with-system-poppler
--with-system-openssl
--enable-gtk3
--with-system-neon
--with-system-zlib
--with-system-jpeg
--with-system-icu
--with-system-openldap
--with-system-expat
--with-system-boost
--with-system-bluez
--enable-dbus
Comment 12 Norbert Thiebaud 2013-02-17 03:55:03 UTC
actually the problem is sue to a div by zero while scaling n >=1 to 1

with https://gerrit.libreoffice.org/#/c/2195/

at least it does not crash anymore.
the rendering is better than in 3.6.5 but still somewhat ugly.
Comment 13 Norbert Thiebaud 2013-02-18 18:03:10 UTC
fixed on master with c4a084e6b87e7c6cdf4a2574070b0523206bbefe
Comment 14 Not Assigned 2013-02-18 18:06:43 UTC
Norbert Thiebaud committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=c4a084e6b87e7c6cdf4a2574070b0523206bbefe

fdo#60719 : fix crash on scaling bmp with target/source width/height = 1



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 15 Jorendc 2013-02-18 18:12:49 UTC
Verified fixed using Version 4.1.0.0.alpha0+ (Build ID: 07ee72672e6966dafccf21ca3349e428c2a9dd0)
Comment 16 Not Assigned 2013-02-19 11:09:33 UTC
Norbert Thiebaud committed a patch related to this issue.
It has been pushed to "libreoffice-4-0":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=0ff04e11c0e79a2969774c21df8e0d5822b54e08&h=libreoffice-4-0

fdo#60719 : fix crash on scaling bmp with target/source width/height = 1


It will be available in LibreOffice 4.0.1.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 17 Thorsten Behrens (CIB) 2013-02-19 13:05:39 UTC
*** Bug 61087 has been marked as a duplicate of this bug. ***
Comment 18 Thorsten Behrens (CIB) 2013-02-19 16:44:43 UTC
*** Bug 61108 has been marked as a duplicate of this bug. ***
Comment 19 Rainer Bielefeld Retired 2013-04-10 05:44:58 UTC
Modified Assignee due to facts to ease finding of experts via Bugzilla