Download it now!
Bug 61108 - Impress crash when navigating in a ppt presentation
Summary: Impress crash when navigating in a ppt presentation
Status: CLOSED DUPLICATE of bug 60719
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
4.0.0.3 release
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-02-19 10:14 UTC by christophe.bertin2
Modified: 2013-12-17 13:48 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
ppt file that make Impress crash (460.50 KB, application/vnd.ms-powerpoint)
2013-02-19 10:14 UTC, christophe.bertin2
Details
gdbtrace (17.05 KB, text/plain)
2013-02-19 13:50 UTC, christophe.bertin2
Details
strace (576.96 KB, application/zip)
2013-02-19 13:55 UTC, christophe.bertin2
Details

Note You need to log in before you can comment on or make changes to this bug.
Description christophe.bertin2 2013-02-19 10:14:12 UTC
Created attachment 75101 [details]
ppt file that make Impress crash

I receive some presentation in ppt format and impress crash when reaching some slides. This occurs with either the 3.6 version and the 4. 0 version and is reproducible with the same ppt document. 
This is not occurring opening the same document with IBM Symphony which is OpenOffice based application.
There is no clear message in a command line (IO error) and Dr Konqi don't show me any report trace to send. 
I've succeeded to identify the exact slide that make Impress crash and send it as attachment to this bug.
Comment 1 Thorsten Behrens (CIB) 2013-02-19 12:43:19 UTC
(In reply to comment #0)
> Created attachment 75101 [details]
> ppt file that make Impress crash
> 
Sorry, does not crash for me neither in master nor 4-0 - except from loading and starting the slideshow, anything else I need to do?

Could you try to obtain a stacktrace of the crash, with your original presentation, as described here:

https://wiki.documentfoundation.org/BugReport#How_to_get_a_backtrace_on_Linux

?
Comment 2 christophe.bertin2 2013-02-19 13:50:47 UTC
Created attachment 75110 [details]
gdbtrace
Comment 3 christophe.bertin2 2013-02-19 13:51:27 UTC
Seems to be linked to my installation. I put the backtrace and strace as attachnement. To understant my configuration, I'm on a RedHat systeme 6.3. I've created a dedicated partition for home and when my root partition has came full, i've moved the opt directory to the home partition and created a symlink beetween /opt and /home/opt). In the backtrace, I see everything like /home/opt.
Comment 4 christophe.bertin2 2013-02-19 13:55:10 UTC
Created attachment 75111 [details]
strace
Comment 5 Thorsten Behrens (CIB) 2013-02-19 16:44:43 UTC
Looks suspiciously like bug 60719 then. There should be nightly builds available from e.g.

 http://dev-builds.libreoffice.org/daily/master/Linux-Fedora17-x86_64@4-gcc-4.7-dbgutil/current/

for verification.

*** This bug has been marked as a duplicate of bug 60719 ***
Comment 6 christophe.bertin2 2013-02-20 10:37:33 UTC
Well, I've tried with last alpha build but it doesn't solve my issue. But what I have discovered is that it was not crashing when opening the document using my root user. So I have deleted my config directory and everything is working fine now. I don't know what was corrupted in my previous config.