Download it now!
Bug 61148 - FORMATTING: Different thickness of lines for LibreOffice Calc and Microsoft Excel
Summary: FORMATTING: Different thickness of lines for LibreOffice Calc and Microsoft E...
Status: RESOLVED NOTOURBUG
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
4.0.0.3 release
Hardware: Other All
: high normal
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
: 86860 104820 (view as bug list)
Depends on:
Blocks: XLSX-Limitations
  Show dependency treegraph
 
Reported: 2013-02-20 01:02 UTC by Alex Rain
Modified: 2016-12-22 06:48 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments
screenshot (27.08 KB, image/png)
2013-02-20 01:02 UTC, Alex Rain
Details
ODS file with border width 1.25pt and 3.25pt (7.08 KB, application/vnd.oasis.opendocument.spreadsheet)
2016-07-31 22:02 UTC, Bartosz
Details
file with border width 1.25pt and 3.25pt exported to .xlsx by LO 5.1 (4.30 KB, application/vnd.openxmlformats-officedocument.spreadsheetml.sheet)
2016-08-03 21:23 UTC, Bartosz
Details
.xlsx file which demonstrate all possible thickness and options of borders style (16.15 KB, application/vnd.openxmlformats-officedocument.spreadsheetml.sheet)
2016-08-03 22:31 UTC, Bartosz
Details
Compare of borders imported by MS Excel 2010 and LO 52 (82.98 KB, image/png)
2016-08-03 22:33 UTC, Bartosz
Details
ODT Border with different width for export (8.91 KB, application/vnd.oasis.opendocument.spreadsheet)
2016-08-03 22:44 UTC, Bartosz
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Alex Rain 2013-02-20 01:02:29 UTC
Created attachment 75147 [details]
screenshot

Problem description: 

Steps to reproduce:
1. Create a file in LibreOffice Calc. Specify the line thickness of framing any cell 0.4pt, 0.5pt, 0.8pt, 2.0pt. Save the file as test_1.ods. Save the file as test_1.xls (Excel 97/2000/XP/2003) and close it.
2. Reopen test_1.xls in LibreOffice Calc. The thickness of the lines will not match the test_1.ods.
3. Test_1.xls open in Microsoft Office Excel 2003. The thickness of the lines will not be the same as the thickness of the lines in the files and test_1.ods test_1.xls, opened in LibreOffice Calc.
4. Create a file in Microsoft Office Excel 2003. Specify the line thickness of framing any cells as thin, medium, thick. Save the file as test_2.xls.
5. Open test_2.xls in LibreOffice Calc. A thick line will look like a medium.

Current behavior:
Different thickness of lines.

Expected behavior:
Thickness of the lines should be the same.
              
Operating System: All
Version: 4.0.0.3 release
Comment 1 Filipe Morais 2013-02-27 16:35:13 UTC
I agree that this is an anoying bug, that should be easy to be resolved, but that could prevent many using LO.
Comment 2 Timur 2013-03-04 11:38:42 UTC
This is likely a duplicate. Please look at https://bugs.freedesktop.org/show_bug.cgi?id=46393 and https://bugs.freedesktop.org/show_bug.cgi?id=60805.
Comment 3 Alexander 2013-06-19 09:19:35 UTC
Why exactly is it 'likely' a duplicate? Zooming and printing are about visual style, not necessarily about fileconversion. Please treat this bug separate until clarified.
Comment 4 A (Andy) 2015-03-07 21:18:51 UTC
Reproducible with LO 4.4.1.2, Win 8.1

Tested with xls and xlsx and in both the border thickness is mostly changed:
0.75 stays 0.75 
1.00 changed to 0.75
1.25 changed to 0.75
1.50 changed to 0.75
1.75 stays 1.75
2.00 changed to 1.75
Comment 5 tommy27 2016-04-16 07:26:49 UTC Comment hidden (obsolete)
Comment 6 Bartosz 2016-07-31 22:02:47 UTC
Created attachment 126503 [details]
ODS file with border width 1.25pt and 3.25pt
Comment 7 Bartosz 2016-08-03 21:23:12 UTC
Created attachment 126555 [details]
file with border width 1.25pt and 3.25pt exported to .xlsx by LO 5.1
Comment 8 Bartosz 2016-08-03 22:31:03 UTC
Created attachment 126556 [details]
.xlsx file which demonstrate all possible thickness and options of borders style
Comment 9 Bartosz 2016-08-03 22:33:29 UTC
Created attachment 126557 [details]
Compare of borders imported by MS Excel 2010 and LO 52
Comment 10 Bartosz 2016-08-03 22:44:34 UTC
Created attachment 126558 [details]
ODT Border with different width for export
Comment 11 Bartosz 2016-08-03 22:51:18 UTC
It is the limitation of MS Excel that there is only 3 thickness available.
Tested on LibreOffice 5.1 Ubuntu 16.04
Comment 12 Roeland 2016-08-10 13:55:05 UTC
I see that this bug report got closed. While I understand the reasoning that the size is a limit of MS Excel, the current situation remains a problem.

Cell thickness saved in LibreOffice as xlsx should reopen in Libreoffice with the same values; regardless of how excel works. Or is this something the openmxl specs don't support?

If someone can confirm this isn't supported by Openmxl, I'll submit an enhancement request where Libreoffice warns when saving as xlsx that this is not supported.
Comment 13 Bartosz 2016-08-11 07:52:57 UTC
*** Bug 86860 has been marked as a duplicate of this bug. ***
Comment 14 Bartosz 2016-08-11 08:25:34 UTC
This is an OpenXML/xlsx.
All possible values which could be taken by Border Style class is available at:
https://msdn.microsoft.com/en-us/library/office/documentformat.openxml.spreadsheet.borderstylevalues.aspx

Unfortunately we cannot do anything more than displaying some warning message, that .xlsx is not supporting different border thickness.
Comment 15 Roeland 2016-08-11 19:53:43 UTC
Maybe we should keep this bug report as meta and create some new bug reports for all the issues this encompasses.

See also these blog post bij LibreOffice dev Kohei on this topic:
http://kohei.us/2014/01/17/the-art-of-drawing-border-lines/
http://kohei.us/2014/01/21/update-on-border-lines/

As I see it:
Bugreport 1:
Dashdot  and dashdotdot line are missing when using openmxl in Libreoffice (xlsx). Kohei also mentiones this in his blog posts.

Bugreport 2:
Line thickness is not kept when using xlsx format internal in LibreOffice:

0.75 stays 0.75 
1.00 changed to 0.75
1.25 changed to 0.75
1.50 changed to 0.75
1.75 stays 1.75
2.00 changed to 1.75

Bugreport 3:
Hair line support is missing when using xlsx in LibreOffice
Comment 16 Roeland 2016-09-06 19:45:33 UTC
I will create these bug reports if there's no other feedback.
Comment 18 Bartosz 2016-12-22 06:48:10 UTC
*** Bug 104820 has been marked as a duplicate of this bug. ***