Download it now!
Bug 61240 - PRINTING: Math Object on Writer page distorts printing of Draw objects
Summary: PRINTING: Math Object on Writer page distorts printing of Draw objects
Status: RESOLVED DUPLICATE of bug 60280
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.0.0.3 release
Hardware: Other Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords: regression
Depends on:
Blocks:
 
Reported: 2013-02-21 16:52 UTC by Jason Baldus
Modified: 2013-04-16 16:50 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
The first two pages are the result of the current behavior obtained from printing the file. The second two pages are the expected result obtained from using the pdf exporter. (35.24 KB, application/pdf)
2013-02-21 16:52 UTC, Jason Baldus
Details
An example of a file that is printing strangely for me (49.40 KB, application/vnd.oasis.opendocument.text)
2013-04-12 14:17 UTC, Jason Baldus
Details
What the example document looks like when it prints (79.45 KB, application/binary)
2013-04-12 14:18 UTC, Jason Baldus
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Jason Baldus 2013-02-21 16:52:18 UTC
Created attachment 75263 [details]
The first two pages are the result of the current behavior obtained from printing the file.  The second two pages are the expected result obtained from using the pdf exporter.

Problem description: When a math formula object is included on a page in a writer document, any Draw objects print at a greatly distorted scale.  This seems to affect all of the following pages some of the time, and other times it seems to only affect the page that includes the math formula object.  

This only affects printing the document.  The screen rendering is correct and the pdf export is correct.  

This bug doesn't seem to affect including math formula objects in a Draw file, or even including math formulas in a Draw file, then pasting from the Draw file into the Writer file.  Which is terrible, but is a workaround.

Steps to reproduce:
1. Open a file in Writer.
2. Insert a math formula object
3. Use the Draw toolbar to make a drawing object or copy and past from a Draw file.
4. Print the file to see the distortion.

Current behavior:
See the attached pdf file.  The first two pages are the current behavior obtained from printing the file to a PDF printer.  Printing to a real printer produces the same results.

Expected behavior:
See the attached pdf file.  The last two pages show the expected behavior.
              
Operating System: Windows (other)
Version: 4.0.0.3 release
Last worked in: 3.6.5.2 release
Comment 1 BorosIstvan 2013-04-12 10:32:26 UTC
Hello I try reproduce your problem but i don't have problem with the printed pages. I created drawing objects some version in the Libre Office, but everythink works good with the printing.
Comment 2 Jason Baldus 2013-04-12 14:17:03 UTC
Created attachment 77884 [details]
An example of a file that is printing strangely for me
Comment 3 Jason Baldus 2013-04-12 14:18:48 UTC
Created attachment 77886 [details]
What the example document looks like when it prints

You can see the triangle is gone and instead is a wide horizontal line at the end.  Yet somehow the graph prints normally.
Comment 4 Jason Baldus 2013-04-12 14:21:03 UTC
(In reply to comment #1)
> Hello I try reproduce your problem but i don't have problem with the printed
> pages. I created drawing objects some version in the Libre Office, but
> everythink works good with the printing.

I've attached an example file that's giving me trouble.  I've tried printing it from several machines with the same result.  Would you check to see if it gives you any trouble?
Comment 5 Rainer Bielefeld Retired 2013-04-16 16:50:08 UTC
[Reproducible] with parallel Dev-installation of  "Version 4.1.0.0.alpha0+ (Build ID: 049ce78144650d92eb6bd73292868f73d37c901) TinderBox: Win-x86@6, Branch:master, Pull Time: 2013-03-29_23:59:42" ENGLISH UI / German Locale on German WIN7 Home Premium (64bit) with LODev/4 Masters User Profile 

This is a new aspect (or may be I simply lost overview) of "Bug 60280 PRINTING of TABLE borders, borders around paragraphs and footer, some graphic elements suppressed by OLE objects in document" or one of the related ones.

Looks similar to "Bug 62261 - PRINTING: Draw objects won't print if formula is inserted in the same page"

@Jason Baldus:
Please observe progress and leave a note if fixes do not heal all your problems.

*** This bug has been marked as a duplicate of bug 60280 ***