Download it now!
Bug 62261 - PRINTING: Draw objects won't print if formula is inserted in the same page
Summary: PRINTING: Draw objects won't print if formula is inserted in the same page
Status: RESOLVED DUPLICATE of bug 60280
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.0.1.2 release
Hardware: Other Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords: regression
Depends on:
Blocks:
 
Reported: 2013-03-12 19:53 UTC by Adam
Modified: 2013-04-24 19:30 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
Screenshots of file to be printed, with print preview and final result, I was lucky to catch LibreOffice on missplacing and not disappearing the draw object (180.61 KB, image/jpeg)
2013-03-12 19:53 UTC, Adam
Details
Sample document created with 3.6.5 (Win) (11.08 KB, application/vnd.oasis.opendocument.text)
2013-03-12 21:47 UTC, Rainer Bielefeld Retired
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Adam 2013-03-12 19:53:40 UTC
Created attachment 76443 [details]
Screenshots of file to be printed, with print preview and final result, I was lucky to catch LibreOffice on missplacing and not disappearing the draw object

Problem description: 
When draw objects and formula are inserted on the same page, LO will only print formulas, draw objects are missplaced from the place they are originally put. Print preview works fine, it's the process of printing that causes this problem. If the page is exported to PDF and then printed, it works just fine. It seems that in the print process Writer missplaces draw object to the non-printable area, I was lucky to catch Writer missplacing drawn line to totally different place, see attachment. Although most of the times, these objects just don't appear on the printed page.

Steps to reproduce:
1. Draw a line or rectangle
2. Add math formula, for example x=4
3. Make sure these objects are on the same page
4. Print this page, it is advised to print using printer emulator like PDFCreator to save paper.
5. In the printed file or paper, drawn line or rectangle disappears(or is misplaced) while math formula x=4 is present.

Current behavior:
LibreOffice won't print draw objects, even if they are visible on print preview.

Expected behavior:
LibreOffice prints all objects seen on print preview in correct position, including draw objects and math formula inserted on the same page.
              
Operating System: Windows 7
Version: 4.0.1.2 release
Last worked in: 3.6.5.2 release
Comment 1 Rainer Bielefeld Retired 2013-03-12 21:47:06 UTC
Created attachment 76447 [details]
Sample document created with 3.6.5 (Win)

More or less [Reproducible] with sample document and server installation of "LibO  4.0.1.2 release   -  German UI / German Locale  [Build ID: 84102822e3d61eb989ddd325abf1ac077904985)]"  {tinderbox: @6, pull time  2013-02-28 08:53(?)} on German WIN7 Home Premium (64bit) with newly created user profile ….\LibreOffice\4012\

More research tomorrow!
Comment 2 Joel Madero 2013-04-16 16:27:36 UTC
Rainer - how'd the research go? Can we confirm this one?
Comment 3 Michael Stahl (CIB) 2013-04-24 19:30:11 UTC
was fixed by 954d695827431a5badd1a993d8f364c669ca9c9c
-> duplicate

*** This bug has been marked as a duplicate of bug 60280 ***