Bug Hunting Session
Bug 61320 - FILESAVE, PREFERENCES: Allow user to choose whether to create thumbnails
Summary: FILESAVE, PREFERENCES: Allow user to choose whether to create thumbnails
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.0.0.3 release
Hardware: All All
: medium enhancement
Assignee: Michael Meeks
URL:
Whiteboard: target:4.3.0
Keywords:
: 78422 (view as bug list)
Depends on:
Blocks:
 
Reported: 2013-02-22 23:45 UTC by Linus Drumbler
Modified: 2017-01-30 19:04 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Linus Drumbler 2013-02-22 23:45:46 UTC
Currently, every .odt file created by writer adds a thumbnail image, approximately 18 kb in size. With some small files, this almost doubles their size, and it drastically increases the files' size. Furthermore, the thumbnails are not really useful: some OSes don't display them, and on those that do display them, they're of too low a resolution to be helpful in identifying the document (and making them so would just make the files larger). Creating a user preference for whether to create this images (preferably turned off by default) would be very helpful.
Comment 1 Thomas van der Meulen 2013-02-24 08:28:27 UTC
I wil set it to new, and enhancement.
Comment 2 christianju 2014-02-09 16:38:28 UTC
Taking it... Let's see if this can be done in decent time..
Comment 3 Michael Stahl (CIB) 2014-02-10 10:37:17 UTC
i think disabling thumbnail generation is a pretty esoteric use-case,
especially with today's storage hardware.

we could easily add a configuration setting for this, but adding
this option to the Tools->Options UI would clutter up that dialog
with another esoteric option that much less than 1% of users would
ever change.

fortunately in 4.2 we have the expert configuration UI for such
use cases; the "Office.Common/Save/Document/PrettyPrinting"
setting was already removed from the Options UI as a consequence of that.
Comment 4 Stefan Knorr (astron) 2014-02-10 17:57:40 UTC
Another vote for WONTFIX from me, for the same reasons that Michael just outlined. Setting this for now...
Additionally, if the previews are not useful at their current size, they may need to be made larger (if they're JPEGs, it might be possible to trade resolution for quality -- thus not making them much larger).
Comment 5 Michael Stahl (CIB) 2014-02-11 17:17:03 UTC
re-opening...

clarified with Astron on IRC, the objection is just against the
extra UI in Tools->Options, a config option without extra UI is fine :)
Comment 6 christianju 2014-02-15 22:10:19 UTC
I am not really happy with abandoning this option into the expert configuration dialog, which looks hard to handle for me, since it's just a big list of preferences that one can tweak, similiar to the about:config page in FF. Without the possibility to search this list, how should the user not be frustrated by sliding his way through the huge list to find the particular option he is looking for?
Comment 7 Adolfo Jayme 2014-02-16 03:08:03 UTC
I feel that this is too “esoteric” as well. We don’t really want to clutter the options pages even more. About the config list not being searchable, please report a new bug for that :-)
Comment 8 Stefan Knorr (astron) 2014-02-16 18:36:14 UTC
(In reply to comment #7)
> I feel that this is too “esoteric” as well. We don’t really want to clutter
> the options pages even more. About the config list not being searchable,
> please report a new bug for that :-)

Ftr, this is reflected already in bug 67642. Of course, it could have been more clever to report each of those issues as a single bug.
Comment 9 christianju 2014-03-01 20:45:04 UTC
Assigning it to Michael Meeks after our IRC conversation today.
Comment 10 Commit Notification 2014-03-03 16:52:09 UTC
christianju committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=0035b3218d8652652e62afe89eddfd28a9021b75

fdo#61320: Allow user to choose whether to create thumbnails inside odf.



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 11 Michael Meeks 2014-03-03 17:59:02 UTC
Thanks for the patch Christian ! =)

Of course it would be lovely to have the ability to search and find neat settings like this more easily in the expert config.

I guess we could even imagine a category of especially useful settings in there (perhaps) =)

Closing for now though.
Comment 12 Stefan Knorr (astron) 2014-06-22 09:58:27 UTC
*** Bug 78422 has been marked as a duplicate of this bug. ***
Comment 13 helplibreoffice 2014-07-09 08:02:34 UTC
So how does one exclude the thumbnail from an individual file?  Count my vote as another one that this is not esoteric.
Comment 14 Linus Drumbler 2014-07-09 15:08:38 UTC
(In reply to comment #13)

To remove the thumbnail from an individual file, rename the file's .odt extension to .zip, and open it with an archiver. In the file META-INF/manifest.xml, there should be a line that says

<manifest:file-entry manifest:full-path="Thumbnails/thumbnail.png" manifest:media-type="image/png"/>

Delete this line. Then, delete the "thumbnails" directory.

The thumbnail will be regenerated the next time you save the file in LibreOffice.
Comment 15 helplibreoffice 2014-07-11 02:22:25 UTC
Thank you for the great details.  I appreciate it.  Does that mean nothing has been added to the UI, and that is the only procedure to remove the thumbnail from a file?
Comment 16 V Stuart Foote 2017-01-30 19:04:37 UTC
*** Bug 105621 has been marked as a duplicate of this bug. ***