Bug Hunting Session
Bug 61421 - V 1.0.2: Prevent smartphone is locked when you are making a presentation
Summary: V 1.0.2: Prevent smartphone is locked when you are making a presentation
Status: RESOLVED FIXED
Alias: None
Product: Impress Remote
Classification: Unclassified
Component: Android app (show other bugs)
Version:
(earliest affected)
1.0.2
Hardware: ARM other
: medium normal
Assignee: Ondřej Smrž
URL:
Whiteboard: target:4.1.0 target:4.0.2
Keywords: difficultyBeginner, easyHack, skillJava, topicCleanup
: 62580 (view as bug list)
Depends on:
Blocks:
 
Reported: 2013-02-25 02:20 UTC by Bastián Díaz
Modified: 2015-12-18 10:07 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Bastián Díaz 2013-02-25 02:20:30 UTC
Last week I made several presentations using IT remote impress with the bluetooth system works great. However, it was somewhat annoying that on several occasions I had to unlock my phone to continue the presentation (I use the pin system) and other occasions I had to change the simple system (slide to unlock) which made things a little more easy.

Propose two possible solutions:
1. Prevent smartphone locks (if a presentation has begun)
2. To use the physical keys (volume) to move the presentation forward or backward while the smartphone is locked.

Thanks, this application has done a great job.
Comment 1 Michael Meeks 2013-02-25 10:37:49 UTC
Oh - wow, good feedback :-) really glad you got it working nicely for you (I hope with 4.0.1rc1).

http://smartandroidians.blogspot.co.uk/2010/03/enabling-and-disabling-lock-screen-in.html

Has the details on how to implement this - it -looks- rather easy (to me).

KeyguardManager keyguardManager = (KeyguardManager)getSystemService(Activity.KEYGUARD_SERVICE);  
KeyguardLock lock = keyguardManager.newKeyguardLock(KEYGUARD_SERVICE);  

lock.disableKeyguard();  

Or use the xml attribute android:keepScreenOn="true" somewhere in the XML goodness.
Comment 2 Ondřej Smrž 2013-02-26 16:41:41 UTC
Hi, I'm student of CTU in Prague and I'd like to implement this feature as a part of my semestral project in Open Source programming course. Is it possible? It looks like easy one to start with. Thanks for your answer
Comment 3 Michael Meeks 2013-02-26 18:16:35 UTC
Go for it - adding potentially a single XML attribute doesn't seem like enough for a semester - but there are lots of other things to improve in the Android remote - so go for it ! :-) we look forward to your patch.
Comment 4 Ondřej Smrž 2013-03-10 14:22:55 UTC
Finally I manage to push my patch back for code review :) Hope it will be accepted soon...
Comment 5 Commit Notification 2013-03-11 09:28:10 UTC
OndÅej Smrž committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=b2a11dc9a1b7890d77314d0101004289088e6054

fdo#61421 Added line to prevent screenlocking during presentation



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 6 Michael Meeks 2013-03-11 12:02:48 UTC
Thanks for the fix ! :-) can you send a suitable license statement to the developers list to be linked into:

https://wiki.documentfoundation.org/Development/Developers

Looking forward to your next fix :-) There is plenty left to do with the android remote - there are a number of GSOC ideas here you could steal:

https://wiki.documentfoundation.org/Development/Gsoc/Ideas#Improved_Android_.2F_Impress_Remote_Control

All the best.
Comment 7 Commit Notification 2013-03-11 12:04:30 UTC
OndÅej Smrž committed a patch related to this issue.
It has been pushed to "libreoffice-4-0":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=f0615d8d399f32de21002add6e033c3a9575f417&h=libreoffice-4-0

fdo#61421 Added line to prevent screenlocking during presentation


It will be available in LibreOffice 4.0.2.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 8 Petr Mladek 2013-03-21 13:45:04 UTC
*** Bug 62580 has been marked as a duplicate of this bug. ***
Comment 9 Rainer Bielefeld Retired 2013-04-04 11:13:31 UTC
Automated Message: Own Impress Remote Versions will be removed from Bugzilla. 
For new AIR bugs please use "(See in Summary)"
<https://wiki.documentfoundation.org/BugReport_Details#Version_Picker:_Particular_Versions>
Comment 10 Robinson Tryon (qubit) 2015-02-13 19:41:52 UTC
Moving bug to (new) 'Impress Remote' product.
Comment 11 Robinson Tryon (qubit) 2015-12-18 10:07:57 UTC
Migrating Whiteboard tags to Keywords: (EasyHack,DifficultyBeginner,SkillJava,TopicCleanup )
[NinjaEdit]