Bug 61522 - EDITING: 'Fields - Functions - Input field' does not open with mouse click
Summary: EDITING: 'Fields - Functions - Input field' does not open with mouse click
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.0.1.1 rc
Hardware: Other All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: BSA target:4.0.2 target:4.1.0
Keywords: regression
Depends on:
Blocks:
 
Reported: 2013-02-26 18:05 UTC by Reinhard Lamsfuss
Modified: 2013-06-27 10:06 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Sample Document (8.07 KB, application/vnd.oasis.opendocument.text)
2013-02-27 08:30 UTC, Rainer Bielefeld Retired
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Reinhard Lamsfuss 2013-02-26 18:05:42 UTC
Problem description: 

Steps to reproduce:
1. In a new document, choose Insert>Fields>Other>Input field, indicate a reference, accept (OK)
2. Click on the field and try to edit
3. Strike ctrl+shift+F9

Current behavior: Field will not open on mouse click, whereas keyboard shortcut [ ctrl+shift+F9] opens it

Expected behavior: Field should open for editing with  ctrl+shift+F9 AND mouse click 

              
Operating System: Ubuntu
Version: 4.0.1.1 rc
Comment 1 Reinhard Lamsfuss 2013-02-27 07:17:43 UTC
Sorry, clarification "edit" means here: fill in text, not edit the field command
Comment 2 Rainer Bielefeld Retired 2013-02-27 08:30:11 UTC
Created attachment 75621 [details]
Sample Document

[Reproducible] with Server Installation of "LibO  4.0.1.1+   -  German UI / German Locale  [Build ID: 2c0c17a6e4bee0ee28131ea4bdc47edc700d659)]"  {tinderbox: @6, pull time  2013-02-1920:00(?)} on German WIN7 Home Premium (64bit) with newly created user profile ….\LODev\4\:

1. open attached "sample.odt"
2. Click into grey input field
   Expected: input dialog opens
   actual: Nothing

With same document everything works fine with 4.0.0.3
Comment 3 Rainer Bielefeld Retired 2013-02-27 08:36:25 UTC
I wonder whether the fix for "Bug 59928 - EDITING: Impossible to fill text into Fields - Functions - Placeholder - text" might have some influence here?

@Michael:
Can your please check?
Comment 4 Rainer Bielefeld Retired 2013-02-27 08:38:49 UTC
Still worked fine  with parallel Dev. Installation of "LODev  4.0.1.0+   -  English UI / German Locale  [Build ID: 693217465486667d38c3b7cd6d654136fe1efc8)]"  {tinderbox: @6, pull time  2013-01-28(?)} on German WIN7 Home Premium (64bit) with User Profile updated from 4.0.0.2
Comment 5 Joel Madero 2013-02-28 20:55:16 UTC
This seems to be fixed on
Version 4.1.0.0.alpha0+ (Build ID: b8e0455f201198b1deb8f8ca0181e6c9cadc335)
Date:   Thu Feb 28 20:17:25 2013 +0100
Bodhi Linux

so I'm marking this as FIXED. 

@Reporter & Rainer - if this is still an issue on rc2 please reopen and we'll investigate further. 

Thanks :)
Comment 6 Michael Stahl (allotropia) 2013-02-28 22:09:47 UTC
eh right that was fixed by commit in comment #18 on bug 59928.

i'm not sure if it's legit to call this a duplicate since this bug
was introduced by the fix originally described at bug 59928
and that bug was then re-opened.
Comment 7 Michael Stahl (allotropia) 2013-02-28 22:10:51 UTC
Comment on attachment 75621 [details]
Sample Document

are all these broken mime-types created by bugzilla auto-detect or what...
Comment 8 Joel Madero 2013-02-28 22:14:15 UTC
Yes, I've emailed Tollef about it to try to get default set to auto but so far no response. Will email him again next week if I don't hear something
Comment 9 Rainer Bielefeld Retired 2013-03-01 06:33:22 UTC
Yes, works fine with Server Installation of "LibO  4.0.2.0+   -  English UI / German Locale  [Build ID: 01f8d0a1dffce854a66c0f957e81e6df6d361a8)]"  {tinderbox: @6, pull time  2013-02-26 09:45:35} on German WIN7 Home Premium (64bit) with newly created user profile ….\LODev\4\
Comment 10 Björn Michaelsen 2013-06-27 10:06:03 UTC
Fixing target in whiteboard.