Bug 59928 - EDITING: Impossible to fill text into Fields - Functions - Placeholder - text
Summary: EDITING: Impossible to fill text into Fields - Functions - Placeholder - text
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.0.0.0.alpha0+ Master
Hardware: All All
: medium normal
Assignee: Michael Stahl (CIB)
URL:
Whiteboard: target:4.1.0 target:4.0.1
Keywords: regression
: 59935 (view as bug list)
Depends on:
Blocks: mab4.0
  Show dependency treegraph
 
Reported: 2013-01-27 11:46 UTC by Rainer Bielefeld Retired
Modified: 2013-02-28 22:09 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
Simple Sample (9.01 KB, application/vnd.oasis.opendocument.text)
2013-01-27 11:46 UTC, Rainer Bielefeld Retired
Details
Sample with more placehaolders (11.96 KB, application/vnd.oasis.opendocument.text)
2013-01-27 14:57 UTC, Rainer Bielefeld Retired
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Rainer Bielefeld Retired 2013-01-27 11:46:04 UTC
Created attachment 73726 [details]
Simple Sample

Steps how to reproduce [Reproducible] with "LibO  4.0.0.2 rc   -  GERMAN UI / German Locale  [Build ID: 5991f37846fc3763493029c4958b57282c2597e)]"  {tinderbox: @6, pull time 2013-01-24  07:20(?)} on German WIN7 Home Premium (64bit) with User Profile automatically created form renamed /3 User profile used by 3.6.5.2:

0. Open attached Sample document with Placeholder from File menu in 
   LibO Start center
2. If necessary, activate "Nonprintable Characters"
1. Click Placholder "<>"
   Expected: only placeholder highlighted
   Actual (Bug): Also blank after placeholder highlighted
2. Type "x"
   Expected: "x" _filled_into_placeholder_ with Default font (Times New Roman)
             with character size 80
   Actual: "x" _replaces_Placeholder_ with font size 12

That's WFM in server installation of  "Version 4.1.0.0.alpha0+ (Build ID: 2823789bec0c029d9714aff0ed65923e23177ef) TinderBox: Win-x86@6, Branch:master, Pull Time: 2013-01-24_22:52:49" ENGLISH UI / German Locale  on German WIN7 Home Premium (64bit) with LO41 Masters User Profile

Still was ok with LibO  3.5.6.2 and 3.6.5.2, so regression

Workaround: With caret flashing in text behind placeholder, a double click selects (only) placeholder as expected
Workaround does not work if caret in line below placeholder
Comment 1 Rainer Bielefeld Retired 2013-01-27 14:21:52 UTC
oops, wrong version. Some further tests:

Already [Reproducible] with unzipped  installation of  "LOdev  4.0.0.0.alpha1+   -  ENGLISH UI / German Locale  [Build ID: af60316514f3ae3d4c475819bf86f2af837171e)]"  {tinderbox: Win-x86@6, pull time 2012-11-23 22:10:31} on German WIN7 Home Premium (64bit) with own separate User Profile

Still was ok with 
* Server-installation of Master "3.7.0.alpha0+  – ENGLISH UI [Build ID: f2e622]" {tinderbox: Win-x86@16, pull time 2012-10-06 09:31:39} on German WIN7 Home Premium (64bit) UserInstallation=$SYSUSERCONFIG/LOdev/3



@Sasha:
do you already have 4.0 for a review with Linux?
Comment 2 Rainer Bielefeld Retired 2013-01-27 14:57:25 UTC
Created attachment 73735 [details]
Sample with more placehaolders

This sample with more objects shows that the "first character after object replaced" problem also is visible for the other object types, but those work more or less as expected
Comment 3 sasha.libreoffice 2013-01-28 07:31:28 UTC
Reproduced in 4.0.0.2 on Russian Fedora Remix 17 64bit
using first attachment
When we click near left edge in placeholder then selected placeholder with one space next to it. If we click near right hand edge inside of placeholder then selected only space after placeholder.
If we double click placeholder then selected placeholder itself instead of opening dialog "Edit fields".
Comment 4 Michael Stahl (CIB) 2013-01-30 11:30:02 UTC
regression from

commit dcb080347ca127044313bbb3c11c37761cc2a7a2
Author: Cédric Bosdonnat <cedric.bosdonnat@free.fr>
Date:   Fri Nov 16 13:37:04 2012 +0100

    n#780277: select field when clicking it instead of having cursor before it

fixed on master
Comment 5 Not Assigned 2013-01-30 11:31:05 UTC
Michael Stahl committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=94721b2aec614e0d99504138d484b2ad6cd550c7

fdo#59928: sw: fix mouse selection of fields:



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 6 sasha.libreoffice 2013-01-31 05:25:37 UTC
Thanks for fixing this bug
Comment 7 Not Assigned 2013-01-31 09:26:50 UTC
Michael Stahl committed a patch related to this issue.
It has been pushed to "libreoffice-4-0":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=afab7f25d20936a93b9d075aadbfcbaff9df8f9e&h=libreoffice-4-0

fdo#59928: sw: fix mouse selection of fields:


It will be available in LibreOffice 4.0.1.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 8 Michael Stahl (CIB) 2013-02-08 19:11:59 UTC
*** Bug 59935 has been marked as a duplicate of this bug. ***
Comment 9 Jean-Baptiste Faure 2013-02-17 09:05:31 UTC
Hi Michael,

Your patch fixes the selection problem but now the mouse click does not work as expected anymore. You can see on the second bugdoc (attachment 73735 [details]) that clicking the second placeholder does not open the dialog to insert a table.

If I revert locally your patch this placeholder and the following works as expected. I do not know how to fix both problems.

Best regards. JBF
Comment 10 Jean-Baptiste Faure 2013-02-19 15:31:08 UTC
Hmmm, seems to be more annoying than I imagined: it is impossible to follow a cross-reference, clicking on a cross-reference does nothing but select the field.
Will add this bug to MAB 4.0.

Best regards.
Comment 11 Michael Stahl (CIB) 2013-02-19 21:36:46 UTC
uhm... this works fine here, double clicking all placeholders
in the second bugdoc opens the dialog, on master and current 4.0.

can anybody confirm this?
Comment 12 Jean-Baptiste Faure 2013-02-19 22:59:06 UTC
(In reply to comment #11)
> uhm... this works fine here, double clicking all placeholders
> in the second bugdoc opens the dialog, on master and current 4.0.
> 
> can anybody confirm this?

The problem is not double-clicking, but single-clicking. Single click on the <tabelle> placeholder should open a dialog to insert a table, the same you get with ctrl+F12 or menu Insert > Table.
It works with LO 4.0.0.3 but not with LO 4.0.2.0+ and master.

Best regards. JBF
Comment 13 Not Assigned 2013-02-19 23:54:01 UTC
Michael Stahl committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=a4a457100a3a6e9f59113e82c9d0b12786273671

fdo#59928: sw: fix mouse selection of fields differently



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 14 Not Assigned 2013-02-20 14:03:11 UTC
Michael Stahl committed a patch related to this issue.
It has been pushed to "libreoffice-4-0":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=7063ea7cc1eadb22ac3ca6c2d54001408b60ef95&h=libreoffice-4-0

fdo#59928: sw: fix mouse selection of fields differently


It will be available in LibreOffice 4.0.2.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 15 Cédric Bosdonnat 2013-02-20 14:59:39 UTC
fixed by Michael
Comment 16 sasha.libreoffice 2013-02-21 05:04:12 UTC
Thanks!
Comment 17 Jean-Baptiste Faure 2013-02-21 19:40:05 UTC
Thank you very much Michael for the fix.
Tested on Version 4.1.0.0.alpha0+ (Build ID: d4b904f7d15be8460dbff4cf6c8d500aea5a4fa) and Version 4.0.2.0+ (Build ID: a4f226088faa5b8d9a688a765af0bb832843068)

To summarize the behavior:
- single click on the field -> action of the field
- double click just before the field -> edition of the field (in previous versions it was, sometimes, possible to edit a field by double-clicking on it)
- right click on the field and choosing item Fields -> edition of the field 

Best regards. JBF
Comment 18 Not Assigned 2013-02-25 16:49:56 UTC
Michael Stahl committed a patch related to this issue.
It has been pushed to "libreoffice-4-0-1":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=7782a3aad25e96b8a26fbb192a6b54c1269b4efd&h=libreoffice-4-0-1

fdo#59928: sw: fix mouse selection of fields differently


It will be available already in LibreOffice 4.0.1.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.