Download it now!
Bug 61629 - Calc: Print File Directly with range selected no longer asks user
Summary: Calc: Print File Directly with range selected no longer asks user
Status: RESOLVED DUPLICATE of bug 54908
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
4.0.0.3 release
Hardware: Other All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-02-28 19:40 UTC by crxssi
Modified: 2013-03-18 19:58 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
Missing dialog in LibreOffice Calc as it appears in OpenOffice Calc (45.91 KB, image/png)
2013-02-28 19:42 UTC, crxssi
Details

Note You need to log in before you can comment on or make changes to this bug.
Description crxssi 2013-02-28 19:40:08 UTC
In OpenOffice Calc, when a range is selected and then Print File Directly is activated, a dialog would appear and ask the user "Do you want to print the selection or the entire document?".  

In LibreOffice this dialog does not appear and it immediately prints the whole sheet or document without asking the user.  This appears to be a regression from a better past behavior.

Also- in both LibreOffice and OpenOffice Calc, when a range is selected and the regular print function is activated, it still defaults to "Selected sheets" instead of "Selected cells."  It might be better if it changes to "Selected cells" just to be more friendly.  Generally, when a user has a range selected and then performs an action (such as print), they mean for it to only happen to the selected range.

Will attach a screenshot of the missing dialog.
Comment 1 crxssi 2013-02-28 19:42:10 UTC
Created attachment 75709 [details]
Missing dialog in LibreOffice Calc as it appears in OpenOffice Calc
Comment 2 crxssi 2013-03-01 23:04:28 UTC
It would appear my bug report is a duplicate of gug 54908 which I discovered exists today.

However, I think my report is better :)
Comment 3 Joel Madero 2013-03-18 19:57:51 UTC
lol despite yours potentially being better, marking as dupe. Please put additional helpful comments on 54908 :-D

Thanks for your bug reports, we're working hard to tackle them.

*** This bug has been marked as a duplicate of bug 54908 ***