Bug 61683 - 64-bit version of LibreOffice on Windows
Summary: 64-bit version of LibreOffice on Windows
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: x86-64 (AMD64) Windows (All)
: medium enhancement
Assignee: DavidO
URL:
Whiteboard:
Keywords:
Depends on: 89441
Blocks: 44123
  Show dependency treegraph
 
Reported: 2013-03-02 11:30 UTC by Gerry
Modified: 2016-03-23 03:44 UTC (History)
10 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Gerry 2013-03-02 11:30:17 UTC
Suprisingly, I did not find an enhancement request on the LibreOffice bug tracker with regards to an 64-Bit port of LibreOffice on Windows.

Enhancement request: creating a 64-Bit version also on Windows.

Currently LibreOffice is only as a 64-Bit binary available for Linux, but not for Mac OS X (bug 58663), but not for Windows.

Please see:
http://tml-blog.blogspot.de/2011/03/porting-libreoffice-to-x64-windows.html
Comment 1 Sam Hokin 2013-04-22 16:35:24 UTC
I'll second this! My problem is that there is no Oos version that runs stably on my Windows XP Pro x64 computer. I've found that 3.6 is more stable than 4.0, but I can crash either one by simply using the Format->Page function in Writer. I'm not sure a 64-bit port would fix my problem, but I'd sure like to find out!
Comment 2 Kedar Bhise 2013-04-30 09:48:52 UTC
I'll third this request!

I too had Libreoffice crash issues, similar to Sam when formatting, but on Windows XP 32-Bit. See bug 60102 and also bug 44595.

Now using LO on Windows 7 64 bit. Would love to have a 64-Bit version for Windows.
Comment 3 Urmas 2013-08-09 07:49:03 UTC
Why that be an issue? Office software will never realistically have any problems due to 2GB memory limit.
Comment 4 João Paulo 2013-09-15 06:34:47 UTC
(In reply to comment #3)
> Why that be an issue? Office software will never realistically have any
> problems due to 2GB memory limit.

Actually, there are spreadsheets and databases that are big enough to benefit from more memory already.

And I can see presentations using large pictures and movies becoming common.

Maybe texts doesn't need so much memory yet, but Microsoft Word 2010 and newer already have 64 bit versions, so why not a 64 bit version for LibreOffice?
Comment 5 mikmas 2013-11-14 12:23:28 UTC
It should be the port for win x64 if there already is on linux x64
Comment 6 Sn3akyP3t3 2014-01-13 19:50:55 UTC
Adobe ColdFusion has the ability to leverage LibreOffice (or OpenOffice) to convert Word Document files to PDF format.  An example of how it gets called is here: http://stackoverflow.com/questions/2292352/is-it-possible-to-convert-a-microsoft-word-document-to-pdf-with-coldfusion  This feature works only in the 32 bit version of Adobe ColdFusion because of this bug read further for explanation why.

The 64 bit version of Adobe ColdFusion leverages 64 bit JVM which requires LibreOffice DLLs for the dependencies to be 64 bit as well.  Ignoring this and mixing 64 bit Adobe ColdFusion with 32 bit Libreoffice results in the JVM rejecting them with this error, "Can't load IA 32-bit .dll on a AMD 64-bit platform". That pretty much kills the file conversion. The solution is to use a 64 bit version of the dependencies which currently does not exist.
Comment 7 Peter CM 2014-06-14 04:18:33 UTC
I'm running LibreOffice 4.2.4.2 on 64-bit Windows 7, SP 1.

When I'm editing or formatting really big documents in Writer, LibreOffice often becomes non-responsive ("not responding") for *very* long periods of time. When I have Resource Monitor analyze the wait chain for soffice.bin, it says it's waiting for splwow64.exe, which I gather is 64-bit Windows' printer spooler for printing from 32-bit applications to 64-bit drivers. Then again, when LibreOffice Writer has become responsive again, is doing nothing, and its share of CPU is 0%, Resource Monitor says its *still* waiting for splwow64.exe.

I don't know enough about Windows or LibreOffice to hazard an informed guess, but is it possible that 32-bit LibreOffice's interaction with splwow64.exe is causing my hangs and that this problem would disappear with a 64-bit version of Libreoffice?

Just throwing it out there as a possibility...
Comment 8 B. Cook 2014-07-21 14:17:08 UTC
The reason for a 64-bit version of the office suite is to allow applications which WOULD benefit from 64-bit capability to leverage LibreOffice functionality. If my engineering application needs to have an embedded spreadsheet it cannot currently use LibreOffice under win64 without writing some sort of horrible COM-based thing.

I am currently working on a Qt app that needs to have embedded spreadsheet functionality. The contract requirements are that it be open source, be 64-bit, and work under both Linux and Windows. A 64-bit version of LibreOffice would be really useful at this time.
Comment 9 Gerry 2014-07-21 14:24:44 UTC
@B.Cook: I am not a developer, but maybe this information here is already helpful for you: As far as I understood a 64-Bit version for Windows is generally working with lots of minor problems. Since you do not need the GUI for your project, maybe it is already good enough for you. In a recent blog entry by Michael Meeks some short news on the 64-bit port: https://people.gnome.org/~michael/blog/2014-07-08.html
Comment 10 B. Cook 2014-07-30 18:36:10 UTC
Thanks, I'll look into that!
Comment 11 pquiring 2014-11-09 01:39:35 UTC
It looks like Windows 10 will drop support for Win32 apps.  I'm not sure why MS would make such a move but this is cause for concern.
Comment 12 Urmas 2014-11-09 02:00:47 UTC
Lol wut? 64-bit applications are Win32 too.
Comment 13 pquiring 2014-11-09 14:44:54 UTC
Nope, MS is removing WoW in Windows 10.  Only 64bit apps from now on.
Comment 14 Friedmann Bruno 2014-11-09 15:09:51 UTC
There's also another reason to have a natvie 64bits windows build.
Consider a workstation having oracle native client + java 64 bits runtime.
Consider having drivers to connect to postgresql, mysql, ms-sql whatever here as native 64 bits drivers due to the fact that 3rd professional apps need them.
Now for example install autodesk 64bits, you want to have mdb(x) access and thus you HAVE TO use the 64bits office drivers (and eventually applications).
Now MS doesn't allow you to co-install those drivers in 64 and 32 bits.

Guess what, all future planification in enterprise to create a pure only 64bits application, drop LibreOffice just because the product doesn't exist.

Now if we want to see still Loo installed on future computers, we have to offer this build. Time to propose it now, so beta users can try it, and improve.
Comment 15 Peter CM 2014-11-09 16:14:03 UTC
(In reply to pquiring from comment #13)
> Nope, MS is removing WoW in Windows 10.  Only 64bit apps from now on.

I'm pretty sure this is either a misunderstanding or a canard. There's an unconfirmed rumor that Microsoft is considering dropping the native 32-bit version of Windows 10, but I've found no evidence anywhere that they are considering dropping the WoW64 (Windows 32-bit on Windows 64-bit) subsystem from 64-bit Windows 10.
Comment 16 pquiring 2014-11-10 01:08:53 UTC
Here are two articles that suggest that Wow will be stripped:

http://www.networkworld.com/article/2220221/microsoft-subnet/windows-9-details-are-already-emerging.html

http://www.product-reviews.net/2014/10/06/32-bit-windows-10-reportedly-dropped/

I'm shocked myself.  I can see them not created a 32bit system, but dropping WoW seems a little too soon.
Comment 17 pquiring 2014-11-10 01:58:34 UTC
After looking at those articles again I'm not sure WoW64 will be dropped.  The first article is from 2011.
Comment 18 Peter CM 2014-11-10 02:03:23 UTC
(In reply to pquiring from comment #16)
> Here are two articles that suggest that Wow will be stripped:
> 
> http://www.networkworld.com/article/2220221/microsoft-subnet/windows-9-
> details-are-already-emerging.html
> 
> http://www.product-reviews.net/2014/10/06/32-bit-windows-10-reportedly-
> dropped/
> 
> I'm shocked myself.  I can see them not created a 32bit system, but dropping
> WoW seems a little too soon.

The first article is from 2011, and the second says nothing about WoW64 being dropped. As for Mozilla finally preparing an official release of Firefox x64, well, everyone else is doing it and some 32-bit Firefox users have actually run up against its 2GB RAM limit in real life. The Wikipedia article on WoW64 states that WoW64 is included in 64-bit Windows 10, and I just read a post by someone who claims to be running 32-bit Firefox nightlies on 64-bit Windows 10 Preview. Finally, after generating so much ill will by terminating support for Windows XP, terminating sales of Windows 7, and forcing a tablet-centric Windows 8 on traditional desktop users, it seems highly unlikely that Microsoft would be willing to incur even more resentment by ending support for the huge existing base of 32-bit Windows apps. (If you're running 64-bit Windows now, go to your C:\Program Files (x86) folder and see how many 32-bit apps *you're* using. How many do you think will be promptly rewritten in 64-bit free of charge?) So again, my vote is for misunderstanding or canard.
Comment 19 Alex Thurgood 2015-01-03 17:39:46 UTC
Adding self to CC if not already on
Comment 20 Jouni Järvinen 2015-01-08 12:34:23 UTC
There are no reasons to -not- make LO64. I might be wrong but Google Chrome64 was made cuz it's more secure, so LO64 should be too, if done correctly. And the performance improvement in addition to RAM limit removal (or at least increment).
Comment 21 DavidO 2015-01-08 15:21:12 UTC
Restricted version of LibreOffice (with some modules disabled) is up and running on Windows 64 bit. See this announcement on the dev ML. Ongoing efforts are tracked on this Wiki page: 

[1] http://lists.freedesktop.org/archives/libreoffice/2015-January/065698.html
[2] https://wiki.documentfoundation.org/Development/msvc-x86_64
Comment 22 Jouni Järvinen 2015-01-08 15:25:11 UTC
(In reply to DavidO from comment #21)
> Restricted version of LibreOffice (with some modules disabled) is up and
> running on Windows 64 bit. See this announcement on the dev ML. Ongoing
> efforts are tracked on this Wiki page: 
> 
> [1]
> http://lists.freedesktop.org/archives/libreoffice/2015-January/065698.html
> [2] https://wiki.documentfoundation.org/Development/msvc-x86_64

Wow, so many issues with the x64.
Comment 23 V Stuart Foote 2015-02-12 07:56:23 UTC
@David, *,
(In reply to DavidO from https://bugs.documentfoundation.org
/show_bug.cgi?id=89310#c5)
> @Stuart, thanks for providing the link for the workaround. There is another
> issue tracking the availability of LO build on 64-bit windows [1]. Could you
> please perform a quick smoke test for LibreOffice 64-bit build? Does it
> looks sane to you?
> 

Loaded up the 2015-02-09 build side by side with current 32-bit TB builds, very solid!
Comment 24 pquiring 2015-03-11 18:31:48 UTC
I've tested the alpha0 builds and they work great except that file associations do not register.  I can create the associations in Windows for now.
Thanks.
Comment 25 DavidO 2015-03-12 07:58:46 UTC
(In reply to pquiring from comment #24)
> I've tested the alpha0 builds and they work great except that file
> associations do not register.  I can create the associations in Windows for
> now.

This is expected, because the build was done without --enable-release switch.
You can force it though, use:

  msiexec /i LibreOrrice.msi WRITE_REGISTRY=1
Comment 26 PICCORO Lenz McKAY 2016-03-23 03:44:58 UTC
too much support for a busy os...