Bug Hunting Session
Bug 61917 - can't fetch data from web using webquery
Summary: can't fetch data from web using webquery
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
4.0.1.2 release
Hardware: All All
: medium critical
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-03-06 20:37 UTC by Edmund Laugasson
Modified: 2014-07-09 15:08 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Edmund Laugasson 2013-03-06 20:37:34 UTC
Cannot import data using WebQuery.

Steps to reproduce:
1. choose Insert->Link to external data...
2. write or copy-paste the url
3. nothing comes
Comment 1 Petr Mladek 2013-03-07 13:21:23 UTC
Could you please attach a sample data file that worked with older LO versions?

I am unable to get this working even in older LO releases. It seems that the file has to have a special format. The help page is not much helpful :-(
Comment 2 Petr Mladek 2013-03-14 15:53:36 UTC
Could you please provide more detailed description how to reproduce this problem?
Could you please paste here the URL that you tried?
Could you please attach a document with a sample data?
We are not able to move forward if we are not able to reproduce the problem.

I am not able to reproduce the problem. The reported does not respond. Such bug could not block the 4.0.2 release => reducing the severity a bit.
Comment 3 Owen Genat (retired) 2013-05-25 04:42:14 UTC
If the query contains non RFC-compliant characters then this bug may be a duplicate of bug #42377, however without further information from the OP it is impossible to tell. Bug #49043 also contains a query that was having intermittent problems, although it is possible than appears to be resolved now.
Comment 4 Edmund Laugasson 2013-05-25 08:40:25 UTC
Currently I use 4.0.3 and here it works.

Steps to reproduce:
1. Open LibreOffice Calc
2. Open web browser and go to address http://www.x-rates.com/table/?from=EUR&amount=1.00  <-- an example address I searched
3. copy the URL above
4. Open Insert->Link to external data...
5. paste the URL to the first field
6. click to the pull down menu arrow once and just close it
7. wait for few moments and then "Import options" dialog box appears
8. additional dialog box appears and asks, which language I would use when importing tables. I chose "automatic" and then press "OK"
9. Then it shows available tables/ranges, which can be imported and I chose HTML_tables and press OK. You can choose also HTML_1, HTML_2 if there are several tables.
10. tables were imported

If connection is lost or other problem (e.g. HTML_all did not succeed), then it announces "The link could not be updated", otherwise tables will be appear into Calc.

I tried also with addresses:
https://www.swedbank.ee/private/home/more/pricesrates/rates?language=ENG
https://www.swedbank.ee/private/home/more/pricesrates/rates?language=EST
... all succeeded

So - in version LibreOffice Version 4.0.3.3 (Build ID: 0eaa50a932c8f2199a615e1eb30f7ac74279539) it seems to work. I use 64-bit Ubuntu 12.04 LTS with all current updates + latest stable kernel (currently 3.9.3).
Comment 5 Edmund Laugasson 2013-05-25 08:44:18 UTC
...
4. Open Insert->Link to external data...

... I meaned this in LibreOffice Calc - choose pull down menu "Insert" and from there the choice "Link to external data..."

Just for clarification - I forgot to mention before and this environment does not allow to correct comments - so I provide new one.
Comment 6 Owen Genat (retired) 2013-06-16 14:43:30 UTC
As a result of comment #4 by the bug reporter I am changing the status to RESOLVED as FIXED. I just want to note that bug #49043 that I linked to above as appearing to be similar, also seemed to have some success with v4.0.3.3 (as here) but the problem appears to have come back in v4.1.0.0 beta. Hopefully that won't be the case here.
Comment 7 Edmund Laugasson 2014-07-09 15:08:33 UTC
I can confirm, that with LibreOffice 4.2.5.2 (64-bit DEB) it works.