Bug Hunting Session
Bug 61948 - [EDITING], [REGRESSION], [CRASH] - Using Data | Validity crashes Calc
Summary: [EDITING], [REGRESSION], [CRASH] - Using Data | Validity crashes Calc
Status: CLOSED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
4.0.1.2 release
Hardware: x86 (IA32) Windows (All)
: medium normal
Assignee: Caolán McNamara
URL:
Whiteboard: target:4.1.0 target:4.0.3
Keywords:
Depends on:
Blocks:
 
Reported: 2013-03-07 08:53 UTC by grofaty
Modified: 2013-04-11 12:34 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
attachment_1.png (42.04 KB, image/png)
2013-03-07 08:53 UTC, grofaty
Details
attachment_2.png (16.30 KB, image/png)
2013-03-07 08:54 UTC, grofaty
Details
attachment_3.png (17.33 KB, image/png)
2013-03-07 08:54 UTC, grofaty
Details
attachment_4.png (10.55 KB, image/png)
2013-03-07 08:54 UTC, grofaty
Details

Note You need to log in before you can comment on or make changes to this bug.
Description grofaty 2013-03-07 08:53:29 UTC
Created attachment 76087 [details]
attachment_1.png

Hi,
today on Windows XP sp3 I have migrated from LibreOffice v3.6.5.2 to LibreOffice v4.0.1.2. This is new problem to v4.0.1.

1. Open new Calc document.
2. In cells write:
A1: London
A2: Berlin
A3: Paris
3. Click on B1 cell.
4. Menu selection Data | Validity.
5. Criteria tab from Allow drop-down box select Cell range.
6. In the line of Source label click on Shrink button.
Note: The first problem: Window opens up and this window is way to big. Purpose of Shrink window is to shrink window, not to stay in the same size (see attachment_1.png)
7. With mouse select cells from A1 to A3.
8. Click shrink button again.
Note: The second problem appears: You get corrupted window (see attachment_2.png)
9. Click on Cancel.
10. Repeat steps 4 and 5.
11. Click in Source input box.
12. At the bottom of window there appears "shrink window" input box and shrink big button.
Note: Third problem appears: Shrink window should not appear at the bottom and big shrink button should not be displayed (see attachemnt_3.png).
12. At the bottom of this window click in the input box (where range is displayed), but clicking on it crashes Calc.
Note: Fourth and final problem: Crash (see attachment_4.png).

P.S. To make it sure this is not my profile problem I have renamed profile C:\Documents and Settings\[user]\Application Data\LibreOffice\4 folder to 4_old and restarted LibreOffice. The same problem appears. I also tested this on two Windows XP sp3 computers having exact the same result.

Regards
Comment 1 grofaty 2013-03-07 08:54:15 UTC
Created attachment 76088 [details]
attachment_2.png
Comment 2 grofaty 2013-03-07 08:54:36 UTC
Created attachment 76089 [details]
attachment_3.png
Comment 3 grofaty 2013-03-07 08:54:52 UTC
Created attachment 76090 [details]
attachment_4.png
Comment 4 Julien Nabet 2013-03-09 12:49:39 UTC
grofaty: once 4.0.2 released (see https://wiki.documentfoundation.org/ReleasePlan#4.0_release), don't hesitate to reopen if you still reproduce this.
Instead of waiting stable 4.0.2, you can give a try daily to 4.0 builds here: http://dev-builds.libreoffice.org/daily/libreoffice-4-0/Win-x86@6/current/

*** This bug has been marked as a duplicate of bug 58630 ***
Comment 5 grofaty 2013-03-12 08:04:51 UTC
I have downloaded/installed LibreOffice daily 2013-03-12-Win-x86
Version 4.0.2.0+ (Build ID: 9b6797ec124921a60e5d1d654139e0b82818a7c)

I have retested majority of problems disappears, but I can still reproduce the crash!

How to reproduce the crash:
1. Open new Calc document.
2. In cells write:
A1: London
A2: Berlin
A3: Paris
3. Click on B1 cell.
4. Menu selection Data | Validity.
5. Criteria tab from Allow drop-down box select Cell range.
6. In the line of Source label click on Shrink button.
Note: Now Shrink window opens successfully - so fixed in daily build.
7. With mouse select cells from A1 to A3.
8. Click shrink button again.
Note: Now window does not get corrupted - so fixed in daily build.
9. Click on Cancel.
10. Repeat steps 4 and 5.
11. Click in Source input box. Don't enter anything.
Note: There is no additional "shrink window" - so fixed in daily build.
12. Click on OK button. Source field is populated with data: $Sheet.$A$1:$A$3.
13. Click on OK button again! And a Calc crash appears.
Comment 6 grofaty 2013-03-12 08:18:24 UTC
I have been playing around and found another crash reproduce scenario (using the same daily build as above).

How to reproduce the crash:
1. Repeat steps from 1 to 8 from my previous post.
2. Click on OK button.
3. Repeat steps from 4 to 6 from my previous post.
Now source of a problem appears: double window - in front there is shrinked window, but behind there is Validity window.
4. Click on behind window's OK button. Now shrinked window disappears.
5. Click on shrinked icon again and crash appears.
Comment 7 Daniel L 2013-03-12 09:49:30 UTC
I confirm the problem on Version 4.0.1.2 (Build ID: 84102822e3d61eb989ddd325abf1ac077904985) and Version 4.0.2.0+ (Build ID: 9b6797ec124921a60e5d1d654139e0b82818a7c)
Comment 8 grofaty 2013-04-05 05:52:52 UTC
Retested Comment_5 and Comment_6 in LibreOffice 4.0.2.2 on Windows XP and crash appears in both cases. It looks like in both cases beside a dialog new the same dialog appears that messes with old dialog.
Comment 9 Caolán McNamara 2013-04-05 10:33:59 UTC
blast it, so there are other exciting things this dialog can do
Comment 10 Commit Notification 2013-04-05 10:41:56 UTC
Caolan McNamara committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=21d6c1022aa528836d20ae1b8be9ea1b84bd61aa

Related: fdo#61948 data->validity crashes calc



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 11 Caolán McNamara 2013-04-05 11:00:24 UTC
Under Linux with master I could reproduce a crash in one particular scenario (specific to master) which I've now fixed.

I can't seem to reproduce the reported problem here with a Linux 4.0.2.2 so will have to try and install a windows 4.0.2 and see if I can replicate it there.
Comment 12 grofaty 2013-04-05 11:14:58 UTC
I have retested the same problem using the following PPA:
sudo add-apt-repository ppa:libreoffice/libreoffice-4-0
sudo apt-get update && sudo apt-get -y dist-upgrade

So version: 4.0.2.1 (Build ID: 400m0(Build:1)) is installed. It looks like PPA has not fully updated to 4.0.2.2 yet.

But I can't reproduce the problem in Comment_5 and Comment_6.
Comment 13 grofaty 2013-04-05 11:17:40 UTC
I think I have found out another bug related to Validity.
1. Just create a validity e.g. in B1 cell.
2. On the bottom just click on "+" to create a new sheet.
Do you notice the "drop-down" arrow in this new sheet's B1 cell? If you click on this new B1 cell drop-down arrow disappears. I think Validity drop-down arrow should be sheet specific.
Comment 14 grofaty 2013-04-05 11:18:36 UTC
I forgot to write test in Comment_12 was tested in Ubuntu 12.04.
Comment 15 Caolán McNamara 2013-04-05 11:47:48 UTC
re comment 13, that's outside the scope of this bug, which is related to my dialog code changes, while that's something apparently preexisting and not my bug :-), so a new bug for that is indicated.
Comment 16 grofaty 2013-04-05 15:52:18 UTC
@Caolán McNamara,
OK, I understand, one problem per bug report. For Comment_13 I have opened a new bug report Bug 63178.
Comment 17 Caolán McNamara 2013-04-08 12:26:56 UTC
I can reproduce the various super weirdness under windows alright, odd that it affects that platform but not Linux
Comment 18 grofaty 2013-04-09 05:47:54 UTC
I have found a simpler way (less steps) to reproduce (LibreOffice 4.0.2.2 on Windows XP sp3):
1. Data | Validity.
2. On default Criteria tab from Allow drop-down selection Cell range.
3. In Source input box just type in: A1:A3
4. Click OK button.
5. Data | Validity
6. Click on Shrink button (right of Source input box).
Double window appears. Now crash does not appear, but you are in death-end, can't close any of this two dialogs. The only way to solve the problem is to force-kill application from Windows Task Manager.

So problem only appears second time. Maybe when first time OK button is clicked there is also some variable set to some value that effects the dialog when it opens in second time. Just a guess.


By the way, I have tried to see if the same problem appears at Tools | Goal (very similar dialog with Shrink button etc), but it does not appear:
1. In cell A1 type in: 100
2. In cell A2 type in: A1*10
3. Click on A2 cell (this is where formula is)
4. Tools | Goal Seek.
5. Formula cell: there is already $A$2 (because of step 3).
6. Target value type in: 2000
7. Variable cell type in: A1
8. Click on OK button. Notification window opens, confirm with Yes.
9. Tools | Goal Seek.
10. Now click on any of the Shrink buttons and problem does not appear.

Maybe if you create a diff of the dialog variable settings from Goal | Seek and Data | Validity and maybe you can find out what is the difference in dialog variable settings.
Comment 19 grofaty 2013-04-09 05:50:39 UTC
In previous post step 2 there there is missing "=" character at formula, so: =A1*10
Comment 20 Commit Notification 2013-04-09 13:12:35 UTC
Caolan McNamara committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=afb3af7ce5fef803d42a549095863e6bb8210ef2

Resolves: fdo#61948 delayed delete deletes nothing under windows



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 21 Caolán McNamara 2013-04-09 13:24:37 UTC
When the dialog is getting closed its not getting deleted, so there ends up being two dialogs the next time and the original gets reshown along with the new one. This only affects windows. A wild and whacky bug.

Fixed on master, submitted as an update to 4-0 via gerrit.
Comment 22 Commit Notification 2013-04-09 14:00:29 UTC
Caolan McNamara committed a patch related to this issue.
It has been pushed to "libreoffice-4-0":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=0e147d836c753280842463326759c9fdb56ff83a&h=libreoffice-4-0

Resolves: fdo#61948 delayed delete deletes nothing under windows


It will be available in LibreOffice 4.0.3.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 23 grofaty 2013-04-11 11:56:05 UTC
Downloaded daily build from: http://dev-builds.libreoffice.org/daily/libreoffice-4-0/Win-x86@6/current/libreoffice-4-0~2013-04-09_13.58.49_LibO-Dev_4.0.3.0_Win_x86.msi on Windows XP.

Help | About displays the following info: Version 4.0.3.0+ (Build ID: 0e147d836c753280842463326759c9fdb56ff83)

Retested problem in Comment_5, Comment_6 and Comment_8.
I can confirm problem is fixed.
Thanks a lot!
Comment 24 Caolán McNamara 2013-04-11 12:34:31 UTC
Who-hoo!