Download it now!
Bug 62028 - UI Enhancement File > Recent Documents - Clear list
Summary: UI Enhancement File > Recent Documents - Clear list
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
4.1.0.0.alpha0+ Master
Hardware: All All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard: target:4.1.0
Keywords:
: 66030 (view as bug list)
Depends on:
Blocks:
 
Reported: 2013-03-08 15:18 UTC by V Stuart Foote
Modified: 2014-12-07 07:01 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description V Stuart Foote 2013-03-08 15:18:10 UTC
As suggested in a UX-Advise thread
http://nabble.documentfoundation.org/bring-over-a-Recent-Documents-gt-Clear-list-implementation-from-AOO-tt4040830.html

Openening a UI enhancement request to implement a "Clear list" action to the File -> Recent Documents list.

Perhaps inclusion of "Clear list" can be done simply as a port of recent AOO work on the framework::RecentFilesMenuController with SVN http://svn.apache.org/viewvc?view=revision&revision=1341725 for AOO issue https://issues.apache.org/ooo/show_bug.cgi?id=37201

This would be point 2 on the much more substantial UI enhancement to the Recent Documents list proposed in bug 61174
Comment 1 Jorendc 2013-03-08 22:36:04 UTC
Mark this one as NEW. Legit enhancement request and I saw the emails on UX-mailinglist passing by. Thanks for your research Stuart!

Kind regards,
Joren
Comment 2 Markus Mohrhard 2013-03-10 13:03:35 UTC
I'll check if it is possible to cherry-pick this commit.
Comment 3 V Stuart Foote 2013-04-10 16:09:10 UTC
So this has been accomplished with http://cgit.freedesktop.org/libreoffice/core/commit/?id=0e6a5bf1d9f4106af44996548ab0924ce7e5648c

A File -> Recent Documents -> Clear List is available and functions correctly in recent dailys of master.
e.g. Version: 4.1.0.0.alpha0+
Build ID: 73cc9fc42cfa524a9965f58092f3a004de3a6b8
TinderBox: Win-x86@6, Branch:master, Time: 2013-04-08_05:35:47

So should be available in 4.0.3

Closing as fixed.
Comment 4 Markus Mohrhard 2013-04-10 16:15:51 UTC
(In reply to comment #3)
> So should be available in 4.0.3
> 

This won't be available in any of the 4.0.* releases. You will have to wait till 4.1.0 to see this feature in a release.
Comment 5 Jorendc 2013-06-25 23:10:40 UTC
*** Bug 66030 has been marked as a duplicate of this bug. ***
Comment 6 Todd 2014-12-07 07:01:23 UTC
(In reply to Jorendc from comment #5)
> *** Bug 66030 has been marked as a duplicate of this bug. ***

In 4.3.4.1, you have the ability to individually remove a single document from the thumbnails.  I use it all the time and love the feature.  Thank you guys!

Not sure a clear "all" is even desirable at this point.  Don't think I ever use it.