Bug 62082 - Consolidate buttons in the animation pane into a single toolbar
Summary: Consolidate buttons in the animation pane into a single toolbar
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
4.0.1.2 release
Hardware: Other All
: medium enhancement
Assignee: Samuel Mehrbrodt (CIB)
QA Contact:
URL:
Whiteboard: target:4.3.0 target:4.2.1
Keywords:
Depends on:
Blocks:
 
Reported: 2013-03-10 01:45 UTC by Tin Man
Modified: 2014-02-05 16:07 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Tin Man 2013-03-10 01:45:09 UTC
Add a toolbar below the animation effect listbox containing the arrows for changing order and icons for "Add...", "Remove", "Change...", and "Play" (and remove the buttons for these in the pane). Also, remove the "Slide Show" button from the pane, as it's already shown in the toolbar.
Comment 1 Rainer Bielefeld Retired 2013-03-10 09:56:40 UTC
What are we talking about? Presentation animations? Ane why do you think that can be an EasyHack? I remove suggestion for now

@mazelm
Please explain more carefully what exactly you suggest.
Comment 2 Joel Madero 2013-04-15 02:43:01 UTC
@Mazelm - please answer Rainer's questions, once you address his concerns, set as UNCONFIRMED and Rainer will answer your request.

Thanks!
Comment 3 Tin Man 2013-04-17 10:05:23 UTC
(In reply to comment #1)
> What are we talking about? Presentation animations? Ane why do you think
> that can be an EasyHack? I remove suggestion for now
> 
> @mazelm
> Please explain more carefully what exactly you suggest.

The suggestion would only be to change the layout of the "Custom Animation" section of the Tasks pane in Impress.
Comment 4 Samuel Mehrbrodt (CIB) 2013-04-20 18:19:35 UTC
See https://wiki.documentfoundation.org/User:Sam_m#Impress:_Custom_Animation_Pane for an exact explanation of what should be changed
Comment 5 Tin Man 2013-04-21 09:48:53 UTC
(In reply to comment #4)
> See
> https://wiki.documentfoundation.org/User:Sam_m#Impress:
> _Custom_Animation_Pane for an exact explanation of what should be changed

It's not an exact explanation -- the design team agreed to have the toolbar below the animation effect listbox instead of above, as tends to be the norm with listbox buttons, and we agreed on a different order of the buttons.
Comment 6 Caolán McNamara 2013-10-08 09:25:55 UTC
*** Bug 70271 has been marked as a duplicate of this bug. ***
Comment 7 ade2 2014-02-01 00:03:09 UTC
In 4.2.0.4 on Windows the new graphical buttons below the list in the Custom Animations pane are gigantic. In order to see all the gigantic buttons the pane requires more horizontal screen space than before: 342px if including the new icon list at the righthand side. 298px excluding the icon list. 272px in previous versions of LO. 

The huge buttons should be changed to small buttons. They cause a waste of screen space and their size is inconsistent with the rest of the UI.
Comment 8 ade2 2014-02-01 00:08:06 UTC
The icon for the "remove effect" button is a paper shredder. There are more intuitive delete/remove icons than that.

The buttons for "move up" and "move down" each have a blue arrow and a small black arrow. Why two arrows on each button?
Comment 9 Commit Notification 2014-02-05 16:05:56 UTC
Samuel Mehrbrodt committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=5350d30b10ebcd939d4b2ca5f142d6c5a3444f42

fdo#62082 Fix buttons in Custom animation toolbar



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 10 Commit Notification 2014-02-05 16:06:12 UTC
Samuel Mehrbrodt committed a patch related to this issue.
It has been pushed to "libreoffice-4-2":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=d18a29455ab6297d7b8a0b37dc93062ce94d37f1&h=libreoffice-4-2

fdo#62082 Fix buttons in Custom animation toolbar


It will be available in LibreOffice 4.2.1.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 11 Caolán McNamara 2014-02-05 16:07:05 UTC
If there are remaining problems, open a new bug for them, don't reopen this one because that really mangles our bug handling as the bug mutates through a gadzillion related topics