Bug 62087 - Performance:Very slow scrolling.
Summary: Performance:Very slow scrolling.
Status: RESOLVED DUPLICATE of bug 53095
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
4.0.2.1 rc
Hardware: All All
: high critical
Assignee: Not Assigned
URL: https://docs.google.com/file/d/0B8qaX...
Whiteboard:
Keywords: perf
Depends on:
Blocks:
 
Reported: 2013-03-10 06:02 UTC by abhimj
Modified: 2015-12-15 11:05 UTC (History)
0 users

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description abhimj 2013-03-10 06:02:08 UTC
File is created in Excel. File size about 50 MB with about 30 sheets, about 10,000 rows per sheet.

The scrolling with arrow keys is extremly slow.

This causes execution macros that involve scrolling very slow.

This is how I have recorded the macro -
1) Select some rows (about 10-15).
2) Copy
3) Paste Special->Transpose in another cell.
4) Scroll to the first row of the next set of rows to be transposed.

The file is shared on google drive -
https://docs.google.com/file/d/0B8qaXt5L1EUXOFJmMXdoSS0xdWs/edit?usp=sharing

There is another bug opened for the same file for load/save (takes almost > 5 minutes) - bug id 61837 - FILESAVE: perf:Calc takes long time to load and save file about 50 MB in size
 OS is Windows 7 64 bit i3 quad processsor with 3 GB RAM.

Strange observation - The scrolling speed improves drastically when the laptop is on AC power.
Comment 1 Thomas van der Meulen [retired] 2013-03-18 18:22:17 UTC
Thank you for reporthing this bug,
I can reproduce this bug running LibreOffice 4.0.2.1 on Mac osx 10.6.8.
Comment 2 A. Fakhouri 2013-04-17 20:16:52 UTC
I can confirm this poor performance when scrolling, not only in spreadsheet, but also in Writer. The performance also degrades significantly when using complex fonts in non-latin languages. I think this is related to the fonts handling library in use.
Comment 3 Thomas Arnhold 2013-05-01 02:15:36 UTC

*** This bug has been marked as a duplicate of bug 53095 ***
Comment 4 Robinson Tryon (qubit) 2015-12-15 11:05:10 UTC
Migrating Whiteboard tags to Keywords: (perf)
[NinjaEdit]