Bug Hunting Session
Bug 62224 - Border Values changes on reopening the format cells Widget in impress
Summary: Border Values changes on reopening the format cells Widget in impress
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
4.0.0.3 release
Hardware: Other All
: medium normal
Assignee: David Tardon
URL:
Whiteboard: target:4.1.0 target:4.2.0 target:4.0.5
Keywords:
: 63556 (view as bug list)
Depends on:
Blocks: mab4.0
  Show dependency treegraph
 
Reported: 2013-03-12 12:13 UTC by gokul
Modified: 2018-06-23 15:04 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments
Steps to reproduce (311.16 KB, image/jpeg)
2013-03-12 12:13 UTC, gokul
Details

Note You need to log in before you can comment on or make changes to this bug.
Description gokul 2013-03-12 12:13:41 UTC
Created attachment 76395 [details]
Steps to reproduce

The Values which we set using Format Cells Widget(Right click on table->table) in impress.

If you create an table with n rows and m columns, and then set the table
border properties ( Set outer border and all inner lines) and/or line width &/or spacing between contents, The value is set properly.

But, If you open the widget again, 
-->  You will see all the inner lines will not be set(if you had selected 
outer border with all inner lines).

--> If you click cancel and then open again You will find the line spacing
to changed and also the synchronize will be checked.

--> If you click "ok" the table borders will disappear. all lines will
be removed and also the spacing between line will be changed and synchronize
will be set.

Check the Attached image, It describes the steps.

Also, The widget is titled as Format cells, Is it Correct, Should it
not be Format table.
Comment 1 Lior Kaplan 2013-03-12 15:01:27 UTC
Bug verified on 4.0.0.3 as well, changing status to new.
Comment 2 Lior Kaplan 2013-03-31 07:31:22 UTC
(In reply to comment #0)
> Also, The widget is titled as Format cells, Is it Correct, Should it
> not be Format table.

Actually format cells is correct, as you get the same dialog for changing the settings for one cell, a few or all of them ("the table"). So actually the "Table..." entry on the right click context menu should be fixed.
Comment 3 gokul 2013-03-31 07:56:37 UTC
(In reply to comment #2)
> Actually format cells is correct, as you get the same dialog for changing
> the settings for one cell, a few or all of them ("the table"). So actually
> the "Table..." entry on the right click context menu should be fixed.

Changing the string in sd/source/ui/app/popup2_tmpl.src from Table... to Format Cells... would do this.
Comment 4 Commit Notification 2013-04-02 12:05:58 UTC
Gokul committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=635f3da03a09213b3d86ced40e7e280cc03d409e

Fix related to fdo#62224.



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 5 Michael Meeks 2013-05-10 19:25:35 UTC
This is a deadly annoying bug - for sure; I was suffering it editing a table the other night and it's horrible; Gokul's fix will help but is not a full solution I think - I imagine we're populating some SfxItemSets incorrectly here ...
Comment 6 Lior Kaplan 2013-05-18 20:16:31 UTC
(In reply to comment #4)
> http://cgit.freedesktop.org/libreoffice/core/commit/
> ?id=635f3da03a09213b3d86ced40e7e280cc03d409e
> 
> Fix related to fdo#62224.

Verified commit, cancel button doesn't change the spacing values any more. The border changes still happens.
Comment 7 David Tardon 2013-05-27 14:39:39 UTC
The cells' attributes only contain the border settings that make sense for them (e.g., the top left cell can only have left or top outer border set, because the bottom and right borders are not outer); see SvxTableController::ApplyBorderAttr(). That means that SvxTableController::MergeAttrFromSelectedCells() would have to reverse that.
Comment 8 Commit Notification 2013-06-03 12:35:59 UTC
David Tardon committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=67e87f8b88a5a6a741717cc4a8e64f65f9c9cd52

fdo#62224 reconstruct border state for table dialog



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 9 Commit Notification 2013-06-03 13:12:21 UTC
David Tardon committed a patch related to this issue.
It has been pushed to "libreoffice-4-1":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=352c89983e108f687c8eed79bdac00c36c641e22&h=libreoffice-4-1

fdo#62224 reconstruct border state for table dialog


It will be available in LibreOffice 4.1.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 10 Lior Kaplan 2013-06-08 10:46:32 UTC
Commit verified, borders looks OK. This still leaves the spacing to contents fields and the synchronize checkbox which don't get the correct values (at the moment all the values are 0 and the checkbox is on).
Comment 11 ign_christian 2013-06-08 11:11:16 UTC
*** Bug 63556 has been marked as a duplicate of this bug. ***
Comment 12 David Tardon 2013-06-13 12:52:05 UTC
I added the distance too. The synchronize checkbox is internal function of the dialog page and its value is not saved anywhere. It is automatically on if all the distances are equal.
Comment 13 Commit Notification 2013-06-13 12:54:25 UTC
David Tardon committed a patch related to this issue.
It has been pushed to "libreoffice-4-1":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=36ecf35102c619b4747fc7ae9af49d4ad052ad8a&h=libreoffice-4-1

fdo#62224 set spacing to content too


It will be available in LibreOffice 4.1.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 14 Commit Notification 2013-06-13 12:54:44 UTC
David Tardon committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=14c139e3705c537556f493657f9cb01818d1f80d

fdo#62224 set spacing to content too



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 15 Commit Notification 2013-06-19 17:26:39 UTC
David Tardon committed a patch related to this issue.
It has been pushed to "libreoffice-4-0":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=2839735633dedfcbf2de77180a140eb4bf9a9c2d&h=libreoffice-4-0

fdo#62224 reconstruct border state for table dialog


It will be available in LibreOffice 4.0.5.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 16 Commit Notification 2013-06-19 17:26:57 UTC
David Tardon committed a patch related to this issue.
It has been pushed to "libreoffice-4-0":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=58c910eda00d1f3751ac1054ef2fcafe4a90abde&h=libreoffice-4-0

fdo#62224 set spacing to content too


It will be available in LibreOffice 4.0.5.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.