Bug Hunting Session
Bug 62448 - FILESAVE .ods with double size of vertically flipped (triangle) drawing shape anchored to cell
Summary: FILESAVE .ods with double size of vertically flipped (triangle) drawing shape...
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
3.4.5 release
Hardware: Other All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: BSA target:4.0.3
Keywords:
Depends on:
Blocks: Shapes
  Show dependency treegraph
 
Reported: 2013-03-17 21:50 UTC by Jori
Modified: 2019-05-05 11:48 UTC (History)
9 users (show)

See Also:
Crash report or crash signature:


Attachments
I join the document in which the problem arrives. Look triangle in columns at right. (73.05 KB, application/vnd.oasis.opendocument.spreadsheet)
2013-03-17 21:50 UTC, Jori
Details
Sample Document, only 1 shape shows bug (8.48 KB, application/x-vnd.oasis.opendocument.spreadsheet)
2013-03-18 07:09 UTC, Rainer Bielefeld Retired
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Jori 2013-03-17 21:50:33 UTC
Created attachment 76665 [details]
I join the document in which the problem arrives. Look triangle in columns at right.

I use the Draw toolbar in LibreOffice Calc.

I draw a triangle who have the point/top/summit directed downward.
If I save the document, I exit, and I open the document again, the triangle become twice as big !

If I draw a rectangle or a triangle who have the point turned upward, there is not problem !
Operating System: Linux (Other)
Version: 3.6.2.2 release
Comment 1 Rainer Bielefeld Retired 2013-03-18 07:02:55 UTC
The effect is reproducible with reporter's sample and  "LibreOffice 3.6.5.2 " German UI/ German Locale [Build-ID: 5b93205] {pull date 2013-01-18} on German WIN7 Home Premium (64bit).

1. open reporter's sample document
2. At the bottom of cell h11 you see 3 triangles. Rightclick most lef 
   (light yellow) one, 'Position and size':  width=8,1 8mm and height=8,51 mm
3. Save under new name, close, reopen
4. Check size again, group of triangles changed position and size,
   now width=16,36 mm and height=17,03 mm

The position problem might be related, but that one is already visible with LibO 3.3.3 (and OOo 2.0), and currently I do not know whether it's a FILEOPEN or a FILESAVE problem.

Due to <http://odf-validator2.rhcloud.com/odf-validator2/A reporter's sample is valid ODF

I created a more simple sample document with OOo 2.0, what shows several different triangles created always by copy / paste. 
The shape what should have been shown below "42. Anchored to cell" is the one what will be shown with wrong size after save - close - reopen.

So latest steps how to reproduce:
20. Open new spreadsheet from LibO start Center
21. To D20 draw a triangle with cell width and similar height
22. 'Rightclick -> Flip vertically'
24. 'Rightclick -> Change Anchor to Cell' if necessary
25. 'Save -> Close -> Reopen'
     Bug: double size compared to Step 21

I also tested shapes Square, Circle Pie, Diamond, they were also affected

Already Reproducible with LibO 3.4.5

@reporter:
Can you confirm my assumptions and results?

@Spreadsheet Team
Please change  Status to ASSIGNED and add yourself to "Assigned To" if you accept this Bug or forward the Bug if it's not your turf (and remove others in team from CC).
Comment 2 Rainer Bielefeld Retired 2013-03-18 07:09:24 UTC
Created attachment 76673 [details]
Sample Document, only 1 shape shows bug

See comment above how to use ("I created a more simple sample document")
Comment 3 Rainer Bielefeld Retired 2013-03-18 07:53:40 UTC
Worked fine with Server Installation of "LibreOffice 3.3.3  English UI/ German Locale [OOO330m19 (Build:301) tag libreoffice-3.3.3.1] on German WIN7 Home Premium (64bit), so regression!

For the positioning problem I submitted "Bug 62456 - Vertically flipped shape anchored to cell at wrong position when reopen .ods"
Comment 4 Noel Power 2013-03-21 12:38:26 UTC
taking this

Pretty weird effect I have to say ( also it's worse on master, most probably due to stuff I did wrt anchor handling for rotated shapes )

but.. lets tackle it first on 3.6 ( and try to understand what is going on there )
Comment 5 Commit Notification 2013-03-28 14:57:40 UTC
Noel Power committed a patch related to this issue.
It has been pushed to "libreoffice-4-0":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=2058479575e4a3e003eb1917c4f0947db9145623&h=libreoffice-4-0

hacky fix for export of cell anchored flipped custom shapes (fdo#62448)


It will be available in LibreOffice 4.0.3.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 6 Commit Notification 2013-03-29 16:17:53 UTC
LuboÅ¡ LuÅak committed a patch related to this issue.
It has been pushed to "libreoffice-4-0":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=d31d06e3d59abdc77e0b1cb5b3575d7fa5357445&h=libreoffice-4-0

Revert "hacky fix for export of cell anchored flipped custom shapes (fdo#62448)"


It will be available in LibreOffice 4.0.3.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 7 QA Administrators 2015-02-19 15:46:59 UTC Comment hidden (obsolete)
Comment 8 Buovjaga 2015-03-08 18:24:44 UTC
(In reply to Rainer Bielefeld Retired from comment #1)
> So latest steps how to reproduce:
> 20. Open new spreadsheet from LibO start Center
> 21. To D20 draw a triangle with cell width and similar height
> 22. 'Rightclick -> Flip vertically'
> 24. 'Rightclick -> Change Anchor to Cell' if necessary
> 25. 'Save -> Close -> Reopen'
>      Bug: double size compared to Step 21

Reproduced.

Win 7 Pro 64-bit, LibO Version: 4.4.1.2
Build ID: 45e2de17089c24a1fa810c8f975a7171ba4cd432
Locale: fi_FI
Comment 9 tommy27 2016-04-16 07:28:47 UTC Comment hidden (obsolete)
Comment 10 Xisco Faulí 2016-09-10 16:04:56 UTC Comment hidden (obsolete)
Comment 11 Xisco Faulí 2017-09-29 08:53:20 UTC Comment hidden (obsolete)
Comment 12 Thomas Lendo 2019-05-05 11:48:28 UTC
I can't reproduce this bug with

Version: 6.3.0.0.alpha0+
Build ID: 98630a0bd49bd80652145a21e4e0d0ded792b36b
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk3; 
TinderBox: Linux-rpm_deb-x86_64@86-TDF, Branch:master, Time: 2019-05-04_04:44:35
Locale: de-DE (de_DE.UTF-8); UI-Language: en-US
Calc: threaded

Therefore I set it as RESOLVED WORKSFORME.

If you still see this bug with Version 6.3 or later, please reopen as NEW.