Bug 62455 - Underbrace and overbrace positions and sizes broken (win only)
Summary: Underbrace and overbrace positions and sizes broken (win only)
Status: RESOLVED DUPLICATE of bug 60268
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Formula Editor (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: All Windows (All)
: low normal
Assignee: Not Assigned
URL:
Whiteboard: needsWindows8
Keywords:
: 69851 (view as bug list)
Depends on:
Blocks:
 
Reported: 2013-03-18 05:05 UTC by David Elm
Modified: 2015-03-01 08:57 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Image of the badly positioned underbrace/overbrace (1.32 KB, image/png)
2013-03-18 05:09 UTC, David Elm
Details
Screenshot (Linux) of example overbrace / underbrace formula with code (16.40 KB, image/png)
2013-11-08 21:38 UTC, Owen Genat (retired)
Details

Note You need to log in before you can comment on or make changes to this bug.
Description David Elm 2013-03-18 05:05:28 UTC
The display position of the underbrace is above and to the left of the formula (what looks like a relative (0,0) position) instead of below and centered.  

The position of the overbrace is below and to the left.

The item used in the overbrace and underbrace is positioned correctly, it is just the brace that is badly positioned.

The pdf's generated a document with these, though, are fine.
Comment 1 David Elm 2013-03-18 05:09:14 UTC
Created attachment 76669 [details]
Image of the badly positioned underbrace/overbrace

This is a screen shot of both the underbrace and overbrace behaving badly.
Comment 2 Rainer Bielefeld Retired 2013-03-18 05:27:14 UTC
NOT  reproducible with server installation of "LibO  4.0.1.2 release   -  German UI / German Locale  [Build ID: 84102822e3d61eb989ddd325abf1ac077904985)]"  {tinderbox: @6, pull time  2013-02-28 08:53(?)} on German WIN7 Home Premium (64bit) with newly created user profile ….\LibreOffice\4012\

@David Elm
@reporter:
Thank you for your report – unfortunately important information is missing.
May be hints on <http://wiki.documentfoundation.org/BugReport> will help you to find out what information will be useful to reproduce your problem? 
Please add all information requested in following:
- Write a meaningful Summary describing exactly what the problem is
- Attach a sample document (not only screenshot) or refer to an existing 
  sample document in an other Bug with a link; to attach a file to this 
  bug report, just click on "Add an attachment" right on this page.
- Contribute a document related step by step instruction containing every 
  key press and every mouse click how to reproduce your problem 
  (similar to example in Bug 43431)
– if possible contribute an instruction how to create a sample document 
  from the scratch
- add information 
  -- concerning your Operating System (Version, Distribution, Language)
  -- concerning your LibO localization (UI language, Locale setting)
  –- Libo settings that might be related to your problems 
    (video hardware acceleration, Experimental features enabled, ...)
  -- how you launch LibO and how you opened the sample document
  –- Whether your problem persists when you renamed your user profile 
     before you launch LibO (please see
     <https://wiki.documentfoundation.org/UserProfile#User_profile_location>)
  -- Whether that worked in former LibO Verions or AOOo / OOo
  -- everything else crossing your mind after you read linked texts

Please use LibreOffice menu Help → Feedback/Bugreport to report new problems you will find.
Comment 3 Owen Genat (retired) 2013-04-28 08:09:05 UTC
This AskLO thread may contain more information that is relevant to this positioning issue:

http://ask.libreoffice.org/en/question/15177/underbraces-and-overbraces/
Comment 4 QA Administrators 2013-11-04 22:17:58 UTC
Dear Bug Submitter,

This bug has been in NEEDINFO status with no change for at least 6 months. Please provide the requested information as soon as possible and mark the bug as UNCONFIRMED. Due to regular bug tracker maintenance, if the bug is still in NEEDINFO status with no change in 30 days the QA team will close the bug as INVALID due to lack of needed information.

For more information about our NEEDINFO policy please read the wiki located here: 
https://wiki.documentfoundation.org/QA/FDO/NEEDINFO

If you have already provided the requested information, please mark the bug as UNCONFIRMED so that the QA team knows that the bug is ready to be confirmed.


Thank you for helping us make LibreOffice even better for everyone!


Warm Regards,
QA Team
Comment 5 David Elm 2013-11-04 22:32:49 UTC
I'm still seeing this problem.

It's a weird one.  I see it with both the installed version and the portable apps versions of LibreOffice Writer when I'm running on the Windows 8 OS.  But when I use the exact same portable apps version of LibreOffice on a Windows 7 machine, the problem isn't there.

It could just be I have a funny install of Windows 8...  I haven't had a chance to try it out on a different Windows 8 machine.
Comment 6 Owen Genat (retired) 2013-11-08 21:38:51 UTC
Created attachment 88909 [details]
Screenshot (Linux) of example overbrace / underbrace formula with code

David, what is the Math code you are using to create the example shown in the attachment to comment#1 ? You can see in the attachment to this comment I am using:

{size +12 bold{3243}}
overbrace a over 31 newline
42 over {size +12 bold{4567}}
underbrace f

...which appears to display OK in v4.1.3.2 running under Crunchbang 11 linux. I will try and test this further today under MacOS 10.6.8 and Win7HP.
Comment 7 David Elm 2013-11-09 00:03:59 UTC
Something as simple as 

x underbrace 3

won't be rendered correctly.  When I export to PDF, it does just fine, though.  So I have a work-around.

BTW: I've tried the same thing out on a friend's Windows 8 machine and I get the same broken result.
Comment 8 Owen Genat (retired) 2014-03-15 23:09:31 UTC
*** Bug 69851 has been marked as a duplicate of this bug. ***
Comment 9 retired 2014-06-27 21:06:17 UTC
David, can you please attach a test document so this can easily be reproduced.

Does this persist with LO 4.3RC1 on windows 8.1?
http://www.libreoffice.org/download/pre-releases/

if so please back to unconfirmed.
Comment 10 David Elm 2014-06-28 16:15:31 UTC
Something as simple as "5 underbrace 5" in the equation editor in Writer will not render correctly in Windows 8.1.  

I've just updated to 4.2.5.2 to double check, and the updates so far haven't addressed this yet.
Comment 11 David Elm 2014-06-28 16:30:53 UTC
Just checked the 4.3.0.1 prerelease version of LibreOffice and it has the same issue.
Comment 12 Buovjaga 2014-11-25 08:40:39 UTC
Back to UNCONFIRMED.
Comment 13 David Elm 2014-11-25 13:32:28 UTC
Still an issue on Windows 8 (but not Windows 7) as of LibreOffice 4.3.4.1.

-David
Comment 14 Joel Madero 2014-12-30 17:15:08 UTC
This is probably the coolest bug I've seen in 3+ years...truly only affects Windows 8...so strange.

Tested on:
LibreOffice 4.3.5
Windows 8.1
Ubuntu 14.04
Windows 7

Bug ONLY appears on Windows 8

Marking as:
New
Normal - can prevent high quality/professional work
Low - while it's pretty inconvenient, it's affecting a single OS and only when using a particular feature that is not used by majority of users (formula, using specifically underbrace/overbrace)
Comment 15 Joel Madero 2014-12-30 17:45:54 UTC
Tested on 3.3 and it has the same issue. So this is inherited from OOo, updating version to reflect this.
Comment 16 Martin G. 2015-02-13 07:45:02 UTC
Duplicate Bug!
Please find the proposed solution here:
https://bugs.documentfoundation.org/show_bug.cgi?id=60268#c20

You have to delete the original font file (Windows\fonts\opens__.ttf) first and then install the modificated one (right click on the file OpenSymbol_V1.7_new2.ttf -> install).
Comment 17 Jean-Baptiste Faure 2015-03-01 08:57:24 UTC
(In reply to Martin G. from comment #16)
> Duplicate Bug!
> Please find the proposed solution here:
> https://bugs.documentfoundation.org/show_bug.cgi?id=60268#c20
> 
> You have to delete the original font file (Windows\fonts\opens__.ttf) first
> and then install the modificated one (right click on the file
> OpenSymbol_V1.7_new2.ttf -> install).

Indeed, thank you for this remark. Closing as duplicate.

Best regards. JBF

*** This bug has been marked as a duplicate of bug 60268 ***