Bug 62540 - Add styles for editing charts
Summary: Add styles for editing charts
Status: RESOLVED DUPLICATE of bug 62925
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Chart (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: All All
: medium enhancement
Assignee: Not Assigned
QA Contact:
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-03-19 22:08 UTC by Francisco
Modified: 2013-11-01 07:46 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Francisco 2013-03-19 22:08:23 UTC
One of the things I love from LibO is its ability to work with styles. There are styles for almost everithing: Text and paragraph, pages, frames in Writer, but also there are styles in Draw, Impress and Calc.

At the same time, people who works with charts, and dislike the default look, the only thing that is changeable are the serie's default colors. Any other thing is imposible, unless one create a template (or many template as needed) with the desires text and axis format.

It would be 0K to add the inability to set different default fonts, series thickness besides colors in "Tools\Options\LibreOffice Charts". 

But I think it would be even better having the ability to work with styles inside charts. At present, of course they don't exist, but also it isn't possible to use styles for shapes drawn inside charts. Any text box drawn inside a chart is always in Times New Roman (while axis and chart title are in Arial by default). And changing them is quite cumbersome since one mas use "Character" option since it isn't possible to use "Font name" button on toolbar (see bug 58038).

Maybe this is a more general problem with respect to charts in writer. IMHO they need some general improvement, with respect to this, but also bug 58038, bug 39052, bug 58260, etc) but I also understand this isn't easy at all, and that you guys, are already working with a lot of bugs, crashed, etc. But I think this could help people who, like me, work a lot with charts.
Comment 1 Francisco 2013-06-08 18:42:30 UTC
I was vivisecting an ODS file, trying to see how does LibO handle styles for charts, since it's supposed that using ODF, you're using styles even if don't want.
Charts content, as for any object are stored inside dirs "Object #", where there are 3 files: meta.xml, content.xml and styles.xml.

Interestingly, the file styles.xml doesn't store any style, but all styles defined for charts are stored in content.xml around "<office:automatic-styles>"

It seems to be that this feature request will be more difficult to solve :-(
Comment 2 stragu 2013-11-01 07:46:48 UTC
I am marking this one as a duplicate of a younger bug because it is more active.

*** This bug has been marked as a duplicate of bug 62925 ***