Bug 62637 - : Automatic Download and Installation Does not Work if Checked for Updates
Summary: : Automatic Download and Installation Does not Work if Checked for Updates
Status: RESOLVED DUPLICATE of bug 74934
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Installation (show other bugs)
Version:
(earliest affected)
3.6.6.2 release
Hardware: All Windows (All)
: high major
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
Depends on:
Blocks:
 
Reported: 2013-03-22 13:29 UTC by Harald Koester
Modified: 2016-04-28 02:34 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Harald Koester 2013-03-22 13:29:57 UTC
Problem description: 

[1] Start LO and check for updates (Menu: Help → Check for Updates...). The “Check for Updates” dialog is displayed with: „LibreOffice 4.0.1 is available.  …. The automatic download of the update is currently not available. … download LibreOffice manually from the web site.“ The automatic download is not only currently unavailable it's always unavailable. A user may assume that it will be available later. Expected: Either it should not be suggestive, that an automatic download is possible or better an automatic download is possible.

[2] Click “Download...” The LO download website page is opened with the browser.

[3] Download LO from the website. 

[4] After download the “Check for Updates” dialog is still displayed. But an installation from this dialog is not possible, the Install button is greyed. Expected: Installation starts by clicking “Install”.

Furthermore I miss how the installation of the offline help will be carried out in this update process. At least the user should be informed that the help has to be installed separately. 

And furthermore, assuming that the Install button works, I wonder if the same components are installed if a customer specific installation has been performed earlier.
              
Operating System: Windows 7
Version: 4.0.0.3 release
Comment 1 Joel Madero 2013-06-26 04:48:52 UTC
As it's still broken I tend to agree - confirmed

It may have already be fixed in 4.1 but until stable is releases and there is an update I can't test it.

Marking as NEW (confirmed) - priority seems appropriate as it's a pretty visible problem and been around for awhile
Comment 2 Joel Madero 2013-06-26 04:49:09 UTC
Forgot to say - verified on 4.0.1 with W7
Comment 3 QA Administrators 2015-04-01 14:40:54 UTC Comment hidden (spam)
Comment 4 Harald Koester 2015-07-02 21:23:29 UTC
Checked again with Version 4.4.3.2 while version 4.4.4.2 is already available. Result: "LibreOffice 4.4 is up do date." Expected: "LibreOffice 4.4.4 is available." In this case the behaviour is even worse: Already the function "Check for updates" does not work correctly.

Also checked with Version 4.3.6 while versions 4.3.7 and 4.4.4 are already available. In this case the user is informed that the version 4.3.7 is available. From my point of view this is correct because the user would get a version that is probably more stable than version 4.3.6. An enhancement may be that a user is also informed that a version with new features (4.4.4) is available, but this version may be less stable, because the number of bugfix releases is less than in his current version.

But still in the last case the automatic download and installation does not work. Hence the bug still exists.

Checked with Win7.
Comment 5 Adolfo Jayme 2016-04-28 02:34:21 UTC
This report is older than 74934, but that one has more details.

*** This bug has been marked as a duplicate of bug 74934 ***