Bug Hunting Session
Bug 62715 - FORMATTING: Format Paintbrush cannot be Used.
Summary: FORMATTING: Format Paintbrush cannot be Used.
Status: RESOLVED DUPLICATE of bug 59029
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.0.2.1 rc
Hardware: Other Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
Depends on:
Blocks:
 
Reported: 2013-03-25 07:07 UTC by Antok Budi
Modified: 2013-08-07 18:04 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Antok Budi 2013-03-25 07:07:31 UTC
Iam Using Libre Office Version 4.2.1 on Ubuntu 12:04.can not use the Format Painbrush. While the latter using Libbre Office Version 3.5.7 can still be done, Thank you for your attention.
Operating System: Ubuntu
Version: 4.0.2.1 rc
Last worked in: 3.5.7.2 release
Comment 1 Rainer Bielefeld Retired 2013-03-25 07:43:26 UTC
LibO 4.0 has several cool new features, but a PAIN-brush??? ;-)
I think it's the Format Paintbrush

NOT reproducible with server installation of "LibO  4.0.1.2 release   -  German UI / German Locale  [Build ID: 84102822e3d61eb989ddd325abf1ac077904985)]"  {tinderbox: @6, pull time  2013-02-28 08:53(?)} on German WIN7 Home Premium (64bit) with newly created user profile ….\LibreOffice\4012\

Might be a user error, behavior has changed with 4.x
DUP of
"Bug 59029 - Format Paintbrush default changed to paste character formatting"
"Bug 61577 - FORMATTING: "Format Paintbrush" function does not apply paragraph settings anymore"?

@reporter:
Thank you for your report – unfortunately important information we will 
need to reproduce your problem is missing.
May be hints on <http://wiki.documentfoundation.org/BugReport> will help you to find out what information will be useful to reproduce your problem? 
Please add all information requested in following:
- Write a meaningful Summary describing exactly what the problem is, what does
  "Can not be used" mean? Your PC will explode if you try? Nothing happens?
   Error message?
- Attach a sample document (not only screenshot) or refer to an existing 
  sample document in an other Bug with a link; to attach a file to this 
  bug report, just click on "Add an attachment" right on this page.
- Contribute a document related step by step instruction containing every 
  key press and every mouse click how to reproduce your problem 
  (similar to example in Bug 43431)
- Attach screenshots with comments if you believe that that might explain the 
  problem better than a text comment. Best way is to insert your screenshots
  into a DRAW document and to add comments that explain what you want to show
  (attachment 68877 [details], attachment 68490 [details])
– if possible contribute an instruction how to create a sample document 
  from the scratch
- add information 
  -- what EXACTLY is unexpected (see above)
  -- and WHY do you believe it's unexpected (cite Help or Documentation!)
  -- concerning your Operating System Language
  -- concerning your LibO localization (UI language, Locale setting)
  –- Libo settings that might be related to your problems
  -- how you launch LibO and how you opened the sample document
  –- Whether your problem persists when you renamed your user profile 
     before you launch LibO (please see
     <https://wiki.documentfoundation.org/UserProfile#User_profile_location>)
Comment 2 Joel Madero 2013-03-25 15:59:44 UTC
Marking as NEEDINFO as Rainer has pointed out - we need more details. Once you provide information mark as UNCONFIRMED and one of us will retest the issue.
Comment 3 Stanislav Horacek 2013-08-07 16:37:47 UTC
I can confirm that format paintbrush does not copy paragraph format in both 4.0 and 4.1 series.

Try this example:
1. Open a new Writer document.
2. Type two paragraphs.
3. Apply the 'Heading 1' style to the first paragraph and the 'Heading 3' to the second one. The first paragraph is left-aligned, the second one centered.
4. Select the first paragraph.
5. Click Format Paintbrush icon when holding Ctrl (which should ensure that paragraph formatting is copied - see documentation).
6. Select the second paragraph.
7. Character format of the second paragraph is changed, but paragraph format not - it is still centered, should be left-aligned.

Tested on Ubuntu 13.04, LO 4.0.2.2 and 4.1.0.4
Comment 4 Joel Madero 2013-08-07 16:40:33 UTC
@Stanislav Horacek - please read comments carefully - this is a feature not a bug: 

https://bugs.freedesktop.org/show_bug.cgi?id=59029#c5

*** This bug has been marked as a duplicate of bug 59029 ***
Comment 5 Stanislav Horacek 2013-08-07 18:04:10 UTC
Yes, I read this help text:

By default only the character formatting is copied ; to include paragraph formatting, hold down Ctrl when you click. To copy only the paragraph formatting, hold down Ctrl+Shift when you click.

...but I didn't realize that "click" here means "select or click the text or object", not "click the Format Paintbrush icon".

Everything works nicely if holding Ctrl when selecting the text; many thanks!