Bug Hunting Session
Bug 62716 - EDITING: CRASH of Writer, Presentation under windows 8
Summary: EDITING: CRASH of Writer, Presentation under windows 8
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
4.0.2.2 release
Hardware: Other Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
Depends on:
Blocks:
 
Reported: 2013-03-25 08:19 UTC by kevindenis
Modified: 2013-05-02 20:25 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
Error message Window (19.71 KB, image/jpeg)
2013-03-25 08:19 UTC, kevindenis
Details

Note You need to log in before you can comment on or make changes to this bug.
Description kevindenis 2013-03-25 08:19:15 UTC
Created attachment 76984 [details]
Error message Window

Problem description:
I use libre office 4.0.1.2 with a french interface, but the problem also occured with version 3.6.

When editing a file (writer, presentation), my laptop (Windows 8, 8Go RAM, Intel i5 3230) freezes and all opened windows are blocked during 30 sec to 1 min. After that problem, when I close libreOffice, an error message window appears (see hereunder)

Microsoft Visual C++ Rntime Library

Runtime Error!
Program:C\Program Files (x86)\LibreOffice4.0\program\soffice.bin

R6025
- pure virtual function call

This is problematic because such problems occurs with all current versions of libreOffice (3.6 and 4.0).

I hope you will fix this bug for next releases.

Anyway, thanks for the software you provide, I hope my comment will help you to improve LibreOffice.

Best regards,

Kevin

Steps to reproduce:
1. open document
2. editing document
3. (automatic)save document

Current behavior:
LibreOffice doesn't answer during 30 sec to 1 min and an error windo appears when I close LibreOffice.
Expected behavior:
No freezing and no error message

              
Operating System: Windows 8
Version: 4.0.1.2 release
Comment 1 Rainer Bielefeld Retired 2013-03-25 08:50:33 UTC
Modified Version due to report

Not reproducible under Win7 with 4.0.1.2!

Might be related to "Bug 38273 - EDITING: CRASH when resize movie object"?

kevindenis@outlook.com
Please contribute more detailed information like the one you see in Bug 38273 what can enable us to reproduce your problem.
Comment 2 Julien Nabet 2013-03-28 20:38:21 UTC
Do you reproduce this with a brand new file or just specific files?
Comment 3 kevindenis 2013-03-29 10:25:27 UTC
I reproduce this problem with both new and already edited files.
I can't give you more details about the steps because it is not systematic.
Comment 4 Julien Nabet 2013-05-01 20:30:49 UTC
Kevin:
did you install LO specific extensions?
did you install fonts?

do you reproduce this after having renamed your LO directory profile (see https://wiki.documentfoundation.org/UserProfile)?
Comment 5 kevindenis 2013-05-02 07:32:51 UTC
This error message (dialog box) didn't appear since I have updated LO to version 4.0.2.2.
I don't use any specific extensions and/or special font.

Anyway, LO continues to freeze when I edit a "doc" file, especially if the file is quite big.

1. Open a doc file
2. Go to page 28 on 35.
3. Cut one line
--> LO freezes during 30 seconds and it is not possible to edit the file during this time.

The file, used for this example, contains 35 pages and 8114 words (very few words per line because it is a list of my Dvd/Blu-ray collection).

Have a nice day.

Good luck and thank you to provide LO suite!

Best regards
Comment 6 Julien Nabet 2013-05-02 20:25:32 UTC
kevin: thank you for your feedback. Following your last comment I put this tracker to WFM.
About hanging problem, don't hesitate to create a new tracker (1 problem => 1 tracker to easy QA/dev job) and attach your file so we can try to reproduce.