Bug Hunting Session
Bug 62764 - Liberation fonts causing Windows 7 SP1 to BSOD
Summary: Liberation fonts causing Windows 7 SP1 to BSOD
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
4.0.5.2 release
Hardware: x86-64 (AMD64) Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Fonts-Bundled
  Show dependency treegraph
 
Reported: 2013-03-26 14:09 UTC by Chris Sherlock
Modified: 2017-10-20 18:18 UTC (History)
10 users (show)

See Also:
Crash report or crash signature:


Attachments
The Liberation fonts on my system that caused the crash (2.46 MB, application/zip)
2013-03-26 14:09 UTC, Chris Sherlock
Details
The results of analyze -v in WinDbg (5.71 KB, text/plain)
2013-03-26 14:10 UTC, Chris Sherlock
Details
systeminfo > systeminfo.txt (9.92 KB, text/plain)
2013-03-26 14:19 UTC, Chris Sherlock
Details
Exported results of msinfo to a .txt file (518.88 KB, text/plain)
2013-03-26 14:30 UTC, Chris Sherlock
Details
The Liberation fonts on my system that caused the crash (2.46 MB, application/x-zip-compressed)
2013-03-26 19:33 UTC, Chris Sherlock
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Chris Sherlock 2013-03-26 14:09:11 UTC
Created attachment 77054 [details]
The Liberation fonts on my system that caused the crash

I preface this to say: I was surprised as anyone when I discovered what was going on here...

After installing LibreOffice 4.0.1 from the LibreOffice website, I started getting BSODs. Without going through all the troubleshooting steps I had to go through to isolate the issue, I discovered via WinDbg that Windows 7 is giving a BAD_POOL_HEADER error when I loaded the fonts folder in Windows Explorer. 

I have isolated the issue to the Liberation fonts on my system, which I am attaching in a zip file. Also included is a copy of the Bugcheck Analysis on the minidump from the system. 

If you need the minidump, I'm actually happy to send it to you, but I would rather keep this off a public bugzilla due to privacy concerns (however small they may be). 

To reproduce the issue, just copy the fonts into c:\windows\fonts, then browse to this folder via Windows Explorer. You'll need Windows 7 SP1 64-bit, I've not tried on any other version as the only computer I own is this one laptop!
Comment 1 Chris Sherlock 2013-03-26 14:10:52 UTC
Created attachment 77055 [details]
The results of analyze -v in WinDbg

See also http://pastie.org/7123994
Comment 2 Michael Meeks 2013-03-26 14:14:15 UTC
Interesting, I wonder what exactly in the font provokes that; thanks for filing !
Comment 3 Chris Sherlock 2013-03-26 14:19:43 UTC
Created attachment 77056 [details]
systeminfo > systeminfo.txt

Results of systeminfo > systeminfo.txt on my laptop.
Comment 4 Chris Sherlock 2013-03-26 14:30:27 UTC
Created attachment 77057 [details]
Exported results of msinfo to a .txt file
Comment 5 Chris Sherlock 2013-03-26 14:31:10 UTC
Please note that I duplicated the results while in safe mode with no networking.
Comment 7 Linus Drumbler 2013-03-26 16:06:29 UTC
Could you please re-attach the fonts that caused the crash, this time setting the attachment type to "auto-detect" instead of plain text?
Comment 8 Chris Sherlock 2013-03-26 19:33:43 UTC
Created attachment 77076 [details]
The Liberation fonts on my system that caused the crash
Comment 9 Julien Nabet 2013-03-26 23:26:57 UTC
Comment on attachment 77054 [details]
The Liberation fonts on my system that caused the crash

Mimetype fixed
Comment 10 Adolfo Jayme 2013-03-26 23:31:44 UTC
@Julien: you do not need to re-attach files to correct mimetypes, just click "Details" next to the attachment to edit its mimetype.

BTW (sorry for this nearly pointless comment!), this bug made me remember when I was 7 and in school we used old Win98 computers, that BSOD'd when we selected the Batang font...
Comment 11 Adolfo Jayme 2013-03-26 23:34:41 UTC
(In reply to comment #10)
> @Julien: you do not need to re-attach files to correct mimetypes, just click
> "Details" next to the attachment to edit its mimetype.

Sorry, I now see yo already did that, I was confused because there's two attachments with the same name. Sorry for the noise.
Comment 12 Jonathan Harford 2013-04-08 18:11:48 UTC
My (Win7 64-bit ASUS UL30A-X5) laptop BSOD'd with BAD_POOL_HEADER while installing LibreOffice 4.0.2 yesterday. Upon reboot, LibreOffice was not in the Start Menu, and the machine would BSOD for no apparent reason within minutes of logging on -- even when in safe mode. This happened, oh, five or six times -- I reckoned the computer was a lost cause.

I figured the aborted install was related, so a little googling brought me here.

Sure enough, when I rebooted to Command Prompt and deleted Liberation*.* from C:\Windows\Fonts, the computer stopped BSOD'ing!
Comment 13 Caolán McNamara 2013-04-09 13:21:51 UTC
Seeing as the Liberation Fonts version 2+ are based on the google croscore fonts I wonder of those crash as well, or if its isolated to the Liberation Fonts
Comment 14 Pravin 2013-04-09 13:42:40 UTC
In the liberation upstream we are patching LiberatoinMono-* fonts for setting Fixedwidth bit with script setisFixedPitch-fonttools.py.

Dunno if that might be causing problem, can someone try to just removing LiberationMono fonts from fonts folder?
Comment 15 Joel Madero 2013-04-15 18:44:53 UTC
Can we mark this as NEW (confirmed)?
Comment 16 Michael Meeks 2013-04-16 09:11:15 UTC
Sure - several duplicates of it, including out there on the web :-)
Comment 17 K. Bauckmeier 2013-05-27 11:43:11 UTC
I wonder why this bug does not have the highest possible priority. I installed version 4.0.3 on 15 Clients with Windows 7-64bit SP1 and most of them crashed at least once with a BSOD, on client crashed repeatedly 2-5 Minutes after every start.
Comment 18 Michael Meeks 2013-05-27 13:49:40 UTC
> I wonder why this bug does not have the highest possible priority.

It's not a bug that we can make any progress on; this appears to be a Microsoft kernel bug - please file it with your MS representative. We can try to work around it - but it would -very- significantly help if we know what actually causes the problem (which we do not).

Failing that - please do feel free to use bisection to further narrow this down - to a single font, and then preferably to a single font feature that we can consider disabling / removing / perturbing in some way so as to avoid problems.
Comment 19 K. Bauckmeier 2013-05-31 08:54:11 UTC
Hm, I tried to reproduce the bug, but it is not as easy as I thought. I set up a new test machine in exact the way my clients are configured, but was not able to provoke the bsod. I keep on testing, but I am afraid I can't  contribute some details to this error. Sorry.

However I am not sure, if it really make sense to install the Liberation font family on windows-systems on default since normally there are Arial, Times New Roman and Courier already available.
Comment 20 kookoo 2013-06-10 18:41:52 UTC
I filed Bug 65617 which could be a different manifestation of the same bug.

Can you clarify:
- whether the crash always happens when you open the font?
- if it doesn't always crash, are there any display issues with the fonts, in Libreoffice or the Windows font preview tool?
- does the problem affect Bold and Italic versions or just the Regular version?
Comment 21 K. Bauckmeier 2013-06-12 11:42:48 UTC
In my case:
> whether the crash always happens when you open the font?
I had 15 clients. In most cases the crash happend only once, about 1-5 Minutes after first booting/ installation of LibreOffice. One client crashed repeatedly in thunderbird. But I assume there was no connection to the program it just happened to be open at the time, because the user tried to send an email again and again.

> if it doesn't always crash, are there any display issues with the fonts, in Libreoffice or the Windows font preview tool?
I don't know.
> does the problem affect Bold and Italic versions or just the Regular version?
I don't know.
Comment 22 it 2013-08-21 09:57:19 UTC
I can also confirm this bug.

Some time ago we tried rolling out 4.0.something and had on may PCs bluescreens. Because we had no time to dig deeper, we went back to 3.5.6.

Last week we started rolling out 4.1.0.4 what worked fine on all Test-PCs including my own PC here at work. But after rolling out 4.1 on 25 computers, we had 5 with one bluescreen after reboot (and it didn't come back yet) and on 2 we had continuous every 5-10 mins after reboot. So we stopped the rollout (we don't want to get trouble when installing on 200 computers).

I'll try to do some testings with the font files, too. For the first I wanted to confirm the bug and say that it still exist in 4.1.0.4.
Comment 23 Michael Meeks 2013-08-21 10:14:55 UTC
> But after rolling out 4.1 on 25 computers. But after rolling out
> 4.1 on 25 computers

In general a 4.x.0 release is not a great plan to roll out on lots of computers :-) I'd wait until 4.x.2 - it's really an initial release to get wider testing of all the new features: that is, unless you want to get involved in early testing / bug reporting :-)

Having said that - there is still zero feedback from Microsoft on this issue and/or how to work around it - which is somewhat irritating. It is emphatically not a LibreOffice issue; we'd like to work around it - but ideally not at the expense of dropping the Liberation fonts.
Comment 24 Lothar Haeger 2013-09-04 15:19:29 UTC
(In reply to comment #18)

> We can try to work around it 

So please do it: make the liberation fonts a (non-preselected) optional component in the installer. Easy.

Until you get there anyone can do it by opening the MSI in Orca (-> http://msdn.microsoft.com/en-us/library/windows/desktop/aa370557%28v=vs.85%29.aspx or an alternative MSI editor) and deleting the Liberation font entries from the "Font" table. Save and install, no more bluescreens (and I tested every 4.x release on my machine over the last months and never even got the installer so complete sucessfully).
Comment 25 Marc Muehlfeld 2013-09-24 07:58:45 UTC
(In reply to comment #24)
> Until you get there anyone can do it by opening the MSI in Orca (->
> http://msdn.microsoft.com/en-us/library/windows/desktop/aa370557%28v=vs.
> 85%29.aspx or an alternative MSI editor) and deleting the Liberation font
> entries from the "Font" table. Save and install, no more bluescreens (and I
> tested every 4.x release on my machine over the last months and never even
> got the installer so complete sucessfully).

I followd your instruction and tried exactly these steps with 4.1.1.2 and installed the modified msi on 6 machines. 5 were fine and one got a bluescreen again ("bad pool header"). So this workaround doesn't fixed the problem here.


If really the fonts are the part that causes the bluescreen, can't they be easily made optional in the installer?
Comment 26 Pravin 2014-01-03 09:19:05 UTC
As i said in https://bugs.freedesktop.org/show_bug.cgi?id=62764#c14 Only thing different we did in liberation 2.00 is fixing isFixedPitch bit by fonttools script. 

I have done test release by removing fonttools script. 

1. http://pravins.fedorapeople.org/liberation-fonts-ttf-2.00.2-test.tar.gz
2. http://pravins.fedorapeople.org/liberation-fonts-2.00.2-test.tar.gz

Can someone test LibreOffice with liberation fonts this release? so at least we will know whether this is happening because of fonttools script or something other problem.
Comment 27 Julien Nabet 2015-04-19 11:55:14 UTC
Chris: any update with recent LO version (4.4.2 or at least 4.3.6)?
If you still reproduce this, could you attach an updated bt?
Comment 28 Yousuf Philips (jay) (retired) 2015-05-01 22:09:09 UTC
I just installed 4.4.2 on my Windows 7 SP1 64-bit machine with the default settings and didnt have any problems and browsing through the Windows Fonts folder didnt cause a crash either. Setting to WORKSFORME and if Chris or others are still having the problem, please reopen, though this seems to be NOTOURBUG.