Download it now!
Bug 79754 - new ODF template files on windows are not using liberation fonts as default
Summary: new ODF template files on windows are not using liberation fonts as default
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
4.3.0.0.beta2
Hardware: Other Windows (All)
: high minor
Assignee: Not Assigned
URL:
Whiteboard: target:6.0.0
Keywords:
Depends on:
Blocks: Fonts Desktop-Integration
  Show dependency treegraph
 
Reported: 2014-06-06 23:48 UTC by Yousuf Philips (jay) (retired)
Modified: 2019-03-15 02:15 UTC (History)
7 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Yousuf Philips (jay) (retired) 2014-06-06 23:48:13 UTC
After reviewing bug 77563, I checked right-clicking on the Windows Desktop, selecting new and then OpenDocument Writer, Spreadsheet, or Presentation and they create default odf files with default fonts as Times New Roman and Arial rather than Liberation Serif and Liberation Sans. Tested with 4.2.4 installed, but this should be fixed for the 4.2.5 and 4.3 releases.
Comment 1 pierre-yves samyn 2014-06-10 12:32:11 UTC
Hi

The system performs only a copy of a template document. This explains why creation is so fast and does not require opening software.

Simply modify or replace this template document.

Depending on your version of windows and your choice of installation (installation for you alone or for all users) the path to the document could be:

C:\Documents and Settings\All Users\Templates (XP)
C:\Documents and Settings\username\Templates (XP)
C:\ProgramData\Microsoft\Windows\Templates (Windows 7)
C:\Program Files (x86)\LibreOffice 4\share\template\shellnew
etc.

Note: you will need to have administrator rights to modify this document (Windows7)

Regards
Pierre-Yves
Comment 2 pierre-yves samyn 2014-06-10 12:39:15 UTC
HI again

Sorry Jay, I made a mistake, I had the two bugs opened and I sent my reply in the wrong. so, I put the same answer in both ...

I reproduce the bug indicated for fonts...

Regards
Pierre-Yves
Comment 3 Yousuf Philips (jay) (retired) 2014-06-10 14:47:28 UTC
Hey Pierre-Yves,

Not a problem. I've done it also. :)

@jmadero: @qubit: i think this is an import thing to be dealt with for the next releases, and should have been caught since LibO began shipping Liberation fonts, as it relates to LibreOffice's fighting against font lockin. I was planning to add this to MAB and increase its priority, but i'll leave that up to you guys to decide.
Comment 4 Robinson Tryon (qubit) 2014-06-10 15:02:40 UTC
(In reply to comment #3)
> @jmadero: @qubit: i think this is an import thing to be dealt with for the
> next releases, and should have been caught since LibO began shipping
> Liberation fonts, as it relates to LibreOffice's fighting against font
> lockin.

Hmm...that is unexpected. I definitely agree that these templates should be using a Free font. I'm not in front of a Windows machine right now, so I can't verify myself.

> I was planning to add this to MAB and increase its priority, but
> i'll leave that up to you guys to decide.

I wouldn't be wholly opposed to adding it to the MAB. It seems like something pretty simple to fix, but perhaps there's more going on here than I expect at first glance.
Comment 5 Yousuf Philips (jay) (retired) 2014-06-10 16:06:02 UTC
(In reply to comment #4)
> Hmm...that is unexpected. I definitely agree that these templates should be
> using a Free font. I'm not in front of a Windows machine right now, so I
> can't verify myself.

Look forward to your verification.

> I wouldn't be wholly opposed to adding it to the MAB. It seems like
> something pretty simple to fix, but perhaps there's more going on here than
> I expect at first glance.

:)
Comment 6 pierre-yves samyn 2014-06-10 16:07:39 UTC
(In reply to comment #4)
> I wouldn't be wholly opposed to adding it to the MAB. It seems like
> something pretty simple to fix, but perhaps there's more going on here than
> I expect at first glance.

Maybe we should expand the problem because there may be other "news" not reflected in these older models (I think for example the default number of sheets 3 to 1 for spreadsheet)

Regards
Pierre-Yves
Comment 7 Yousuf Philips (jay) (retired) 2014-06-10 19:56:04 UTC
(In reply to comment #6)
> Maybe we should expand the problem because there may be other "news" not
> reflected in these older models (I think for example the default number of
> sheets 3 to 1 for spreadsheet)

Yes a rethinking of alot of the old norms is quite important. i never understood why ms excel loaded with three blank sheets, as if i needed more, i know i can add more. It would be like opening ms word and each new document had 3 pages, just doesnt make sense to me.

personally i think the toolbars need to be refined heavily, as it blows my mind that insert picture/media isnt part of the standard toolbar. The standard toolbars really need to be molded to what people use more frequently, as i definitely use insert photo more than insert hyperlink. :)
Comment 8 pierre-yves samyn 2014-06-11 16:20:47 UTC
Hi

(In reply to comment #7)
> (In reply to comment #6)
> Yes a rethinking of alot of the old norms is quite important

I can only agree but this is not what I meant :)

I meant create a spreadsheet with right-clicking on the windows desktop creates a 3 sheets spreadsheet, that is no longer the default format (1 sheet).

So there is not only the fonts problem, there are probably other outdated options in those templates.

> it blows my mind that insert picture/media isnt part of the standard toolbar

Yes but it is in the Drawing toolbar... which also makes sense.

Regards
Pierre-Yves
Comment 9 Yousuf Philips (jay) (retired) 2014-06-11 17:49:10 UTC
(In reply to comment #8)
> Yes but it is in the Drawing toolbar... which also makes sense.

i dont see the relationship between a drawing toolbar and inserting an image. when you open up writer for the first time, you are given the standard and formatting toolbars. In stardard, you get the options to insert a hyperlink, table, and gallery art, but no button for inserting an image. if you look on the writer logo, you see text and an image, which is why its so hilarious not to see it in the standard toolbar.
Comment 10 Andras Timar 2015-05-01 15:17:37 UTC
Related: bug 62764 -- Liberation fonts causing Windows 7 SP1 to BSOD.

Why take the risk?
Comment 11 Robinson Tryon (qubit) 2015-05-01 18:12:05 UTC
(In reply to Andras Timar from comment #10)
> Related: bug 62764 -- Liberation fonts causing Windows 7 SP1 to BSOD.
> 
> Why take the risk?

In general we'd like to encourage use of the freely-licensed font over the proprietary alternative, however bug 62764 is pretty serious!

That said, the last comment confirming the BSoD w/Liberation fonts was quite a while ago (2013-09-24), so if we can't get any confirmation of continued font problems in our latest builds over the next month or so, I'd suggest that we tentatively move forward with using the Liberation fonts once again.
Comment 12 Timur 2016-04-05 11:30:38 UTC
Still a problem as described in Comment 0. 
Explanation from Comment 1 is not logical, templates shouldn't be there, but in LO profile folder?
Comment 13 pierre-yves samyn 2016-04-22 10:45:34 UTC
Hi

Still reproduced on windows 7/64 & Version: 5.2.0.0.alpha1 (x64)
Build ID: 902b28a39528b6c92602e9b521a1d0861be1caf9
Threads CPU : 2; Version de l'OS :Windows 6.1; UI Render : par défaut; 
Locale : fr-FR (fr_FR)

(In reply to Timur from comment #12)
> Explanation from Comment 1 is not logical, templates shouldn't be there, but
> in LO profile folder?

I agree that installing templates in the LO profile would be good (allow personalization) but IMHO this is the current install procedure that is perfectible and not my explanation is not logical :)

Regards
Pierre-Yves
Comment 14 Yousuf Philips (jay) (retired) 2017-10-13 20:23:46 UTC
Stuart, Maxim: Do you know where these template files are so they can be modified?
Comment 15 Chavdar 2017-10-16 18:29:08 UTC
LO 5.3.6.1 (x64), Win10 x64

I can confirm that the newly created document has default font Times New Roman
Comment 16 Yousuf Philips (jay) (retired) 2017-10-20 19:53:38 UTC
patch - https://gerrit.libreoffice.org/43625
Comment 17 Roeland 2017-11-06 08:11:07 UTC
Is this bug fixed with this patch?
Comment 18 Yousuf Philips (jay) (retired) 2017-11-06 08:58:49 UTC
(In reply to Roeland from comment #17)
> Is this bug fixed with this patch?

Patch is still pending review.
Comment 19 Commit Notification 2017-11-20 19:03:51 UTC
Yousuf Philips committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=2a33c69b16cce539951a796d7afa45c13b097cf6

tdf#79754 updated windows shellnew template files

It will be available in 6.0.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.