Download it now!
Bug 62808 - FILEOPEN, FILESAVE create document as odt, save as docx , corrupts images
Summary: FILEOPEN, FILESAVE create document as odt, save as docx , corrupts images
Status: RESOLVED DUPLICATE of bug 52226
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.0.1.2 release
Hardware: Other Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-03-27 12:41 UTC by Winfried Donkers
Modified: 2013-05-13 06:53 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Winfried Donkers 2013-03-27 12:41:10 UTC
Way to reproduce (see attachments):
1. start new writer document
2. insert-image-from file..
3. select png image
4. save as dd1.odt
5. save as dd1-1.docx
6. close dd1-1.docx
7. open dd1.odt - shows as expected
8. save as dd1-2.docx
9. close dd1-2.docx
10. open dd1.odt - shows as expected
11. open dd1-1.docx - shows error where image should be visible
12. open dd1-2.docx - shows as expected

It seems that saving a new document as docx results in a corrupted docx where saving an existing odt as docx does not.
Comment 1 Timur 2013-05-10 16:55:43 UTC
Same as Bug 63059 so DUPLICATE but I think it should be marked as duplicate of Bug 52226 because it's earlier.
Comment 2 Timur 2013-05-10 17:02:12 UTC
Sorry, didn't check https://bugs.freedesktop.org/show_bug.cgi?id=60922, so many similar reports. Please take a look at https://bugs.freedesktop.org/show_bug.cgi?id=63059.
Comment 3 Winfried Donkers 2013-05-13 06:53:25 UTC
(In reply to comment #1 and comment #2)
Timur, thank you for comparing and trying to match all these bug reports with docx. There are indeed a lot of these and the differences are often hard to find (or similar from a user POV, but quite different with respect to the developer).

Problem of this bug is still present with version 4.0.3 (tested on Windows XP), so fixes for other bugs (like bug 60922) have not fixed this problem.

This bug report seems to be a duplicate of bug 52226 indeed; I have marked this bug as such.

I don't know if bug 63059 is also a duplicate, I leave that to the reporter of bug 63059.

*** This bug has been marked as a duplicate of bug 52226 ***