Download it now!
Bug 63059 - FILESAVE FILEOPEN LO saves corrupt docx files with images
Summary: FILESAVE FILEOPEN LO saves corrupt docx files with images
Status: RESOLVED DUPLICATE of bug 52226
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.0.1.2 release
Hardware: x86-64 (AMD64) All
: high normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-04-03 07:29 UTC by Milos Sramek
Modified: 2013-11-13 20:15 UTC (History)
0 users

See Also:
Crash report or crash signature:


Attachments
File to reproduce the problem (16.33 KB, application/vnd.oasis.opendocument.text)
2013-04-03 07:29 UTC, Milos Sramek
Details
Screenshot with the corrupt docx file opened (96.08 KB, image/png)
2013-04-03 07:31 UTC, Milos Sramek
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Milos Sramek 2013-04-03 07:29:53 UTC
Created attachment 77355 [details]
File to reproduce the problem

If a document with images is saved as docx after being saved to odt, the docx file is corrupt (no images)

To reproduce:
1. open the attached document
2. change it
3. save it (as odt)
4. save as docx
5. close the document
6. open the docx version: images are  missing

Reproduced also on Windows
No problems in LO3.6 on Linux
If step 3 is omitted, the docx file is OK

--
Milos
Comment 1 Milos Sramek 2013-04-03 07:31:02 UTC
Created attachment 77359 [details]
Screenshot with the corrupt docx file opened
Comment 2 Brenda Granados 2013-04-04 14:01:32 UTC
Hi, thank you for submitting a bug report. After following your steps with a brand new document, I am able to reproduce this issue.  I am increasing the priority to Normal - High, because this could be a big problem for someone who saves a document as a .docx with images- and finds they are not there when reopening the document.


Version: 4.0.2.1 (Build ID: 7e5467ff8f30d821f4fbf69cb2769163eb64c2c)
Platform: Ubuntu Linux 12.04 LTS x64


-Brenda

--------------------------------------------
LibreOffice is powered by a team of volunteers, every bug is confirmed (triaged) by human beings who mostly give their time for free. We invite you to join our triaging by checking out this link: https://wiki.documentfoundation.org/QA/BugTriage  There are also other ways to get involved including with marketing, UX, documentation, and of course developing -  http://www.libreoffice.org/get-help/mailing-lists
Comment 3 Timur 2013-05-10 16:46:47 UTC
Please check Bug 52226 and see whether you can mark this one as DUPLICATE, because Bug 52226 is earlier. 
If so, please write your steps to reproduce there, because they are nice and clear.
Comment 4 Timur 2013-05-10 16:59:46 UTC
Sorry, check also https://bugs.freedesktop.org/show_bug.cgi?id=60922 and https://bugs.freedesktop.org/show_bug.cgi?id=62808, so many similar reports.
Comment 5 Timur 2013-05-15 15:33:56 UTC
According to comment on https://bugs.freedesktop.org/show_bug.cgi?id=52226#c12 - I think it refered to Bug 63059  and not to Bug 63058, I close this one as a duplicate. 
Please feel free to reopen if not fixed in Bug 52226.

*** This bug has been marked as a duplicate of bug 52226 ***