Download it now!
Bug 62981 - FILEOPEN: Speadsheet display nothing in file xls on ftp sever
Summary: FILEOPEN: Speadsheet display nothing in file xls on ftp sever
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
3.5.7.2 release
Hardware: Other Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
Depends on: 64223
Blocks:
  Show dependency treegraph
 
Reported: 2013-04-01 07:37 UTC by Tuyen Tang
Modified: 2013-11-22 05:23 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Tuyen Tang 2013-04-01 07:37:13 UTC
Problem description: 

Steps to reproduce:
1. Connect ftp file server using nautilus
2. Double-click to open file

Current behavior:
  - Display blank cells as opening by double-click. However, Libreoffice only open that file by using "Open" function in Menu -> File
Expected behavior:
  - Display as opening file in local disk
              
Operating System: Ubuntu
Version: 3.5.7.2 release
Comment 1 Robinson Tryon (qubit) 2013-11-17 07:53:49 UTC
Unable to complete test (using LO 3.5.7 + Nautilus 3.4.2 + Ubuntu 12.04.3).

* Installed VSFTPD: https://help.ubuntu.com/12.04/serverguide/ftp-server.html

* No test file indicated or attached so I used:
http://cgit.freedesktop.org/libreoffice/contrib/test-files/tree/calc/tab-color.xls

REPRO STEPS:

* Log-in to the ftp server (anonymous) via Nautilus
* Double-click on tab-color.xls file

Immediately get error "General input/output error while accessing /home/qubit/.gvfs/FTP on localhost/tab-color.xls."


I'm not sure how to test this one (and Joel got the same error), so changing status to NEEDINFO.
Comment 2 Robinson Tryon (qubit) 2013-11-17 07:56:08 UTC
(In reply to comment #1)
> Unable to complete test (using LO 3.5.7 + Nautilus 3.4.2 + Ubuntu 12.04.3).
> ... 
> Immediately get error "General input/output error while accessing
> /home/qubit/.gvfs/FTP on localhost/tab-color.xls."
> 

The error Joel and I saw is reported as bug 64223. It's unclear if Tuyen's problem has the same root cause as that bug or if it's unrelated (and we're unable to get close to it to fix it because of bug 64223).
Comment 3 Tuyen Tang 2013-11-19 02:24:36 UTC
(In reply to comment #2)
> (In reply to comment #1)
> > Unable to complete test (using LO 3.5.7 + Nautilus 3.4.2 + Ubuntu 12.04.3).
> > ... 
> > Immediately get error "General input/output error while accessing
> > /home/qubit/.gvfs/FTP on localhost/tab-color.xls."
> > 
> 
> The error Joel and I saw is reported as bug 64223. It's unclear if Tuyen's
> problem has the same root cause as that bug or if it's unrelated (and we're
> unable to get close to it to fix it because of bug 64223).

I didn't get any errors. My speadsheet just show nothing
Comment 4 Tuyen Tang 2013-11-19 02:24:54 UTC
(In reply to comment #2)
> (In reply to comment #1)
> > Unable to complete test (using LO 3.5.7 + Nautilus 3.4.2 + Ubuntu 12.04.3).
> > ... 
> > Immediately get error "General input/output error while accessing
> > /home/qubit/.gvfs/FTP on localhost/tab-color.xls."
> > 
> 
> The error Joel and I saw is reported as bug 64223. It's unclear if Tuyen's
> problem has the same root cause as that bug or if it's unrelated (and we're
> unable to get close to it to fix it because of bug 64223).

I didn't get any errors. My speadsheet just showed nothing
Comment 5 Joel Madero 2013-11-19 02:35:08 UTC
With LibreOffice 4.1?
Comment 6 Robinson Tryon (qubit) 2013-11-19 02:37:17 UTC
Florian R. - Can you try to repro here?
Comment 7 Tuyen Tang 2013-11-19 04:19:19 UTC
(In reply to comment #5)
> With LibreOffice 4.1?

Yes, it is
Comment 8 Florian Reisinger 2013-11-19 17:59:17 UTC
Tested it on Windows
1) LibO has a password manager with a master password - cool
2) "Allgemeiner Ein-/Ausgabefehler" (In Output Error Version: 4.1.3.2
Build ID: 70feb7d99726f064edab4605a8ab840c50ec57a)
No error in LibreOffice 3.3.4 
OOO330m19 (Build:401)
tag libreoffice-3.3.4.1
bur writer opened with an empty file

WORKING
Version: 4.2.0.0.alpha1+
Build ID: f99736820a23cb7e37139607713658dea1c69dd4
TinderBox: Win-x86@47-TDF, Branch:master, Time: 2013-11-17_23:56:08

IMHO RESOLVED -> WFM
Available with 4.2
Comment 9 Joel Madero 2013-11-19 18:29:49 UTC
Hm - the only thing is that this bug is about nautilus so Windows test perhaps not super useful ?
Comment 10 Florian Reisinger 2013-11-19 18:32:03 UTC
Joel: Same error on Win... If it is a NAutilus problem, it is not a LibO problem ;)
So it is helpful -> Same error on Win with 4.1
No error with 4.2 -> So Pls check with a Linux daily....
Comment 11 Joel Madero 2013-11-19 18:32:37 UTC
Will do - going to test with 4.2 built just a few days ago
Comment 12 Arnaud Versini 2013-11-21 00:50:33 UTC
So I tested, results :

General IO error after 2 minutes for me on master.
No issue if I use the GTK dialog for opening the file.

Really slow, but copying from Nautilus is really fast.
Comment 13 Florian Reisinger 2013-11-21 06:32:47 UTC
Okay, WHAT exactly is slow.
Today i reopened the file online in seconds: Branch:master, Time: 2013-11-17_23:56:08
I haven't tested yet with LibreOffice dialogue, but the LibO part SHOULD work....
Comment 14 Joel Madero 2013-11-21 14:23:48 UTC
The splashscreen hangs Florian in Linux - I brought it up in the dev channel and they said it could indeed be our problem but we have to wait for the I/O issue to be solved before testing it :-/
Comment 15 Florian Reisinger 2013-11-21 14:32:07 UTC
Joel, the IO Error is fixed with the Dev Build I used (on Windows)....
Comment 16 Joel Madero 2013-11-21 14:44:58 UTC
I will test again as soon as my master build finishes - but the issue is that the new nautilus doesn't have an open with "other" option and I can't for the life of me figure out how to add an open with my soffice.bin from my master build, without that I can't really test it against my master build. Then on top of it our daily debian packages are broken (already known and being looked into by Cloph) so I can't test that way.
Comment 17 Maxim Monastirsky 2013-11-21 15:19:18 UTC
Hi all,

For me the 'General input/output error while accessing' error occurs only when the .desktop file doesn't contain 'X-GIO-NoFuse=true'. Otherwise the file opens without any problem. Another solution is to remove 'gvfs-fuse' package (and logout - login)

Tested with:
Ubuntu 12.04.2 (64-bit) LiveCD & LO 3.5.4.2
Fedora 19 (64-bit) & LO 4.1.3.2

When X-GIO-NoFuse is set, LO gets 'ftp://localhost/filename.xls' as argument, and it deals *itself* with the connection to the server. When it isn't set, LO gets '~/.gvfs/FTP on localhost/filename.xls' as argument (if gvfs-fuse is installed).

Note that starting with 4.1 'X-GIO-NoFuse' is defined in the .desktop file, so users won't get this error anymore (unless someone decides to edit his .desktop file).

If someone still couldn't open a file from ftp even if 'X-GIO-NoFuse' is defined, probably he is missing some libgnomevfs2\gvfs packages.
Comment 18 Maxim Monastirsky 2013-11-21 15:21:47 UTC
(In reply to comment #16)
> Then on top of it our daily debian packages are broken (already known and
> being looked into by Cloph) so I can't test that way.
Already fixed yesterday: http://cgit.freedesktop.org/libreoffice/core/commit/?id=65a7e714292dbf4c5a2a4f5760f3b546d603c40c
Comment 19 Florian Reisinger 2013-11-21 15:26:30 UTC
What I did: File -> Open -> Connect to ftp in Windows Explorer
Seeing that there is a different problem described - sorry. Maybe dragging onto soffice(.exe)

Drag and drop is impossible @ Windows
Double-click will download the file with default web browser
Sorry for confusion
Comment 20 Maxim Monastirsky 2013-11-21 15:37:31 UTC
(In reply to comment #17)
> If someone still couldn't open a file from ftp even if 'X-GIO-NoFuse' is
> defined, probably he is missing some libgnomevfs2\gvfs packages.
Or he didn't pass --enable-gnome-vfs\--enable-gio to the configuration script.
Comment 21 Maxim Monastirsky 2013-11-21 15:47:55 UTC
(In reply to comment #16)
> I will test again as soon as my master build finishes - but the issue is
> that the new nautilus doesn't have an open with "other" option and I can't
> for the life of me figure out how to add an open with my soffice.bin from my
> master build, without that I can't really test it against my master build.
Just make a copy of the .desktop file, adjust the path, and place it to /usr/share/applications. Then it should appear in 'Open with' sub-menu.
Comment 22 Joel Madero 2013-11-22 05:23:47 UTC
I have FINALLY been able to fully test this bug and I do not see the problem.

Steps:
I connected to this: ftp://ftp.bls.gov/pub/special.requests/ep/emp.requirement (public ftp)
Opened sect_industry_x195.xls


Worked fine. 


LibreOffice Daily Build http://dev-builds.libreoffice.org/daily/master/Linux-rpm_deb-x86_64@46-TDF/

Nautilus 3.8.2

So when 4.2 is released it should work, if it doesn't, then it's not our bug, it's Nautilus but 3.8.2 or newer should work just fine.