Bug 64223 - FILEOPEN: 'General input/output error' when opening file from ftp
Summary: FILEOPEN: 'General input/output error' when opening file from ftp
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
(earliest affected)
3.5.0 release
Hardware: Other All
: medium normal
Assignee: Not Assigned
Whiteboard: target:4.1.0
Depends on:
Blocks: 62981
  Show dependency treegraph
Reported: 2013-05-04 22:14 UTC by Vitaly
Modified: 2013-11-21 22:35 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Note You need to log in before you can comment on or make changes to this bug.
Description Vitaly 2013-05-04 22:14:38 UTC
I've got an error when opening a document from a nautilus-mounted ftp:
'General input/output error while accessing <path/to/doc>'.

Documents located on my pc open without any problems.
I've also tryed to mount an ftp share using curlftpfs and got the same error.

openSUSE Linux 11.4
Gnome 2.32.1
Libreoffice 3.5
Comment 1 news4roland 2013-06-05 10:09:35 UTC
Same on Windows 7 Professional 64-bit, Windows 8 Pro 64-bit

LibreOffice (Build ID: 0eaa50a932c8f2199a615e1eb30f7ac74279539)
LibreOffice Build ID: 5271b34bec742e190e2fe5a7dadb7334a705b54

Opening a document in Writer (for example) File - Open - ftp://server/document.odt causes the same error.

Reason: LibreOffice wants to write a temporary file on C: instead of writing to the temp-directory of the user. Writing and deleting directly on C: is not allowed in Win 7 and 8 as normal user, only as admin.
Comment 2 tommy27 2013-08-31 16:04:22 UTC
changing status to NEW and platform to ALL according to previous comment.
Comment 3 Alex Thurgood 2013-09-25 08:03:29 UTC
Confirming also on Linux Ubuntu Raring Ringtail 32bit

Before I get the general input/output error, I also get a "This file is corrupted...do you want LO to repair it, blah blah blah" message.

Comment 4 Maxim Monastirsky 2013-11-21 22:35:40 UTC
Should be already fixed in 4.1 with http://cgit.freedesktop.org/libreoffice/core/commit/?id=f574e1defdb537bdd741edd2523563aa0b03be5a. Opening with gvfs-fuse mounted path is not supported by LO, see https://bugzilla.redhat.com/show_bug.cgi?id=885156#c19. Probably a duplicate of some bug, but I'm not going to search for it now. Bug 58236 might be also a duplicate.