Bug 63025 - Copying chart to Writer looses data/ changes diagram type
Summary: Copying chart to Writer looses data/ changes diagram type
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Chart (show other bugs)
Version:
(earliest affected)
4.0.1.2 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
: 63300 114368 (view as bug list)
Depends on:
Blocks: Chart Paste
  Show dependency treegraph
 
Reported: 2013-04-02 13:19 UTC by mahfiaz
Modified: 2019-03-28 18:57 UTC (History)
7 users (show)

See Also:
Crash report or crash signature:


Attachments
ODS document with chard representing the problem. (26.56 KB, application/vnd.oasis.opendocument.spreadsheet)
2013-04-02 13:19 UTC, mahfiaz
Details

Note You need to log in before you can comment on or make changes to this bug.
Description mahfiaz 2013-04-02 13:19:10 UTC
Created attachment 77315 [details]
ODS document with chard representing the problem.

Open the attached document. Select and copy diagram, open a new writer document, paste. Charts don't look not even similar.
Comment 1 mahfiaz 2013-04-02 13:23:00 UTC
Happens in 4.0.2.2 as well.
Comment 2 Thomas van der Meulen 2013-04-02 13:44:33 UTC
Thank you for reporthing this bug,
I can reproduce this bug running LibreOffice 4.0.2.2 on Mac osx 10.8.3. 

I also have changed the name of the bug.
Comment 3 bugquestcontri 2013-05-27 07:48:51 UTC
I observe problems on XP Prof/ SP3.

See comment 8 of https://bugs.freedesktop.org/show_bug.cgi?id=61805
Comment 4 ign_christian 2013-06-11 04:08:05 UTC
*** Bug 63300 has been marked as a duplicate of this bug. ***
Comment 5 ign_christian 2013-06-11 04:28:36 UTC
Still reproducible on LO 4.0.4.1 (Win7 32bit). 

Similar to Bug 63017 (on XY chart), copying to Impress produces same result. 
-> so I think it should moved to component: Chart
Comment 6 A (Andy) 2015-03-07 20:43:32 UTC
Reproducible with LO 4.4.1.2, Win 8.1
Comment 7 tommy27 2016-04-16 07:28:01 UTC Comment hidden (obsolete)
Comment 8 mahfiaz 2016-04-16 07:59:15 UTC
Still an issue in 5.1.2.1 (current Fresh build).
Comment 9 QA Administrators 2017-05-22 13:25:31 UTC Comment hidden (obsolete)
Comment 10 m.a.riosv 2017-12-10 01:52:10 UTC
*** Bug 114368 has been marked as a duplicate of this bug. ***
Comment 11 Ian 2018-03-25 20:09:39 UTC
Still an issue in version 6.0.2.1

(Build ID: 1:6.0.2~rc1-0ubuntu0.16.04.1~lo1)

I would also argue it is potentially a major bug given it affects basic functionality and interaction within LO.

Being able to update Calc and have linked charts in Writer docs automatically update would be a major productivity gain for multiple use cases.

Anyone creating periodic documents based on updated data and analysis would only need to update the spreadsheet charts rather than then have to copy-paste each chart as bitmap.

I would fund a bug bounty to see this bug squashed if it was possible.
Comment 12 QA Administrators 2019-03-27 03:40:52 UTC Comment hidden (obsolete)
Comment 13 mahfiaz 2019-03-27 11:30:14 UTC
This has been fixed. Works like a charm in 6.1.4.2.
Comment 14 Xisco Faulí 2019-03-28 18:57:49 UTC
(In reply to mahfiaz from comment #13)
> This has been fixed. Works like a charm in 6.1.4.2.

Thanks for retesting with the latest version.
Setting to RESOLVED WORKSFORME as the commit fixing this issue hasn't been identified.