Bug 63223 - Extension failures in LibreOffice 4.0 (on upgrade)
Summary: Extension failures in LibreOffice 4.0 (on upgrade)
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
4.0.2.2 release
Hardware: Other All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: regression
Depends on:
Blocks:
 
Reported: 2013-04-07 07:21 UTC by andis.lazdins
Modified: 2014-02-02 10:24 UTC (History)
6 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Sample file emonstrating crash on entering formula (79.86 KB, application/vnd.oasis.opendocument.spreadsheet)
2013-04-07 07:21 UTC, andis.lazdins
Details

Note You need to log in before you can comment on or make changes to this bug.
Description andis.lazdins 2013-04-07 07:21:46 UTC
Created attachment 77549 [details]
Sample file emonstrating crash on entering formula

Version 4.0.2.2 (Build ID: 4c82dcdd6efcd48b1d8bba66bfe1989deee49c3) Ubuntu Linux 12.04, Kernel 3.2.0-40-generic-pae, MATE 1.6.0

Steps to reproduce:
1. Open attached file
2. Select cell BC4 (or any other in this column or any other column after it)
3. Write "=" without quotation marks.

Libreoffice constantly crashes.
The problem can be reproduced also by writing "=" anywhere else in the attached file. No problems appears in 3.6.5 with the same file.
Comment 1 Jorendc 2013-04-07 22:19:44 UTC
Hi,

Thanks for reporting.

I can not reproduce a crash using Linux Mint 14 x64 with LibreOffice Version 4.0.2.2 (Build id: 4c82dcdd6efcd48b1d8bba66bfe1989deee49c3).

1) Do you have any extensions installed?
2) Is this crash still reproducible after a user profile reset (guide: https://wiki.documentfoundation.org/UserProfile#Resetting_the_user_profile)?

If reproducible, please try to do a backtrace (guide: https://wiki.documentfoundation.org/BugReport#How_to_get_a_backtrace_on_Linux) so we have a bit more information about the crash.

Thanks in advance,
Joren
Comment 2 andis.lazdins 2013-04-08 05:58:48 UTC
(In reply to comment #1)
> Hi,
>
> 1) Do you have any extensions installed?

Yes, it seems that Libreoffice 4.0 imports extensions installed on a Libreoffice 3.6. There are quite many of extensions related to calc. Some of them, like remove duplicates and solvit could not be installed on libreoffice 4.0

> 2) Is this crash still reproducible after a user profile reset (guide:
> https://wiki.documentfoundation.org/UserProfile#Resetting_the_user_profile)?
> 

When I removed existing profile of libreoofice 4.0, the new profile contained all of extensions installed on the libreoffice 3.6, some of the didn't work (remove duplicates from those related to calc). When I tried to open existing calc files with new profile, the most of them didn't opened at all. In some cases I got permanent response that document is loading, in some cases it ended with "Read-Error. An unknown error has occured." Writer documents at the same time loaded fine.

I removed all of the extensions related to calc and the problem disappeared. I also changed locale settings to the same that I had in Lilbreoffice 3.6. I'll try to add the extensions to see, if the problem will appear again.

> If reproducible, please try to do a backtrace (guide:
> https://wiki.documentfoundation.org/
> BugReport#How_to_get_a_backtrace_on_Linux) so we have a bit more information
> about the crash.
> 
> Thanks in advance,
> Joren
Comment 3 andis.lazdins 2013-04-08 06:36:45 UTC
Unfortunately I was not able to check, which extension could be a reason of the problem. When I tried to reinstall extensions on Libreoffice 4.0, I got error responses for the most of them. The list of extensions and error messages follows below. However, now I don't have any problems with entering formulas. So this error is gone, but switching to version 4.0 would lead to loosing of some very useful extensions.

I tried to switch between java 1.7 and 1.8 during installation, but without any effect.

java.lang.reflect.InvocationTargetException

CorelPolyGUI

(com.sun.star.uno.RuntimeException) { { Message = "<class 'TabError'>: inconsistent use of tabs and spaces in indentation (Duplicates.py, line 67), traceback follows\X000a  /opt/libreoffice4.0/program/pythonloader.py:102 in function getModuleFromUrl() [codeobject = compile( src, encfile(filename), \"exec\" )]\X000a  /opt/libreoffice4.0/program/pythonloader.py:149 in function writeRegistryInfo() [mod = self.getModuleFromUrl( locationUrl )]\X000a\X000a", Context = (com.sun.star.uno.XInterface) @0 } }

RemoveOOoDuplicates

loading component library failed: file:///home/****/.config/libreoffice/4/user/uno_packages/cache/uno_packages/lusg0rzw.tmp_/ROOo.oxt/Linux_x86/ROOo.uno.so

ROOo

java.lang.reflect.InvocationTargetException

SLAMLib

java.lang.reflect.InvocationTargetException

Solvit

java.lang.reflect.InvocationTargetException

StatisticalDataAnalyzerForOOCalc

java.lang.reflect.InvocationTargetException

Validator

java.lang.reflect.InvocationTargetException

Readability report
Comment 4 Julien Nabet 2013-04-08 21:49:07 UTC
Andis/Jorendc: it seems a dup of fdo#62155, see "See also". Michael pushed a quick fix on master and 4.0 branch. So it should be ok from 4.0.3.

Michael:  Even if it's surely a dup, perhaps the traces given comment 3 may interest you.
Comment 5 Jorendc 2013-04-08 21:59:33 UTC
(In reply to comment #4)
> Andis/Jorendc: it seems a dup of fdo#62155, see "See also". Michael pushed a
> quick fix on master and 4.0 branch. So it should be ok from 4.0.3.
> 
> Michael:  Even if it's surely a dup, perhaps the traces given comment 3 may
> interest you.

Thanks for narrowing down Julien! Lets mark it as such then.
@Bug reporter: please REOPEN this bug if this is still reproducible using mentioned version LibreOffice 4.0.3.

Kind regards,
Joren

*** This bug has been marked as a duplicate of bug 62155 ***
Comment 6 Michael Meeks 2013-04-09 09:36:35 UTC
Andis - wow thanks for the great report.

I'm pretty amazed that there is -such- compound failure of Java extensions with LibreOffice 4.0 - they -should- all be compatible.

I can only assume there is some horrific upgrade / re-registration issue. Can you confirm that none of these extensions work in 4.0 if you install them by themselves ?

Stephan - seems like something pretty serious here; any ideas ?

Un-marking, re-opening and switching the focus to the extension failures which ( I guess ) are the other primary cause of this embarassing bug.

Thanks for the report.
Comment 7 andis.lazdins 2013-04-09 10:34:45 UTC
(In reply to comment #6)
> Andis - wow thanks for the great report.
> 
> I'm pretty amazed that there is -such- compound failure of Java extensions
> with LibreOffice 4.0 - they -should- all be compatible.
> 
Hello!

It seems that the problem is in profile upgrade from version 3.6.5 to 4.0. I tried to use separate installation of Libreoffice 4.0. 
[Bootstrap]
UserInstallation=$ORIGIN/..

No problems appeared with installation of all above mentioned extensions in separate installation of the Libreoffice 4.0. In other words, most probably it is rather specific problem related to upgrade. I used several pre-releases between 3.6.5 and 4.0.2 therefore it is very hard to say, when this problem appeared.
Comment 8 andis.lazdins 2013-04-09 11:54:40 UTC
I solved this problem for myself  by making new profile for libreoffice 4.0 installation. Order of activities:
Close libreoffice 3.6 and 4.0
Rename libreoffice 3.6 profile form /3 to /3bkp
Delete libreoffice 4.0 profile
Start libreoffice 4.0 and reinstall all extensions
Rename libreoffice 3.6 profile to /3
Start libreoffice 3.6 with all extensions in place

The most of extensions are working now. The only exceptions still not working are:
RemoveOOoDuplicates
(com.sun.star.uno.RuntimeException) { { Message = "<class 'TabError'>: inconsistent use of tabs and spaces in indentation (Duplicates.py, line 67), traceback follows\X000a  /opt/libreoffice4.0/program/pythonloader.py:102 in function getModuleFromUrl() [codeobject = compile( src, encfile(filename), \"exec\" )]\X000a  /opt/libreoffice4.0/program/pythonloader.py:149 in function writeRegistryInfo() [mod = self.getModuleFromUrl( locationUrl )]\X000a\X000a", Context = (com.sun.star.uno.XInterface) @0 } }

ROOo
loading component library failed: file:///home/****/.config/libreoffice/4/user/uno_packages/cache/uno_packages/luu6n8qd.tmp_/ROOo.oxt/Linux_x86/ROOo.uno.so

Now I have nicely working 3.6 and 4.0 installations :)
Comment 9 Stephan Bergmann 2013-04-09 12:09:58 UTC
(In reply to comment #8)
> RemoveOOoDuplicates
> (com.sun.star.uno.RuntimeException) { { Message = "<class 'TabError'>:
> inconsistent use of tabs and spaces in indentation (Duplicates.py, line 67),
> traceback follows\X000a  /opt/libreoffice4.0/program/pythonloader.py:102 in
> function getModuleFromUrl() [codeobject = compile( src, encfile(filename),
> \"exec\" )]\X000a  /opt/libreoffice4.0/program/pythonloader.py:149 in
> function writeRegistryInfo() [mod = self.getModuleFromUrl( locationUrl
> )]\X000a\X000a", Context = (com.sun.star.uno.XInterface) @0 } }

Python 3 is more picky about tabs and spaces in source code than Python 2, that's why the above starts to become a problem with LibreOffice 4.  You should report that with the authors of that extension---they can probably clean it up so that it works fine with both Python 2 and 3.

> ROOo
> loading component library failed:
> file:///home/****/.config/libreoffice/4/user/uno_packages/cache/uno_packages/
> luu6n8qd.tmp_/ROOo.oxt/Linux_x86/ROOo.uno.so

Hard to tell anything about the above without having access to that extension.  Do you have a link, in case it is freely available?
Comment 10 andis.lazdins 2013-04-09 12:57:06 UTC
(In reply to comment #9)

> 
> > ROOo
> > loading component library failed:
> > file:///home/****/.config/libreoffice/4/user/uno_packages/cache/uno_packages/
> > luu6n8qd.tmp_/ROOo.oxt/Linux_x86/ROOo.uno.so
> 
> Hard to tell anything about the above without having access to that
> extension.  Do you have a link, in case it is freely available?

http://rcom.univie.ac.at/download.html#ROOo

It's not updated for 3 years, so I'm not sure if anybody is taking care for the code.

I'll contact authors of Duplicates finder.
Comment 11 Stephan Bergmann 2013-04-09 14:47:36 UTC
(In reply to comment #10)
> > > ROOo
> > > loading component library failed:
> > > file:///home/****/.config/libreoffice/4/user/uno_packages/cache/uno_packages/
> > > luu6n8qd.tmp_/ROOo.oxt/Linux_x86/ROOo.uno.so
> > 
> > Hard to tell anything about the above without having access to that
> > extension.  Do you have a link, in case it is freely available?
> 
> http://rcom.univie.ac.at/download.html#ROOo

The contained Linux_x86/ROOo.uno.so and Linux_x86/StatConnector.uno.so depend on libstlport_gcc.so, which has deliberately been dropped from LO 4.0, see <http://lists.freedesktop.org/archives/libreoffice/2012-December/042804.html> "modules removal surprises."

That causes the same problem for this extension as it causes for the German Duden Korrektor extension, see the LO 4.0 release notes at <https://www.libreoffice.org/download/release-notes/> and the potential workaround at <https://wiki.documentfoundation.org/ReleaseNotes/4.0#Duden_Rechtschreibpr.C3.BCfung_.2F_Duden_Korrektor>.

(Note that this affects the extension on both Linux x86 and Windows, and fixing it would require re-building the extension against a LO 4 SDK.)

Closing as NOTOURBUG.
Comment 12 andis.lazdins 2013-04-10 12:08:10 UTC
The problem with crashing libreoffice 4.0 returned today. I used extension texttonumber for spreadsheet with about 7000 records and calc crashed, when I entered "=" in one cell. After recovery Libreoffice crashes all the time, when I enter "=" in any calc file.

Later I'll try to generate new profile, but anyway it is something terrible.
Comment 13 Michael Meeks 2013-04-10 13:31:15 UTC
Wow - that is ridiculous - thanks for filing Andis ! - can you confirm that the 'texttonumber' extension triggers this ? if that is Cor's CT2N extension (is it) then it is written in StarBasic - which can't possibly have any Java or stlport issues with it, but that would point to a more horrible underlying brokenness.

Can you confirm that this is triggered by installing CT2N and goes away when it is removed ? if so we need to look at this again I guess.
Comment 14 andis.lazdins 2013-04-10 14:03:34 UTC
(In reply to comment #13)

> 
> Can you confirm that this is triggered by installing CT2N and goes away when
> it is removed ? if so we need to look at this again I guess.

I'm not sure if it is CT2N, because after removing the particular extension the problem was still there. Removal of extensions did not help at all. Just creation of new profile (renaming before 3.6 profile) makes difference.

But the last extension I used before the crash was CT2N. There is another problem with this extension. When applied to large array (like 7000 records in this case), it cause crash of the program from time to time, I guess because of lack of memory or something like that.
Comment 15 Stephan Bergmann 2013-04-10 16:12:27 UTC
(In reply to comment #12)
> The problem with crashing libreoffice 4.0 returned today. I used extension
> texttonumber for spreadsheet with about 7000 records and calc crashed, when
> I entered "=" in one cell. After recovery Libreoffice crashes all the time,
> when I enter "=" in any calc file.

The best way to help us track down what's really going wrong there is to zip/tar your complete ~/.config/libreoffice directory tree and make it available (either attach it to this issue or mail it to me directly).
Comment 16 andis.lazdins 2013-04-10 19:41:14 UTC
(In reply to comment #15)

> 
> The best way to help us track down what's really going wrong there is to
> zip/tar your complete ~/.config/libreoffice directory tree and make it
> available (either attach it to this issue or mail it to me directly).

Zipped profile (stopped working after installation of all extensions) is uploaded here https://docs.google.com/file/d/0Bxv4jQ_04jXZUkFqM1JtLU55ekE/edit?usp=sharing

I deleted temp and backup information in extensions folder to reduce file size, but it didn't affected functionality.
Comment 17 andis.lazdins 2013-04-11 07:10:58 UTC
This morning I tried to upgrade to 3.6.6.2 to see if the problem appears there as well and the situation was even worse. The program loaded to dashboard, but then crashed as soon as I tried to open any document or create new one. I think 3.6.6.2 imported something from libreoffice 4.0 profile information.

When I went back to 3.6.5.2 with new profile, everything was fine. However it is quite horrible problem.
Comment 18 andis.lazdins 2013-05-03 06:08:34 UTC
The same problem still appears with 4.0.3.2. I'm not sure if this very specific issue or there is just a lack of resources to deal with it, but it is really annoing. It is not possible to migrate to Libreoffice 4.0 keeping current profile and extensions, and even creation of new profile after some time ends with crash.
Probably the source of the problem is locale settings, at least today 4.0.3.2 calc started to crash on "=" or even "-", when I changed locale to Latvian. Next time it started to crash after updating extensions, particularly update of Language tool. Probably locale was just a coincident. When I removed language tool Libreoffice stopped to crash, so probably the reason is at least this extension.
Comment 19 Michael Meeks 2013-05-03 09:34:02 UTC
Wow - this is bad; clearly there is some deep badness there; clearly the earlier we get feedback on the proposed fix - the faster we get a fix that works. I was under the impression that we had fixed this '=' crash in formula entry in bug#62155

Can you get a stack-trace somehow ?
Comment 20 andis.lazdins 2013-05-03 10:07:42 UTC
(In reply to comment #19)

> 
> Can you get a stack-trace somehow ?

After some investigation I found that the problem is specific to LanguageTool extension Version 2.1. If it is installed Libreoffice 4.0 constantly crashes on "=" or "-" If I downgrade LanguageTool to 2.0, no crashes anymore, at least on these signs. So, something bad is done with this extension and there is quite easy solution - use older version.

For me it looks like problem with extension and I think this bug report can be closed.
Comment 21 Julien Nabet 2013-05-03 10:22:10 UTC
andis: thank you Andis for your feedback. I'll put back state to "NOTOURBUG".
It could be interesting your retrieve an attach a backtrace so someone (maybe you?) contact author(s) of LanguageTool.
Comment 22 Michael Meeks 2013-05-03 10:34:20 UTC
Woah - so I'm not that happy about this resolution. LibreOffice should -never- crash, certainly not with a Java plugin like languagetool; and certainly not in calc pressing '=' ;-)

Andis - does LanguageTool work in other ways ? ie. does it do grammar checking elsewhere ?
Comment 23 andis.lazdins 2013-05-03 11:00:29 UTC
(In reply to comment #22)
> 
> Andis - does LanguageTool work in other ways ? ie. does it do grammar
> checking elsewhere ?

I use it for spell/grammer checking in Writer. I don't know, how it is interfering with Calc. I already sent a message to author of the extension.
Comment 24 k.a.miernik 2013-06-09 19:00:20 UTC
I confirm this bug with libreoffice-4.0.3-3 on Arch Linux.

The solution is to completely remove LO installation and manually remove the /usr/lib/libreoffice folder. Apparently the problem arises from some fatal interaction with LO3 leftovers (extensions?). Anyway a new, clean install fixes the issue.
Comment 25 Michael Meeks 2013-06-10 08:52:35 UTC
This is horrible - can we re-open the bug if it is repeatable; we should -never- crash. Upgrading is no excuse for crashing :-) Having to manually remove your profile is no solution.

k.a.miernik - do you have a copy of your old profile ? can you keep that like gold-dust :-) and reproduce this with 4.0.4 ?

http://www.libreoffice.org/download/pre-releases/

If so, can you get a backtrace:

./soffice --backtrace 2>&1 | tee /tmp/foo.log

and attach that ?

Thanks !
Comment 26 k.a.miernik 2013-06-12 00:50:18 UTC
It is not a matter of a user profile. Removing this does not help. The problem was on the system level (/usr/lib/libreoffice was not clean after uninstallation of the LO). I have a backup of the user profile but it does not cause crashes ones I have reinstalled the LO.
Comment 27 Michael Meeks 2013-06-12 10:18:24 UTC
Wow this is bad:

> It is not a matter of a user profile. Removing this does not help. The
> problem was on the system level (/usr/lib/libreoffice was not clean after
> uninstallation of the LO). I have a backup of the user profile but it does
> not cause crashes ones I have reinstalled the LO.

Can you reproduce this and/or attach a list of files left in /usr/lib/libreoffice ?

Were these files leftover from the system installed libreoffice ? The dump of an ls -R /usr/lib/libreoffice would be fine [ perhaps there is/was some mixup there ]. It'd be great to isolate that. We could add some conflicts rules to ensure they are removed I guess.

I thought we installed our generic packages to /opt/libreoffice/ myself - but ... Out of interest what does your system's /etc/ld.so.conf and cat /etc/ld.so.conf.d/* say ? It should not include /usr/lib/libreoffice at all.

Thanks !
Comment 28 Michael Meeks 2013-06-17 11:31:44 UTC
It may well be that fixing bug#65859 (an easy hack) would fix this too.
Comment 29 QA Administrators 2014-02-02 02:07:10 UTC
Dear Bug Submitter,

Please read the entire message before proceeding.

This bug has been in NEEDINFO status with no change for at least 6 months. Please provide the requested information as soon as possible and mark the bug as UNCONFIRMED. Due to regular bug tracker maintenance, if the bug is still in NEEDINFO status with no change in 30 days the QA team will close the bug as INVALID due to lack of needed information.

For more information about our NEEDINFO policy please read the wiki located here: 
https://wiki.documentfoundation.org/QA/FDO/NEEDINFO

If you have already provided the requested information, please mark the bug as UNCONFIRMED so that the QA team knows that the bug is ready to be confirmed.


Thank you for helping us make LibreOffice even better for everyone!


Warm Regards,
QA Team
Comment 30 andis.lazdins 2014-02-02 08:12:33 UTC
Hello!

I'm using Libeoffice in everyday work, so as soon as I find workaround (new profile without problematic extensions), I did it and forget about the problem. I don't have possibility, it the problem persist in following versions and I don't have any more the problematic profile. 
I think creation of new profile and avoiding problematic extensions should be recommended to everybody having this problem.

So, from my point of view bug report can be closed;however, possibility to crash program due to problems in extensions for me seems to be quite serious to consider in future.
Comment 31 Julien Nabet 2014-02-02 10:24:03 UTC
Thank you Andis for your feedback, let's put this to WFM.