Bug 65541 - Missing dependencies among packages of our "generic" Linux instsets (Libreoffice 4.0.4 RC1 systematically segfaults)
Summary: Missing dependencies among packages of our "generic" Linux instsets (Libreoff...
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
4.0.4.1 rc
Hardware: Other Linux (All)
: medium normal
Assignee: Stephan Bergmann
URL:
Whiteboard: BSA target:4.2.0
Keywords:
Depends on:
Blocks:
 
Reported: 2013-06-08 14:53 UTC by sergio.callegari
Modified: 2013-07-08 08:53 UTC (History)
6 users (show)

See Also:
Crash report or crash signature:


Attachments
log file (129.31 KB, text/x-log)
2013-06-08 14:55 UTC, sergio.callegari
Details
output from libreoffice --backtrace (20.81 KB, text/x-log)
2013-06-10 06:43 UTC, sergio.callegari
Details
strace output (304.14 KB, application/x-tar)
2013-06-10 06:44 UTC, sergio.callegari
Details

Note You need to log in before you can comment on or make changes to this bug.
Description sergio.callegari 2013-06-08 14:53:02 UTC
Problem description: 

Steps to reproduce:
1. type libreoffice4.0 at the shell prompt
2. select text document at the new document window
3. see the application crashing

Current behavior:

the application segfaults (immediately on writer, after some time on draw, etc)

Expected behavior:

The application should be usable...
Operating System: Ubuntu
Version: 4.0.4.1 rc
Last worked in: 4.0.3.3 release
Comment 1 sergio.callegari 2013-06-08 14:55:40 UTC
Created attachment 80530 [details]
log file
Comment 2 Joel Madero 2013-06-09 18:05:34 UTC
michael & Bjoern - I can't test this as it seems like the mirrors are down for download but it looks pretty serious - thoughts on next steps?


Although it's not confirmed I am setting it as BLOCKER - HIGHEST so if it is confirmed the priority is correct
Comment 3 Julien Nabet 2013-06-09 18:37:16 UTC
Joel: as you said, it could be a blocker IF it's confirmed (https://wiki.documentfoundation.org/Release_Criteria#Blocker_Bug_Definition), for the moment it's not. Perhaps someone who's got an Ubuntu may confirm (see https://wiki.documentfoundation.org/QA/QA_Team). If installed via dpkg, it could be a dependency problem.

Sergio:
- did you install any LO specific extensions?
- what's your Java version?
- did you try to rename your LO directory profile (see https://wiki.documentfoundation.org/UserProfile)?
- could you try to retrieve a complete backtrace? (see https://wiki.documentfoundation.org/BugReport#How_to_get_a_backtrace_on_Linux)
Comment 4 sergio.callegari 2013-06-10 06:42:40 UTC
Some more details:

1) Installed LibO 4.0.4 RC1 over the previous debs of 4.0.3.3 keeping my working environment (user profile + user extensions), as I usually do to try release candidates. This means that I did not have the LibO debs from the distribution before, but 4.0.3.3 from Libreoffice site.

2) Java is version "1.7.0_21"
OpenJDK Runtime Environment (IcedTea 2.3.9) (7u21-2.3.9-1ubuntu1)
OpenJDK 64-Bit Server VM (build 23.7-b01, mixed mode). 
This was also in the log file attached before:
JRE version: 7.0_21-b02
# Java VM: OpenJDK 64-Bit Server VM (23.7-b01 mixed mode linux-amd64 compressed oops)
# Problematic frame:
# C  [libvclplug_genlo.so+0x36ebe]  SalXLib::CheckTimeout(bool)+0xe

3) I have a couple of extensions: latest languagetool and texmaths. This in addition to the 'standard' extensions shipped with LibO.

4) All LibO modules segfault, but most of them seem to do it only on closing the application (draw, calc). Only write seem to segfault immediately

5) Launching LibO without opening any module (i.e. staying at the window showing buttons to open text document, spreadsheet, presentation, etc. and maybe exploring Add on or options) and then closing does not cause segfault.

6) Chosing a text document, LibO crashes immediately.

7) At first launch of LibO 4.0.4 RC1, after having moved away the current profile, before the window to open LibO modules there is briefly another window a progress bar and writings running over it. This is badly mangled, with the progress bar not being filled, another progress bar appearing halfway through the window and filling, text running over this new progress bar. But maybe this has nothing to do with the current issue.

8) LibO does anyway crash even after having started with an empty profile when opening the text document module.

9) I have a gdbtrace, but I do not know how useful this can be, since it seems not to have symbols resolved. I do not know how to get the equivalent of a -dbg package from the Libreoffice repo.

10) I have a strace.
Comment 5 sergio.callegari 2013-06-10 06:43:11 UTC
Created attachment 80599 [details]
output from libreoffice --backtrace
Comment 6 sergio.callegari 2013-06-10 06:44:08 UTC
Created attachment 80600 [details]
strace output
Comment 7 sergio.callegari 2013-06-10 06:46:12 UTC
Some more details on my hardware too:

1) Intel graphics (gen4)
2) 64bit Ubuntu

Removed 4.0.4 RC1 I went back to 4.0.3.3 that works fine.
Comment 8 Joel Madero 2013-06-10 15:20:39 UTC
Moving back to unconfirmed as Sergio has provided a lot of info
Comment 9 Julien Nabet 2013-06-10 20:45:21 UTC
Sergio: thank you for all these details! I rarely use dpkg so I'm not an expert at all but I would have uninstalled .deb before installing new ones.

Just to complete information, do you reproduce this with 4.1.0 beta2? (you can rename your LO directory profile and therefore make your test with a brand new LO profile).
Comment 10 sergio.callegari 2013-06-12 09:18:31 UTC
I have quickly tested 4.1 beta 2:

1) I do not see the segfault
2) I see the same mangling of the very initial progress bar as in 4.0.4 RC1

I have also tested 4.0.4 RC1 /after completely manually removing 4.0.3/

1) In this way I do not see the segfault
2) There is still some mangling of the very intial progress bar

A note about debs

I have disinstalled all the distribution-provided libreoffice debs before testing, since these are quite different form the debs delivered by libreoffice.org (which is obvious, since libreoffice.org cannot finely control what the distribution does. Moreover, the distribution wants to use all the distribution libs).

However, I am typically installing debs from libreoffice.org over previous debs from libreoffice.org, as this is how debs and dpkg should work (i.e. dpkg should take care automatically of disinstalling the previous debs and installing the new ones). I believe that most people will do this, particularly upgrading between point releases 4.0.3 -> 4.0.4. If this does not work (as it now looks to be the case) there is probably some packaging bug. However, these are certainly not as serious as an application segfaulting on its own.
Comment 11 Michael Meeks 2013-06-12 10:10:56 UTC
> I believe that most people will do this, particularly upgrading between
> point releases 4.0.3 -> 4.0.4. If this does not work (as it now looks to
> be the case) there is probably some packaging bug. However, these
> are certainly not as serious as an application segfaulting on its own.

Well - ideally we would fix the segfault too of course :-) but the stack-trace is ~nonsensical sadly.

If you can reproduce the system state where this crashes on startup - then I'd love to see a package list to see what files / packages are left over from the old packages - quite possibly we need to tweak that somehow.

Can you get it back into that state ?
Comment 12 sergio.callegari 2013-06-12 13:39:17 UTC
I'll try to check removing everything installing 4.0.3 updating to 4.0.4 RC without wiping 4.0.3 and see if the segfaults comes out again. Unfortunately I do not think that I will be able to try it before the weekend.
Comment 13 sergio.callegari 2013-06-17 10:40:37 UTC
I confirm the packaging bug for deb files for ubuntu.

I have:

1) completely uninstalled libreoffice.
2) installed libreoffice 4.0.3 from the provided debs
3) installed libreoffice 4.0.4 RC2 from the provided debs

  during the installation dpkg says that it is removing the 4.0.3 components and installing the corresponsing 4.0.4 ones.

However, with this procedure libreoffice 4.0.4 does not work and segfault

This is because libreoffice4.0-gnome-integration from 4.0.3 remain installed.
Initially, with the great deal of things getting installed, I did not notice it.

For some reason the install of the 4.0.4 gnome-integration in my system fails unless the 4.0.3 gnome integration is manually removed.

So the issue in the end is really minor.
Comment 14 Michael Meeks 2013-06-17 11:29:49 UTC
> For some reason the install of the 4.0.4 gnome-integration in my system
> fails unless the 4.0.3 gnome integration is manually removed.

Ok - that's still bad - we shouldn't have unexpected segfaults [!]

Let me turn this into an easy-hack - which I'll file separately to make that issue cleaner; see bug#65859
Comment 15 Stephan Bergmann 2013-06-18 15:36:31 UTC
Does not make sense to not try to get the missing dependencies described in commeent 13 fixed for our "generic" installation sets downloadable from <http://www.libreoffice.org/download>.
Comment 16 Stephan Bergmann 2013-06-18 15:38:34 UTC
See <https://gerrit.libreoffice.org/#/c/4344/> "Proper EPM %requires dependencies, at least for Linux" for the proposed fix.
Comment 17 Stephan Bergmann 2013-06-18 15:40:57 UTC
[the missing dependencies are not a regression AFAICT; removing the keyword]
Comment 18 Commit Notification 2013-06-24 13:04:30 UTC
Stephan Bergmann committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=d07cbe86f34ca6dfc6580b63879235c339831a5e

fdo#65541: Proper EPM %requires dependencies, at least for Linux



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.