Bug 63430 - FILESAVE: Image captions disappear
Summary: FILESAVE: Image captions disappear
Status: RESOLVED INVALID
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.0.2.2 release
Hardware: Other Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
Depends on:
Blocks:
 
Reported: 2013-04-11 14:49 UTC by miikka.salminen
Modified: 2015-08-28 15:47 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
Image caption invisible (32.21 KB, image/png)
2015-08-27 16:00 UTC, thanasis57
Details
Image caption visible (36.59 KB, image/png)
2015-08-27 16:00 UTC, thanasis57
Details

Note You need to log in before you can comment on or make changes to this bug.
Description miikka.salminen 2013-04-11 14:49:35 UTC
The latest known-working version was some 3.6, can't remember which one.

Problem description:
Captions have disappeared from some of the images in my odt document.

Steps to reproduce:
1. I added images and captions for each image in my document.
2. I saved the document.
3. When I opened the document the next time, I found that captions have disappeared from some of the images I added during the previous time I edited the document, and also from some of the images I have added to the document long time ago.

Current behavior:
Captions disappear from seemingly arbitrary images.

Expected behavior:
Captions don't disappear.
Operating System: Windows 7
Version: 4.0.2.2 release
Comment 1 miikka.salminen 2013-04-11 15:31:36 UTC
I tried moving the images, whose captions were gone, and found out that the missing captions were behind the images. Also, looking at the caption property of either the image or its surrounding frame yielded no caption for the image, even though the text was there - right under the image at the bottom of the surrounding box.
Comment 2 Joel Madero 2013-04-11 17:01:13 UTC
So with a fresh document I cannot confirm with 4.0.1.2 with the given instructions but "save the document" - what format did you save in?

Please attach a document that has this behavior so we can look at the xml data.

Marking as NEEDINFO, once you attach document and answer the question that I posed, mark as UNCONFIRMED and we will look into it. Thanks!
Comment 3 stragu 2013-06-05 04:35:41 UTC
Same problem here.
I am writing a report of 20+ pages and it often happens, I always save in default ODT format but every so often I have to move a picture to make its caption reappear.

But it gets more complicated: as I see a caption missing from one frame, I can also not touch anything and just scroll through the document, and some frames jump from one position to another, sometimes even overlapping, the gets a bit messy with all this moving around, and going back to the missing captions, they somehow reappear and stay where they were supposed to be. All this just by scrolling through the document...

I am using 4.0.3.3 on Ubuntu 13.04 (64 bits).

I'll let you know if I can get a document together where it is reproducible (not comfortable sharing my consultancy report :) ) or if I can add to the bug description.
Comment 4 QA Administrators 2014-02-02 02:06:55 UTC
Dear Bug Submitter,

Please read the entire message before proceeding.

This bug has been in NEEDINFO status with no change for at least 6 months. Please provide the requested information as soon as possible and mark the bug as UNCONFIRMED. Due to regular bug tracker maintenance, if the bug is still in NEEDINFO status with no change in 30 days the QA team will close the bug as INVALID due to lack of needed information.

For more information about our NEEDINFO policy please read the wiki located here: 
https://wiki.documentfoundation.org/QA/FDO/NEEDINFO

If you have already provided the requested information, please mark the bug as UNCONFIRMED so that the QA team knows that the bug is ready to be confirmed.


Thank you for helping us make LibreOffice even better for everyone!


Warm Regards,
QA Team
Comment 5 stragu 2014-02-02 13:48:40 UTC
Hi there

I have tried to reprduce this with 4.1.5 to no avail, so I am not sure if this issue still exists.

Cheers
Comment 6 QA Administrators 2014-02-26 19:31:26 UTC
Dear Bug Submitter,

Please read this message in its entirety before proceeding.

Your bug report is being closed as INVALID due to inactivity and a lack of information which is needed in order to accurately reproduce and confirm the problem. We encourage you to retest your bug against the latest release. If the issue is still present in the latest stable release, we need the following information (please ignore any that you've already provided):

a) Provide details of your system including your operating system and the latest version of LibreOffice that you have confirmed the bug to be present

b) Provide easy to reproduce steps – the simpler the better

c) Provide any test case(s) which will help us confirm the problem

d) Provide screenshots of the problem if you think it might help

e) Read all comments and provide any requested information

Once all of this is done, please set the bug back to UNCONFIRMED and we will attempt to reproduce the issue. 
Please do not:
a) respond via email 
b) update the version field in the bug or any of the other details on the top section of FDO
Comment 7 thanasis57 2015-08-27 16:00:15 UTC
Created attachment 118226 [details]
Image caption invisible
Comment 8 thanasis57 2015-08-27 16:00:58 UTC
Created attachment 118227 [details]
Image caption visible
Comment 9 thanasis57 2015-08-27 16:01:14 UTC
In LibO 5.0.0.5 I confirm this behaviour (see screenshots).

Steps to reproduce:
-Insert image from file
-Insert caption (frame is automatically created).
-Edit caption as needed.
-Re-open file (caption is invisible)
-Click on image and move it around (the caption re-appears)
-After working on the document the caption re-disappears (randomly)

The document I am working on is 700 pages and under publication, so I cannot submit it per se. I can, however, post two screenshots, one before and one after moving the image around.
Comment 10 Joel Madero 2015-08-27 16:39:06 UTC
So this bug was closed as INVALID - please report a new bug and we NEED (absolutely need) a test document. If your current file is confidential - please create a new (simple) test document that demonstrates the issue. Our QA team is small and we can't be responsible for making tens of thousands of test cases...thanks for understanding
Comment 11 thanasis57 2015-08-28 15:47:46 UTC
I absolutely understand and tried to make a test file.

For the moment I could not reproduce it with a test file I created with 5.0.0.5. At the same time I could read the document correctly on 4.3.0.4 (on a Win7 VM), so I have a hunch that this is a regression.

The frustrating thing is that I don't know which aspect of the document creates the problem, as it is quite complex (~700 pages, ~800 footnotes, ~1000 Zotero bibliography entries, numerous cross-references etc). So building a simple document from the bottom up does not reproduce the problem.

If I manage to reproduce it I will most definitely upload the test file. Until then I believe I will downgrade to 4.3 or 4.4.