Bug Hunting Session
Bug 93461 - Caption of images are hidden behind the image
Summary: Caption of images are hidden behind the image
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
5.0.0.5 release
Hardware: Other All
: medium normal
Assignee: Caolán McNamara
URL:
Whiteboard: target:5.1.0 target:5.0.3 target:5.0.4
Keywords: bibisected, regression
: 93943 (view as bug list)
Depends on:
Blocks: Matters-to-Caolan
  Show dependency treegraph
 
Reported: 2015-08-16 08:58 UTC by Robert Großkopf
Modified: 2016-10-25 19:20 UTC (History)
9 users (show)

See Also:
Crash report or crash signature:


Attachments
The image captions disappear (or are hidden) images following tables (page 7+) (25.15 KB, application/vnd.oasis.opendocument.text)
2015-09-15 07:55 UTC, Stefan
Details
Screenshot LO 5.0.1 (Ubuntu 15.10) showing caption bug. (159.46 KB, image/png)
2015-09-23 20:25 UTC, Stefan Glasenhardt
Details
private odt file with image problem (4.16 MB, application/vnd.oasis.opendocument.text)
2015-09-24 15:41 UTC, Pawel
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Robert Großkopf 2015-08-16 08:58:18 UTC
Seems this bug is a rebirthing of this one: https://bugs.documentfoundation.org/show_bug.cgi?id=78149

I have tried to edit new Base-Handbook with LO 5.0.0.5. Seems all captions of images are hidden behind the image in the German document. When editing the English document and changing an image the caption will also be behind the image. A little bit dragging of the caption-frame with the mouse will show the description for the image where it should be.

Try this example:
https://wiki.documentfoundation.org/images/e/ea/Base_03_Tabellen_V50.odt

First with all versions before 5.*:
Open the example and scroll to page 5.
There is a caption under the big image.
Same on page 6 and so on.

Do the same with LO 5.0.0.5 (OpenSUSE 13.2, 64bit rpm Linux):
No caption under the images.
Drag the frame for the caption a little bit.
Caption will appear.
Comment 1 Jan Bart 2015-08-28 06:21:30 UTC
Captions disappear when a sub-document is embedded in a master-document and a PDF is generated from the master-doc.
But a PDF created from the sub-document alone shows the figure captions.
This happens in LO 5.0.0.5 win7 and xubuntu version.

The same setup in 4.0.5 works beautifully (i do not use newer versions due to other issues with templates (https://bugs.documentfoundation.org/show_bug.cgi?id=93421)
Comment 2 thanasis57 2015-08-28 15:41:53 UTC
With the same version on Ubuntu 12.04 64 bit, I "unfortunately" can read the captions correctly.

I have been having the exact same problem with another document (~700 pages) of mine with version 5.0.0.5 (cannot see them or print them to pdf). Testing the exact same document with version 4.3.0.4 (on a Win7 VM) the captions read correctly.

I tried making a test file but could not reproduce it. Very frustrating!
Comment 3 Cor Nouws 2015-09-05 18:54:11 UTC
*** Bug 93943 has been marked as a duplicate of this bug. ***
Comment 4 Timur 2015-09-08 15:14:10 UTC
I couldn't reproduce Windows/Mint. I can read the captions "Abbildung".
Comment 5 Rolf S 2015-09-10 19:12:39 UTC
The first caption is showing normally, but have you see for example the "Abbildung 10". 

I've got LO document with 600 pages and the first caption is normally. But all after in the most cases are not visible.
Comment 6 Stefan 2015-09-15 07:55:27 UTC
Created attachment 118728 [details]
The image captions disappear (or are hidden) images following tables (page 7+)

Maybe this SERIOUS(!) Bug is connected with table-updates or something.
If you delete the tables (especially the ones with multiline-fields), the captions are rendered normally.

This Bug makes LO unusable for documents with images and tables.

P.S. If i open this example, LO renders crap for the first page (like  failing to update the canvas). After i "move" the canvas, this crap will dissapear.
Comment 7 Stefan 2015-09-15 08:04:31 UTC
Can't reproduce this bug with Roberts file from 2015-08-16 08:58:18 UTC and LO 5.0.1.2.

Please check out my example !
Comment 8 Dominik Kopp 2015-09-20 21:02:15 UTC
I can confirm Roberts test file from comment#1
Doing a "print preview" could help sometimes.

But in my master thesis with tens of captions it makes only some of the captions visible.

I'm using LO 5.0.1.2 (opensuse tumbleweed 64-bit).
Comment 9 thanasis57 2015-09-20 21:14:01 UTC
(In reply to Dominik Kopp from comment #8)
> I can confirm Roberts test file from comment#1
> Doing a "print preview" could help sometimes.
> 
> But in my master thesis with tens of captions it makes only some of the
> captions visible.
> 
> I'm using LO 5.0.1.2 (opensuse tumbleweed 64-bit).

In my case, captions were invisible even in the print preview.
Comment 10 Dr. David Alan Gilbert 2015-09-21 09:45:28 UTC
I have a similar problem on an internal document; it works fine on a colleagues 4.4.5, but on Fedora 5.0.0.5, on upstream 5.0.2.2 or on last nights dev build, the captions are hidden.  They reappear if you do a send-backwards on the figure, but then disappear again if you export as PDF
Comment 11 Stefan Glasenhardt 2015-09-23 20:25:21 UTC
Created attachment 118978 [details]
Screenshot LO 5.0.1 (Ubuntu 15.10) showing caption bug.
Comment 12 Stefan Glasenhardt 2015-09-23 20:26:17 UTC
I've added another screenshot which clearly shows the mentioned bug. It still persists in LO 5.0.2 (Tested it 5min ago with the latest Vanilla version).
Comment 13 Pawel 2015-09-24 12:41:56 UTC
In company we (40 users!) also have problem with image caption.

For me it seems that LibreOffice5 thinks that image doesn't have caption (right click, it allows to add caption and don't have possiblity to edit caption).

After clicking F9 (refreshing) images shows.
The best results as far I've got when I zoomed out document, clicked F9 and export it to pdf.

In bigger documents, I have to export few pages and join multiple pdf's in one after that.

For us importance of the problem should be critical. We cannot work on version 5 and above.
Comment 14 thanasis57 2015-09-24 13:33:55 UTC
With regard to Pawel's and other users' comments, and from my experience, I read, I get the impression that the problem impacts bigger, heavier and more complex documents.

Maybe that is why it is so difficult to produce a test document from scratch, precisely because it will be much lighter with less features.
Comment 15 Stefan 2015-09-24 13:39:15 UTC
This bug makes LO unusable for "professional use". ("pictures!, captions!")
Comment 16 Pawel 2015-09-24 15:41:29 UTC
Created attachment 118995 [details]
private odt file with image problem
Comment 17 Pawel 2015-09-24 15:42:14 UTC
Hello,
I've attached file with such problem.
Hopefully someone could investigate it further with that file.
Comment 18 Cor Nouws 2015-09-24 19:03:38 UTC
(In reply to Stefan from comment #15)
> This bug makes LO unusable for "professional use". ("pictures!, captions!")

Useless comment if you read the release notes.
Comment 19 Stefan 2015-09-24 22:01:33 UTC
Not useless for priorizing:

https://wiki.documentfoundation.org/images/0/06/Prioritizing_Bugs_Flowchart.jpg
Comment 20 Caolán McNamara 2015-09-28 10:47:50 UTC
bibisect says...


commit 774257d6708ea059c108ac2831a583dafc385370
Author: Markus Mohrhard <markus.mohrhard@googlemail.com>
Date:   Sat May 2 20:36:30 2015 +0200

    it works if we first set the size and then the position, tdf#86624
    
    Change-Id: I8ed98981ef3041839ab73b749a04febe369f66fe
Comment 21 Caolán McNamara 2015-09-28 11:23:06 UTC
grrr, no that's not right. Seems to be a variable thing, works some loads and not others.
Comment 22 Caolán McNamara 2015-09-28 12:06:22 UTC
More careful multiple-testing of the "ok" path suggests a better source as...

commit 8a08f68669f9acfe98dadcca4af6519164a17000
Author: Mike <mikekaganski@hotmail.com>
Date:   Mon Apr 27 01:27:05 2015 +1000

    tdf#66141: SwTxtFrm::FormatQuick(bool) endless loop
    
    If a line happens to be invisible (e.g. in too thin cell of a table)
    then aLine.FormatLine(nStart) returns nStart, and
    aLine.Insert( new SwLineLayout() ) is executed until OOM.
Comment 23 Commit Notification 2015-09-28 12:32:01 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=f06508e2cfa7e833862b7e9ff3b2f79181672275

Resolves: tdf#93461 captions laid out behind images

It will be available in 5.1.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 24 Commit Notification 2015-09-29 20:08:34 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=e0e2cc7ca6d498b3e696bbc306d3f1e403ebf27d

Related: tdf#93461 relax loop detection some more

It will be available in 5.1.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 25 Commit Notification 2015-10-02 14:32:06 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=a6e6eb8b37ba431df575be4799114bb821f54b0d

Related: tdf#93461 relax loop detection some more

It will be available in 5.1.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 26 Commit Notification 2015-10-05 08:00:12 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "libreoffice-5-0":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=dabd6add51783f7b9fed502873dfa71beb936e96&h=libreoffice-5-0

Resolves: tdf#93461 captions laid out behind images

It will be available in 5.0.3.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 27 Commit Notification 2015-10-08 12:54:28 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "libreoffice-5-0":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=e450bd6ebde3892850c5fcf5590122a2f10ac8ae&h=libreoffice-5-0

Related: tdf#93461 relax loop detection some more

It will be available in 5.0.4.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 28 Helmut 2015-10-18 18:48:14 UTC
(In reply to Commit Notification from comment #25)
> Caolán McNamara committed a patch related to this issue.
> It has been pushed to "master":
> 

Tested version 
master~2015-10-18_04.55.50_LibreOfficeDev_5.1.0.0.alpha1_Win_x86_en-US_de_ar_ja_ru_qtz

with a known to fail document 
  96       pages
  686      paragraph
  116 733  character with blanks
  84       pictures with a total of 65 MByte
     nealy 85 MB of size
and other test documents

The problem did not appear anymore

Thank you very much for the fix
Comment 29 Robinson Tryon (qubit) 2015-12-17 10:31:11 UTC Comment hidden (obsolete)