Bug 63567 - EDITING: no spellcheck suggestions for typos in comments
Summary: EDITING: no spellcheck suggestions for typos in comments
Status: NEW
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: Other All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
Depends on:
Blocks: Spell-Checking Calc-Comments
  Show dependency treegraph
 
Reported: 2013-04-15 19:36 UTC by Jean-Baptiste Faure
Modified: 2019-01-05 12:52 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jean-Baptiste Faure 2013-04-15 19:36:58 UTC
Steps to reproduce:
1. open a new spreadsheet and activate spellchecking during typing
2. select a cell and hit ctrl+alt+C to insert a comment
3. type something with a typo in the comment field
4. click outside the comment field to validate
5. select the cell with the comment: the typo becomes red underlined
6. right click on the typo

Current behavior: no suggestion done

Expected behavior: several suggestions done to correct the typo, as it works when the erroneous word is in a cell

Spellcheck in comments works as expected in Writer.

Bug found in version 3.6.5 and 4.0.3.0+

Best regards. JBF

              
Operating System: All
Version: 3.6.5.2 release
Comment 1 tommy27 2013-04-21 09:46:20 UTC
has it ever worked in OOo/LibO ?

I tried on an old OpenOffice 3.1.1 release and spellcheck suggestion are not offered in spreadsheet comments... right clicking on typos do not show any correction suggestion.

I think that this features was never present and has been inherited from OOo.

so setting as NEW and changing the release version to first ever LibO version
Comment 2 dE 2014-09-07 09:25:55 UTC
So this's an enhancement.
Comment 3 QA Administrators 2015-10-14 19:56:39 UTC Comment hidden (obsolete)
Comment 4 tommy27 2015-10-14 20:59:28 UTC
still reproducible with LibO 5.1.0.0.alpha1+
Build ID: f830600ece806ec365a4839e79afabe183c5e36d
TinderBox: Win-x86@62-merge-TDF, Branch:MASTER, Time: 2015-10-06_22:49:09
Locale: it-IT (it_IT)
Comment 5 QA Administrators 2016-11-08 11:09:20 UTC Comment hidden (obsolete)
Comment 6 Jean-Baptiste Faure 2016-11-11 09:07:57 UTC
Still reproducible in LO 5.2.3 and current master built at home under Ubuntu 16.10 x86-64.

Best regards. JBF
Comment 7 QA Administrators 2017-11-30 06:27:44 UTC Comment hidden (obsolete)
Comment 8 tommy27 2017-12-01 05:43:55 UTC
bug still present in LibO 5.4.3.2
Comment 9 QA Administrators 2018-12-03 03:59:47 UTC Comment hidden (obsolete)
Comment 10 Jean-Baptiste Faure 2019-01-05 12:52:01 UTC
Still reproducible with LO 6.2.0.1.0+ built at home under Ubuntu 18.04 x86-64.

Best regards. JBF