Download it now!
Bug 63618 - Huge text boxes
Summary: Huge text boxes
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
4.1.0.0.alpha0+ Master
Hardware: Other Mac OS X (All)
: medium normal
Assignee: Caolán McNamara
URL:
Whiteboard: target:4.1.1
Keywords:
: 67077 (view as bug list)
Depends on:
Blocks:
 
Reported: 2013-04-17 00:48 UTC by Emir Sarı
Modified: 2013-08-08 22:44 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
Preferences window (153.39 KB, image/png)
2013-04-17 00:48 UTC, Emir Sarı
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Emir Sarı 2013-04-17 00:48:58 UTC
Created attachment 78118 [details]
Preferences window

Hello,

Textboxes in the latest 64-bit master build is huge, compared to the default font size. 

And also there is a weird behaviour, text alignment jumps from left to right, then returns to left eventually. 

Screenshot attached. 

Version: 4.1.0.0.alpha0+
Build ID: 092bc9b54c5b091d517315b61cbc0aa53d12737
Comment 1 Jorendc 2013-04-17 09:59:03 UTC
Yes, I can reproduce this using Mac OSX 10.8.3 and LibreOffice Version: 4.1.0.0.alpha0+ Build ID: 7fbea4712774467fcf7edf535905f02c586ccfe

When I enter for example my name, the cursor is jumping in the field box. I can type correctly, but when I type the 3 first characters for example, my cursor jumps for a while to the front, until I type the next character (and then jumps to somewhere else in the field box).

Can not reproduce this behavior using LibreOffice Version 4.0.2.2 (Build ID: 4c82dcdd6efcd48b1d8bba66bfe1989deee49c3)
TinderBox: MacOSX TDF Release, Branch:libreoffice-4-0, Time: 2013-03-26_15:52:16

Kind regards,
Joren
Comment 2 Jorendc 2013-05-21 19:08:21 UTC
The behavior is "a bit less weird". Now the text don't jump inside the text field, but only the cursor is shown before the last character (although you can type *behind* it)... so maybe there is just a "-1" error somewhere.

Tested using Mac OSX 10.8.3 with own build: Version: 4.1.0.0.alpha1+
Build ID: 43c234b0481fe63b8c4823affad066c6362f506

Kind regards,
Joren
Comment 3 Emir Sarı 2013-07-24 12:41:32 UTC
*** Bug 67077 has been marked as a duplicate of this bug. ***
Comment 4 Caolán McNamara 2013-07-25 12:52:54 UTC
Two reported problems here. The first about huge heights is fixed with http://cgit.freedesktop.org/libreoffice/core/commit/?id=0fcf74d203d97b7e829e72b7e55782d86a048802

Dunno what the second is all about, but I suggest splitting that off from this as a different problem and I'll take this one as the id for backporting the huge height fix to 4.1
Comment 5 Commit Notification 2013-07-25 13:29:20 UTC
Caolan McNamara committed a patch related to this issue.
It has been pushed to "libreoffice-4-1":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=74a3450b6d681b9ca0fa3e4d01522bfd4269ab5e&h=libreoffice-4-1

Resolves: fdo#63618 don't include border size twice in edit optimal size


It will be available in LibreOffice 4.1.1.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 6 Caolán McNamara 2013-07-25 13:52:01 UTC
That should make it look much better.
Comment 7 Frantisek Erben 2013-08-08 22:44:45 UTC
Much better :-)

Verified in:
Version: 4.1.1.1
Build ID: a990db030b8125868501634ff662be1d89d086
OS X 10.8.4