Bug Hunting Session
Bug 63641 - REPORTBUILDER: Text properties in report
Summary: REPORTBUILDER: Text properties in report
Status: RESOLVED DUPLICATE of bug 62147
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Base (show other bugs)
Version:
(earliest affected)
4.0.2.2 release
Hardware: Other Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
Depends on:
Blocks:
 
Reported: 2013-04-17 12:04 UTC by vpupkinmaps
Modified: 2013-04-17 19:13 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description vpupkinmaps 2013-04-17 12:04:10 UTC
Problem description: Properties of text fields does not work. For example, I have a Calc document from where Database take the information. I created report where I want to see this fields from Calc. I set it properties for my report and there is a text and number, so with numbers everything works fine, but with text there no formatting at all.  

Steps to reproduce:
1. Create or import any existing report where text fields will be loaded from Calc
2. Right click on report and select "Edit"
3. Click on text field where must be loaded exactly TEXT, not numbers. 
4. In properties change Horz.Alignment to "Right" (or you can choose any of field from properties, because none of them did not work, exactly with TEXT)
5. Save it
6. Open the report and you will see that properties of text fields, where must be text does not work. It will shows Horz.Alignment set it to "Left" and font is set it like as default in LibreOffice Writer "Time New Roman" and font will be default, not like you set it in properties. 

Also like I say with numbers everything is fine. 

Current behavior:
Like it is

Expected behavior:
properties of text fields must work like user set it in report. 
              
Operating System: Ubuntu
Version: 4.0.2.2 release
Comment 1 Rainer Bielefeld Retired 2013-04-17 13:59:21 UTC
Looks related to or DUP of "Bug 63623 - REPORTBUILDER: font FORMATTING changes will not appear in the dynamic report output file"
Comment 2 Robert Großkopf 2013-04-17 19:13:31 UTC
It's a duplicate of https://bugs.freedesktop.org/show_bug.cgi?id=62147. The title of this report is misleading for people, who will report a bug. It has been changed by a person, who would give a hint for developers with this.
The bug will be fixed in LO 4.0.3.

*** This bug has been marked as a duplicate of bug 62147 ***